removed community/maven

This commit is contained in:
Kevin Mihelich 2017-04-10 12:35:31 +00:00
parent c03e11f7a3
commit 4059fdcbb7
4 changed files with 0 additions and 67 deletions

View file

@ -1,3 +0,0 @@
2007-06-29 tardo <tardo@nagi-fanboi.net>
* Built for x86_64
* Not sure if the binary will work.. but lets try anyway

View file

@ -1,47 +0,0 @@
# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to increase build timeout
pkgname=maven
pkgver=3.3.9
pkgrel=1
pkgdesc="A Java project management and project comprehension tool"
arch=('any')
url="http://maven.apache.org"
license=('APACHE')
depends=('java-environment')
makedepends=('apache-ant')
backup=('opt/maven/conf/settings.xml')
source=(http://apache-mirror.rbc.ru/pub/apache/maven/maven-3/$pkgver/source/apache-maven-$pkgver-src.tar.gz
maven.sh
timeout.patch)
md5sums=('030ce5b3d369f01aca6249b694d4ce03'
'5ed0bddbf5c5375fe5032a76a9506426'
'b44156dc845e23c220a99bf0e110ff48')
package() {
cd $srcdir/apache-maven-$pkgver
patch -p1 -i ../timeout.patch
. /etc/profile.d/jre.sh
# . /etc/profile.d/jdk.sh
mkdir -p $srcdir/repo
mkdir $pkgdir/opt
export MAVEN_OPTS=-Xmx512m
export M2_HOME=$pkgdir/opt/maven
export PATH=$PATH:$M2_HOME/bin
# FIXME: downloads many deps from Internet. Probably they should be
# packaged or added into source=()
ant -Dmaven.repo.local=$srcdir/repo
install -D -m 755 $srcdir/maven.sh $pkgdir/etc/profile.d/maven.sh
rm $pkgdir/opt/maven/*.txt
mkdir -p $pkgdir/usr/bin
ln -s /opt/maven/bin/mvn $pkgdir/usr/bin/mvn
ln -s /opt/maven/bin/mvnDebug $pkgdir/usr/bin/mvnDebug
}

View file

@ -1,5 +0,0 @@
#!/bin/bash
export MAVEN_OPTS=-Xmx512m
#export M2_HOME=/opt/maven
#export PATH=$PATH:$M2_HOME/bin

View file

@ -1,12 +0,0 @@
diff -urN a/build.xml b/build.xml
--- a/build.xml 2015-03-13 14:08:21.000000000 -0600
+++ b/build.xml 2015-03-18 10:47:44.169521550 -0600
@@ -251,7 +251,7 @@
</target>
<target name="maven-compile" depends="compile-boot,process-classes" description="compiles Maven using the bootstrap Maven, skipping automated tests">
- <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="600000" maxmemory="${maven-compile.maxmemory}">
+ <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="6000000" maxmemory="${maven-compile.maxmemory}">
<!--jvmarg line="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=8000"/-->
<!--jvmarg value="${maven-compile.jvmargs}"/-->
<classpath refid="maven.classpath" />