mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/tarantool to 2.1.1.r193-1
This commit is contained in:
parent
54c18bc235
commit
4071ab025a
2 changed files with 5 additions and 55 deletions
|
@ -6,9 +6,9 @@
|
|||
buildarch=12
|
||||
|
||||
pkgname=tarantool
|
||||
_commit=9a543202c93ef903b07b293463650d78002ae866
|
||||
pkgver=2.0.4.r497
|
||||
pkgrel=4
|
||||
_commit=dbbd93171374323cef95e2bcde9767bca77143b2
|
||||
pkgver=2.1.1.r193
|
||||
pkgrel=1
|
||||
pkgdesc='Lua application server integrated with a database management system'
|
||||
arch=(x86_64)
|
||||
url='https://www.tarantool.org'
|
||||
|
@ -25,7 +25,6 @@ source=(git+https://github.com/tarantool/tarantool.git#commit=$_commit
|
|||
git+https://github.com/tarantool/small.git
|
||||
git+https://github.com/tarantool/zstd.git
|
||||
git+https://github.com/tarantool/luarocks.git#branch=tarantool-1.7
|
||||
libcurl-7.62.patch
|
||||
tarantool.sysusers)
|
||||
sha1sums=('SKIP'
|
||||
'SKIP'
|
||||
|
@ -36,7 +35,6 @@ sha1sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'8308459e0d3832cbdf37b8aa678fde37ed627fce'
|
||||
'9021b3d50e45f719f0304ab529627cac69a7a149')
|
||||
|
||||
pkgver() {
|
||||
|
@ -47,9 +45,6 @@ pkgver() {
|
|||
prepare() {
|
||||
cd tarantool
|
||||
|
||||
# https://github.com/tarantool/tarantool/commit/02da15f710
|
||||
patch -Np1 -i ../libcurl-7.62.patch
|
||||
|
||||
git submodule init
|
||||
git config -f .gitmodules 'submodule.third_party/luajit.url' "$srcdir/luajit"
|
||||
git config -f .gitmodules 'submodule.src/lib/msgpuck.url' "$srcdir/msgpuck"
|
||||
|
@ -79,7 +74,8 @@ build() {
|
|||
-DENABLE_BUNDLED_LIBYAML:BOOL=OFF \
|
||||
-DENABLE_BACKTRACE:BOOL=OFF \
|
||||
-DWITH_SYSTEMD:BOOL=ON \
|
||||
-DENABLE_DIST:BOOL=ON
|
||||
-DENABLE_DIST:BOOL=ON \
|
||||
.
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
From 02da15f7109b8bb7921eb97a751607b9dd2885b2 Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Davydov <vdavydov.dev@gmail.com>
|
||||
Date: Thu, 1 Nov 2018 13:35:24 +0300
|
||||
Subject: [PATCH] httpc: fix compilation with libcurl >= 7.62.0
|
||||
|
||||
Starting from libcurl 7.62.0, CURL_SSL_CACERT is defined as a macro
|
||||
alias to CURLE_PEER_FAILED_VERIFICATION, see
|
||||
|
||||
https://github.com/curl/curl/commit/3f3b26d6feb0667714902e836af608094235fca2
|
||||
|
||||
This breaks compilation:
|
||||
|
||||
httpc.c:337:7: error: duplicate case value 'CURLE_PEER_FAILED_VERIFICATION'
|
||||
case CURLE_PEER_FAILED_VERIFICATION:
|
||||
^
|
||||
httpc.c:336:7: note: previous case defined here
|
||||
case CURLE_SSL_CACERT:
|
||||
^
|
||||
curl.h:589:26: note: expanded from macro 'CURLE_SSL_CACERT'
|
||||
#define CURLE_SSL_CACERT CURLE_PEER_FAILED_VERIFICATION
|
||||
^
|
||||
|
||||
Fix this by using CURLE_SSL_CACERT only if libcurl version is less
|
||||
than 7.62.0.
|
||||
|
||||
Note, we can't use CURL_AT_LEAST_VERSION to check libcurl version,
|
||||
because it isn't available in libcurl shipped with CentOS 6.
|
||||
---
|
||||
src/httpc.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/httpc.c b/src/httpc.c
|
||||
index 4d48a313d8..950f8b32f6 100644
|
||||
--- a/src/httpc.c
|
||||
+++ b/src/httpc.c
|
||||
@@ -333,7 +333,9 @@ httpc_execute(struct httpc_request *req, double timeout)
|
||||
++env->stat.http_other_responses;
|
||||
}
|
||||
break;
|
||||
- case CURLE_SSL_CACERT:
|
||||
+#if LIBCURL_VERSION_NUM < 0x073e00
|
||||
+ case CURLE_SSL_CACERT: /* deprecated in libcurl 7.62.0 */
|
||||
+#endif
|
||||
case CURLE_PEER_FAILED_VERIFICATION:
|
||||
/* 495 SSL Certificate Error (nginx non-standard) */
|
||||
req->status = 495;
|
Loading…
Reference in a new issue