mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
409ccfcebf
4 changed files with 24 additions and 161 deletions
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=mythtv
|
||||
pkgver=0.26.0
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
epoch=1
|
||||
pkgdesc="A Homebrew PVR project"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -36,23 +36,27 @@ source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2"
|
|||
'alsa.patch'
|
||||
'mythbackend.rc'
|
||||
'mythbackend.conf'
|
||||
'mythbackend.service')
|
||||
'mythbackend.service'
|
||||
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.patch')
|
||||
md5sums=('f57066bf75e6f14824c494d41639f4f9'
|
||||
'f64b8219e3d27a2edf96733b851e576b'
|
||||
'c8f935d42fb8617e9279bd539811ca5f'
|
||||
'ab962d83614cbd0ac11ce3fcc929829d'
|
||||
'e4d572dcc307d6d8ae26bee5aebf9f3a')
|
||||
'e4d572dcc307d6d8ae26bee5aebf9f3a'
|
||||
'6e156c9fc0b369346d93ccafad46cba3')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
||||
|
||||
patch -Np1 -i "$srcdir/alsa.patch"
|
||||
patch -Np2 -i "$srcdir/libcec-2-support.patch"
|
||||
|
||||
sed -re 's@Key, &@Key, @' -i 'bindings/php/MythBase.php'
|
||||
|
||||
[[ $CARCH == "arm" ]] && ARCH="armv5te"
|
||||
[[ $CARCH == "armv7" ]] && ARCH="armv7-a"
|
||||
[[ $CARCH == "arm" ]] && ARCH="armv5te"
|
||||
[[ $CARCH == "armv6h" ]] && ARCH="armv6l"
|
||||
[[ $CARCH == "armv7h" ]] && ARCH="armv7-a"
|
||||
./configure --prefix=/usr \
|
||||
--cpu="$ARCH" \
|
||||
--disable-mmx \
|
||||
|
|
|
@ -8,16 +8,14 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - --disable-vdpau/xvda, remove from makedepends
|
||||
# - specify our C/CXXFLAGS in configure
|
||||
# - patch to remove very wrong XBMC code trying to assert its own ARM CFLAGS, MathUtils.h ARM fix
|
||||
# - commented TexturePacker install, doesn't appear to want to build
|
||||
|
||||
buildarch=4
|
||||
|
||||
_prefix=/usr
|
||||
|
||||
pkgname=xbmc
|
||||
pkgver=11.0
|
||||
pkgrel=14
|
||||
pkgver=12.0
|
||||
pkgrel=1
|
||||
pkgdesc="A software media player and entertainment hub for digital media"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://xbmc.org"
|
||||
|
@ -26,9 +24,10 @@ depends=('libpulse' 'hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff'
|
|||
'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg-turbo' 'libsamplerate'
|
||||
'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2'
|
||||
'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos'
|
||||
'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez' 'glu')
|
||||
'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez' 'glu'
|
||||
'tinyxml' 'taglib')
|
||||
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'libxinerama' 'zip' 'libcec'
|
||||
'udisks' 'upower' 'bluez' 'mesa')
|
||||
'udisks' 'upower' 'bluez' 'mesa' 'doxygen' 'swig' 'java-environment')
|
||||
optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
||||
'pulseaudio: pulseaudio support'
|
||||
'lirc: remote controller support'
|
||||
|
@ -39,27 +38,22 @@ optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
|||
install="${pkgname}.install"
|
||||
source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz"
|
||||
"xbmc.service"
|
||||
"cdio.patch"
|
||||
"alarm.patch")
|
||||
sha256sums=('1fe5d310c16138f26e2b13bc545604e95f48ace6c8636f23e77da402cd7b0b19'
|
||||
'82ebca3d66155f889a3d70311b000ac8b911b062af8df308d6a86aecc6b1b52b'
|
||||
'eef23b30b11acca317f71022df1091e35d8295138680618712f3ef6c719145ca'
|
||||
'6e4934e8d1bf82890679eca2fa78b3bc5942feedd9c012728a8d04c59be1651d')
|
||||
"cdio.patch")
|
||||
md5sums=('a79128b9d094a046947bfd9bb4550809'
|
||||
'76fae229ebc3bcfaab7e7f27e4fb51f5'
|
||||
'49c0a7cbfca3666a24e8824950bd371b')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/xbmc-$pkgver"
|
||||
|
||||
# fix retard code
|
||||
patch -p1 -i "${srcdir}/alarm.patch"
|
||||
|
||||
# fix lsb_release dependency
|
||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||
|
||||
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADER:' \
|
||||
lib/libid3tag/libid3tag/configure.ac \
|
||||
lib/libdvd/libdvdcss/configure.ac
|
||||
# sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADER:' \
|
||||
# lib/libid3tag/libid3tag/configure.ac \
|
||||
# lib/libdvd/libdvdcss/configure.ac
|
||||
|
||||
patch -p1 <$srcdir/cdio.patch
|
||||
# patch -p1 <$srcdir/cdio.patch
|
||||
|
||||
# Bootstrapping XBMC
|
||||
./bootstrap
|
||||
|
@ -118,7 +112,7 @@ package() {
|
|||
|
||||
# Tools
|
||||
install -D -m 0755 "${srcdir}/xbmc-$pkgver/xbmc-xrandr" "${pkgdir}${_prefix}/share/xbmc/xbmc-xrandr"
|
||||
#install -D -m 0755 "${srcdir}/xbmc-$pkgver/tools/TexturePacker/TexturePacker" "${pkgdir}${_prefix}/share/xbmc/"
|
||||
install -D -m 0755 "${srcdir}/xbmc-$pkgver/tools/TexturePacker/TexturePacker" "${pkgdir}${_prefix}/share/xbmc/"
|
||||
|
||||
# Licenses
|
||||
install -d -m 0755 "${pkgdir}${_prefix}/share/licenses/${pkgname}"
|
||||
|
|
|
@ -1,135 +0,0 @@
|
|||
diff -urN a/configure b/configure
|
||||
--- a/configure 2012-03-24 13:06:47.000000000 -0600
|
||||
+++ b/configure 2012-06-08 14:37:25.504009179 -0600
|
||||
@@ -15984,38 +15984,9 @@
|
||||
LIBS="$LIBS -framework ApplicationServices"
|
||||
fi
|
||||
elif test "$use_arch" = "arm"; then
|
||||
- CFLAGS="$CFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
|
||||
- CXXFLAGS="$CXXFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
|
||||
- FFMPEG_EXTRACFLAGS="-mfloat-abi=softfp"
|
||||
- if test "$use_tegra" = "yes"; then
|
||||
- # Compile for ARMv7a architecture, need to test gcc for vfpv3-d16 support
|
||||
- SAVE_CFLAGS="$CFLAGS"
|
||||
- CFLAGS="-mfpu=vfpv3-d16"
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-int foo;
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||
- CFLAGS="$SAVE_CFLAGS -Wno-psabi -Wa,-march=armv7a -mtune=cortex-a9 -mfpu=vfpv3-d16 -mthumb-interwork"
|
||||
- CXXFLAGS="$CXXFLAGS -Wno-psabi -Wa,-march=armv7a -mtune=cortex-a9 -mfpu=vfpv3-d16 -mthumb-interwork"
|
||||
- FFMPEG_EXTRACFLAGS="$FFMPEG_EXTRACFLAGS -mtune=cortex-a9 -mfpu=vfpv3-d16"
|
||||
- use_cpu=cortex-a9
|
||||
-else
|
||||
- CFLAGS="$SAVE_CFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
|
||||
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
|
||||
- use_cpu=cortex-a8
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
- else
|
||||
- # Compile for ARMv7a architecture, CortexA8 cpu and check for enabled NEON coprocessor
|
||||
- CFLAGS="$CFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
|
||||
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
|
||||
- if test "$use_neon" = "yes"; then
|
||||
- CFLAGS="$CFLAGS -mfpu=neon -mvectorize-with-neon-quad"
|
||||
- CXXFLAGS="$CXXFLAGS -mfpu=neon -mvectorize-with-neon-quad"
|
||||
- FFMPEG_EXTRACFLAGS="$FFMPEG_EXTRACFLAGS -mfpu=neon"
|
||||
- fi
|
||||
- fi
|
||||
+ CFLAGS="$CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
+ FFMPEG_EXTRACFLAGS=""
|
||||
fi
|
||||
|
||||
# Checks for library functions.
|
||||
diff -urN a/configure.in b/configure.in
|
||||
--- a/configure.in 2012-03-21 16:07:50.000000000 -0600
|
||||
+++ b/configure.in 2012-06-08 14:46:52.687054825 -0600
|
||||
@@ -572,32 +572,9 @@
|
||||
LIBS="$LIBS -framework ApplicationServices"
|
||||
fi
|
||||
elif test "$use_arch" = "arm"; then
|
||||
- CFLAGS="$CFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
|
||||
- CXXFLAGS="$CXXFLAGS -mfloat-abi=softfp -mno-apcs-stack-check"
|
||||
- FFMPEG_EXTRACFLAGS="-mfloat-abi=softfp"
|
||||
- if test "$use_tegra" = "yes"; then
|
||||
- # Compile for ARMv7a architecture, need to test gcc for vfpv3-d16 support
|
||||
- SAVE_CFLAGS="$CFLAGS"
|
||||
- CFLAGS="-mfpu=vfpv3-d16"
|
||||
- AC_COMPILE_IFELSE(
|
||||
- [AC_LANG_SOURCE([int foo;])],
|
||||
- [ CFLAGS="$SAVE_CFLAGS -Wno-psabi -Wa,-march=armv7a -mtune=cortex-a9 -mfpu=vfpv3-d16 -mthumb-interwork"
|
||||
- CXXFLAGS="$CXXFLAGS -Wno-psabi -Wa,-march=armv7a -mtune=cortex-a9 -mfpu=vfpv3-d16 -mthumb-interwork"
|
||||
- FFMPEG_EXTRACFLAGS="$FFMPEG_EXTRACFLAGS -mtune=cortex-a9 -mfpu=vfpv3-d16"
|
||||
- use_cpu=cortex-a9],
|
||||
- [ CFLAGS="$SAVE_CFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
|
||||
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv6 -mtune=cortex-a8 -mthumb-interwork"
|
||||
- use_cpu=cortex-a8])
|
||||
- else
|
||||
- # Compile for ARMv7a architecture, CortexA8 cpu and check for enabled NEON coprocessor
|
||||
- CFLAGS="$CFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
|
||||
- CXXFLAGS="$CXXFLAGS -Wa,-march=armv7a -mcpu=cortex-a8"
|
||||
- if test "$use_neon" = "yes"; then
|
||||
- CFLAGS="$CFLAGS -mfpu=neon -mvectorize-with-neon-quad"
|
||||
- CXXFLAGS="$CXXFLAGS -mfpu=neon -mvectorize-with-neon-quad"
|
||||
- FFMPEG_EXTRACFLAGS="$FFMPEG_EXTRACFLAGS -mfpu=neon"
|
||||
- fi
|
||||
- fi
|
||||
+ CFLAGS="$CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
+ FFMPEG_EXTRACFLAGS=""
|
||||
fi
|
||||
|
||||
# Checks for library functions.
|
||||
diff -urN a/xbmc/utils/MathUtils.h b/xbmc/utils/MathUtils.h
|
||||
--- a/xbmc/utils/MathUtils.h 2012-03-21 16:07:50.000000000 -0600
|
||||
+++ b/xbmc/utils/MathUtils.h 2012-06-08 15:43:59.044891727 -0600
|
||||
@@ -63,46 +63,8 @@
|
||||
sar i, 1
|
||||
}
|
||||
#else
|
||||
-#if defined(__powerpc__) || defined(__ppc__)
|
||||
+#if defined(__powerpc__) || defined(__ppc__) || defined(__arm__)
|
||||
i = floor(x + round_to_nearest);
|
||||
-#elif defined(__arm__)
|
||||
- // From 'ARM®v7-M Architecture Reference Manual' page A7-569:
|
||||
- // "The floating-point to integer operation (vcvt) [normally] uses the Round towards Zero rounding mode"
|
||||
- // Because of this...we must use some less-than-straightforward logic to perform this operation without
|
||||
- // changing the rounding mode flags
|
||||
-
|
||||
- /* The assembly below implements the following logic:
|
||||
- if (x < 0)
|
||||
- inc = -0.5f
|
||||
- else
|
||||
- inc = 0.5f
|
||||
- int_val = trunc(x+inc);
|
||||
- err = x - int_val;
|
||||
- if (err == 0.5f)
|
||||
- int_val++;
|
||||
- return int_val;
|
||||
- */
|
||||
-
|
||||
- __asm__ __volatile__ (
|
||||
- "vmov.F64 d1,%[rnd_val] \n\t" // Copy round_to_nearest into a working register (d1 = 0.5)
|
||||
- "fcmpezd %P[value] \n\t" // Check value against zero (value == 0?)
|
||||
- "fmstat \n\t" // Copy the floating-point status flags into the general-purpose status flags
|
||||
- "it mi \n\t"
|
||||
- "vnegmi.F64 d1, d1 \n\t" // if N-flag is set, negate round_to_nearest (if (value < 0) d1 = -1 * d1)
|
||||
- "vadd.F64 d1,%P[value],d1 \n\t" // Add round_to_nearest to value, store result in working register (d1 += value)
|
||||
- "vcvt.S32.F64 s3,d1 \n\t" // Truncate(round towards zero) (s3 = (int)d1)
|
||||
- "vmov %[result],s3 \n\t" // Store the integer result in a general-purpose register (result = s3)
|
||||
- "vcvt.F64.S32 d1,s3 \n\t" // Convert back to floating-point (d1 = (double)s3)
|
||||
- "vsub.F64 d1,%P[value],d1 \n\t" // Calculate the error (d1 = value - d1)
|
||||
- "vmov.F64 d2,%[rnd_val] \n\t" // d2 = 0.5;
|
||||
- "fcmped d1, d2 \n\t" // (d1 == 0.5?)
|
||||
- "fmstat \n\t" // Copy the floating-point status flags into the general-purpose status flags
|
||||
- "it eq \n\t"
|
||||
- "addeq %[result],#1 \n\t" // (if (d1 == d2) result++;)
|
||||
- : [result] "=r"(i) // Outputs
|
||||
- : [rnd_val] "Dv" (round_to_nearest), [value] "w"(x) // Inputs
|
||||
- : "d1", "d2", "s3" // Clobbers
|
||||
- );
|
||||
#else
|
||||
__asm__ __volatile__ (
|
||||
"fadd %%st\n\t"
|
|
@ -6,7 +6,7 @@ After = remote-fs.target
|
|||
User = xbmc
|
||||
Group = xbmc
|
||||
Type = simple
|
||||
ExecStart = /usr/bin/xinit /usr/bin/xbmc-standalone -- :0
|
||||
ExecStart = /usr/bin/xinit /usr/bin/xbmc-standalone -- :0 -nolisten tcp
|
||||
Restart = always
|
||||
|
||||
[Install]
|
||||
|
|
Loading…
Reference in a new issue