mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-base to 5.15.2+kde+r207-2
This commit is contained in:
parent
47594f0c38
commit
40a4b7e1bb
2 changed files with 30 additions and 3 deletions
|
@ -9,7 +9,7 @@
|
||||||
pkgbase=qt5-base
|
pkgbase=qt5-base
|
||||||
pkgname=(qt5-base qt5-xcb-private-headers)
|
pkgname=(qt5-base qt5-xcb-private-headers)
|
||||||
pkgver=5.15.2+kde+r207
|
pkgver=5.15.2+kde+r207
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
_commit=6ee419d6597fb297c2f35d5be63c4eb16ae9b12c
|
_commit=6ee419d6597fb297c2f35d5be63c4eb16ae9b12c
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://www.qt.io'
|
url='https://www.qt.io'
|
||||||
|
@ -35,10 +35,12 @@ groups=('qt' 'qt5')
|
||||||
_pkgfqn=qtbase
|
_pkgfqn=qtbase
|
||||||
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
|
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
|
||||||
qt5-base-cflags.patch
|
qt5-base-cflags.patch
|
||||||
qt5-base-nostrip.patch)
|
qt5-base-nostrip.patch
|
||||||
|
qt5-base-mariadb-10.6.patch)
|
||||||
sha256sums=('SKIP'
|
sha256sums=('SKIP'
|
||||||
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
|
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
|
||||||
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
|
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
|
||||||
|
'dde1c2c7300a6e05b12145f0c0b180991aa5929a4bf13c026eef6511593f357b')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd $_pkgfqn
|
cd $_pkgfqn
|
||||||
|
@ -49,6 +51,8 @@ prepare() {
|
||||||
cd ${_pkgfqn}
|
cd ${_pkgfqn}
|
||||||
|
|
||||||
git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
|
git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
|
||||||
|
patch -p1 < ../qt5-base-mariadb-10.6.patch # Fix broken mysql version detection with mariadb 10.6
|
||||||
|
|
||||||
patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
|
patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
|
||||||
patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
|
patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
|
||||||
}
|
}
|
||||||
|
|
23
extra/qt5-base/qt5-base-mariadb-10.6.patch
Normal file
23
extra/qt5-base/qt5-base-mariadb-10.6.patch
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
diff --git a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||||
|
index a641935dc5..19e6a8286d 100644
|
||||||
|
--- a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||||
|
+++ b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||||
|
@@ -1355,7 +1355,7 @@ bool QMYSQLDriver::open(const QString& db,
|
||||||
|
}
|
||||||
|
|
||||||
|
#if MYSQL_VERSION_ID >= 50007
|
||||||
|
- if (mysql_get_client_version() >= 50503 && mysql_get_server_version(d->mysql) >= 50503) {
|
||||||
|
+ if (true) {
|
||||||
|
// force the communication to be utf8mb4 (only utf8mb4 supports 4-byte characters)
|
||||||
|
mysql_set_character_set(d->mysql, "utf8mb4");
|
||||||
|
#if QT_CONFIG(textcodec)
|
||||||
|
@@ -1371,8 +1371,7 @@ bool QMYSQLDriver::open(const QString& db,
|
||||||
|
}
|
||||||
|
#endif // MYSQL_VERSION_ID >= 50007
|
||||||
|
|
||||||
|
- d->preparedQuerysEnabled = mysql_get_client_version() >= 40108
|
||||||
|
- && mysql_get_server_version(d->mysql) >= 40100;
|
||||||
|
+ d->preparedQuerysEnabled = true;
|
||||||
|
|
||||||
|
#if QT_CONFIG(thread)
|
||||||
|
mysql_thread_init();
|
Loading…
Reference in a new issue