mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/kodi to 15.0-1
This commit is contained in:
parent
d04e5d04f7
commit
40aa661b19
3 changed files with 9 additions and 57 deletions
|
@ -19,9 +19,9 @@ _prefix=/usr
|
|||
|
||||
pkgbase=kodi
|
||||
pkgname=('kodi' 'kodi-eventclients')
|
||||
pkgver=14.2
|
||||
_codename=Helix
|
||||
pkgrel=5
|
||||
pkgver=15.0
|
||||
_codename=Isengard
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://kodi.tv"
|
||||
license=('GPL2')
|
||||
|
@ -30,18 +30,15 @@ makedepends=(
|
|||
'gperf' 'hicolor-icon-theme' 'jasper' 'java-runtime' 'libaacs' 'libass'
|
||||
'libbluray' 'libcdio' 'libcec' 'libgl' 'libmariadbclient' 'libmicrohttpd'
|
||||
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse' 'libssh' 'libva'
|
||||
'libxrandr' 'libxslt' 'lzo' 'nasm' 'nss-mdns' 'python2-pillow'
|
||||
'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2' 'sdl_image'
|
||||
'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower' 'yajl' 'zip'
|
||||
'libxrandr' 'libxslt' 'lzo' 'mesa' 'nasm' 'nss-mdns'
|
||||
'python2-pillow' 'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2'
|
||||
'sdl_image' 'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower'
|
||||
'yajl' 'zip'
|
||||
)
|
||||
source=(
|
||||
"$pkgname-$pkgver-$_codename.tar.gz::https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
|
||||
"kodi-14.0-dvddemux-ffmpeg.patch"
|
||||
"kodi-14.0-gcc5.patch"
|
||||
)
|
||||
sha256sums=('d9cb8590430a925fb789a5beb4da2695cdcd2d2500dd31126f3b77b31aa267f4'
|
||||
'01453e18987b01ad40c9ae423a7e47422e537b648e74f5c942f132c37e6370f8'
|
||||
'598f36cea0f63440e5755d88752552240fc5cd2b98e4f80a9feeb9605c917777')
|
||||
sha256sums=('27dba173cfe74b323f4dbaa72ae2bfe5961f76c27bddcd5210253be91cae0dff')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/xbmc-$pkgver-$_codename"
|
||||
|
@ -50,13 +47,6 @@ prepare() {
|
|||
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
|
||||
sed 's/python/python2/' -i tools/Linux/kodi.sh.in
|
||||
sed 's/shell python/shell python2/' -i tools/EventClients/Makefile.in
|
||||
# disable wiiremote due to incompatibility with bluez-5.29
|
||||
sed '/WiiRemote/d' -i tools/EventClients/Makefile.in
|
||||
sed '/mkdir -p $(DESTDIR)$(bindir)/i \
|
||||
install:' -i tools/EventClients/Makefile.in
|
||||
|
||||
patch -p0 -i "$srcdir/kodi-14.0-dvddemux-ffmpeg.patch"
|
||||
patch -p1 -i "$srcdir/kodi-14.0-gcc5.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -77,7 +67,7 @@ build() {
|
|||
--enable-shared-libraries \
|
||||
--with-lirc-device=/run/lirc/lircd \
|
||||
--disable-vaapi \
|
||||
ac_cv_lib_bluetooth_hci_devid=no
|
||||
ac_cv_type__Bool=yes
|
||||
|
||||
# Now (finally) build
|
||||
make
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp.orig 2014-08-01 11:18:24.000000000 -0500
|
||||
+++ xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp 2014-08-24 15:36:34.844966866 -0500
|
||||
@@ -519,10 +519,6 @@
|
||||
|
||||
void CDVDDemuxFFmpeg::Flush()
|
||||
{
|
||||
- // naughty usage of an internal ffmpeg function
|
||||
- if (m_pFormatContext)
|
||||
- av_read_frame_flush(m_pFormatContext);
|
||||
-
|
||||
m_currentPts = DVD_NOPTS_VALUE;
|
||||
|
||||
m_pkt.result = -1;
|
|
@ -1,25 +0,0 @@
|
|||
--- a/xbmc/screensavers/rsxs-0.9/lib/argp.h.orig 2015-03-26 13:25:20.000000000 -0500
|
||||
+++ b/xbmc/screensavers/rsxs-0.9/lib/argp.h 2015-05-19 16:05:20.992493851 -0500
|
||||
@@ -559,7 +559,7 @@
|
||||
# endif
|
||||
|
||||
# ifndef ARGP_EI
|
||||
-# define ARGP_EI extern __inline__
|
||||
+# define ARGP_EI extern __inline__ __attribute__ ((gnu_inline))
|
||||
# endif
|
||||
|
||||
ARGP_EI void
|
||||
--- a/xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h.orig 2015-03-26 13:25:20.000000000 -0500
|
||||
+++ b/xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h 2015-05-19 16:02:25.775456866 -0500
|
||||
@@ -198,11 +198,7 @@
|
||||
#endif
|
||||
|
||||
#ifndef ARGP_FS_EI
|
||||
-#ifdef __clang__
|
||||
#define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
|
||||
-#else
|
||||
-#define ARGP_FS_EI extern inline
|
||||
-#endif
|
||||
#endif
|
||||
|
||||
ARGP_FS_EI size_t
|
Loading…
Reference in a new issue