mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community -> extra/qtcreator to 2.8.1-2
This commit is contained in:
parent
559e5fb0b0
commit
40dc108d40
5 changed files with 16 additions and 20 deletions
|
@ -1,10 +0,0 @@
|
|||
--- qt-creator-2.6.2-src/qtcreator.pri~ 2013-02-27 13:55:23.818990553 +0000
|
||||
+++ qt-creator-2.6.2-src/qtcreator.pri 2013-02-27 13:55:52.335454428 +0000
|
||||
@@ -147,6 +147,7 @@
|
||||
}
|
||||
|
||||
INCLUDEPATH += \
|
||||
+ /usr/include \
|
||||
$$IDE_BUILD_TREE/src \ # for <app/app_version.h>
|
||||
$$IDE_SOURCE_TREE/src/libs \
|
||||
$$IDE_SOURCE_TREE/tools \
|
|
@ -1,6 +1,6 @@
|
|||
# $Id: PKGBUILD 86795 2013-03-22 10:46:14Z svenstaro $
|
||||
# Maintainer: Imanol Celaya <ornitorrincos@archlinux-es.org>
|
||||
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
||||
# Contributor: Imanol Celaya <ornitorrincos@archlinux-es.org>
|
||||
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
|
||||
# Contributor: Dan Vratil <progdan@progdansoft.com>
|
||||
# Contributor: thotypous <matiasΘarchlinux-br·org>
|
||||
|
@ -12,7 +12,7 @@
|
|||
pkgname=qtcreator
|
||||
pkgver=2.8.1
|
||||
_pkgver=2.8.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc='Lightweight, cross-platform integrated development environment'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org'
|
||||
|
@ -29,22 +29,28 @@ optdepends=('qt5-doc: for the integrated Qt documentation'
|
|||
'bzr: for bazaar support'
|
||||
'valgrind: for analyze support')
|
||||
install=qtcreator.install
|
||||
source=("http://download.qt-project.org/official_releases/qtcreator/2.8/${pkgver}/qt-creator-${pkgver}-src.tar.gz"
|
||||
source=("git://gitorious.org/qt-creator/qt-creator.git#tag=v${_pkgver}"
|
||||
"git://gitorious.org/qt-labs/qbs.git"
|
||||
'qtcreator.desktop'
|
||||
'botan-upgrade.patch')
|
||||
md5sums=('79ef6c6ece0c00035ef744c9d6e3bd3b'
|
||||
md5sums=('SKIP'
|
||||
'SKIP'
|
||||
'82888d4be900e7833d768050a135cd37'
|
||||
'7d71e58bdb7a918adb779b0e527fbba5')
|
||||
|
||||
build() {
|
||||
cd qt-creator-${pkgver}-src
|
||||
patch -p1 -i "${srcdir}"/botan-upgrade.patch
|
||||
cd ../
|
||||
prepare() {
|
||||
cd qt-creator
|
||||
git submodule init
|
||||
git config submodule.qbs.url $srcdir/qbs
|
||||
git submodule update
|
||||
patch -p1 -i "${srcdir}"/botan-upgrade.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
[[ -d build ]] && rm -r build
|
||||
mkdir build && cd build
|
||||
|
||||
qmake ../qt-creator-${pkgver}-src/qtcreator.pro
|
||||
qmake ../qt-creator/qtcreator.pro
|
||||
make
|
||||
make docs -j1
|
||||
}
|
||||
|
@ -56,5 +62,5 @@ package() {
|
|||
make INSTALL_ROOT="${pkgdir}/usr/" install_docs
|
||||
|
||||
install -Dm644 ${srcdir}/qtcreator.desktop ${pkgdir}/usr/share/applications/qtcreator.desktop
|
||||
install -Dm644 ${srcdir}/qt-creator-${pkgver}-src/LGPL_EXCEPTION.TXT ${pkgdir}/usr/share/licenses/qtcreator/LGPL_EXCEPTION.TXT
|
||||
install -Dm644 ${srcdir}/qt-creator/LGPL_EXCEPTION.TXT ${pkgdir}/usr/share/licenses/qtcreator/LGPL_EXCEPTION.TXT
|
||||
}
|
Loading…
Reference in a new issue