mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/chromium to 64.0.3282.140-2
This commit is contained in:
parent
00a3715045
commit
40fdd36046
2 changed files with 7 additions and 42 deletions
|
@ -14,7 +14,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=64.0.3282.140
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=5
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
|
||||
|
@ -36,7 +36,6 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-skia-harmony.patch
|
||||
chromium-memcpy-r0.patch
|
||||
chromium-clang-r2.patch
|
||||
chromium-exclude_unwind_tables.patch
|
||||
chromium-widevine.patch
|
||||
chromium-angle-r0.patch
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
|
@ -48,7 +47,6 @@ sha256sums=('146afbab37982c52251e5c71b6e19e6e7053b527217fe1da9966c794478c29ce'
|
|||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
'455f0029987d9f0532bd9a5250669af5146a9c2b65b776d4a6e2499e8aca7bb4'
|
||||
'4495e8b29dae242c79ffe4beefc5171eb3c7aacb7e9aebfd2d4d69b9d8c958d3'
|
||||
'9478f1ec1a3c53425306cf41c2d0555c215a4f106955d9d6adfff38044530ce8'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'ec9dbff87e8a8655090eaa456905b67936c3d0d48d6fd84e088864af39ceed47'
|
||||
'8489d2a85b32e9b08f5c30d47b40ae41911d1915f48b6de3c41fe350dfecfef6')
|
||||
|
@ -65,7 +63,7 @@ readonly -A _system_libs=(
|
|||
[libdrm]=
|
||||
[libjpeg]=libjpeg
|
||||
#[libpng]=libpng # https://crbug.com/752403#c10
|
||||
#[libvpx]=libvpx # https://bugs.gentoo.org/611394
|
||||
[libvpx]=libvpx
|
||||
[libwebp]=libwebp
|
||||
#[libxml]=libxml2 # https://crbug.com/736026
|
||||
[libxslt]=libxslt
|
||||
|
@ -114,9 +112,6 @@ prepare() {
|
|||
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
|
||||
patch -Np1
|
||||
|
||||
# https://chromium-review.googlesource.com/c/chromium/src/+/712575
|
||||
patch -Np1 -i ../chromium-exclude_unwind_tables.patch
|
||||
|
||||
# https://crbug.com/772655
|
||||
patch -Np1 -i ../chromium-use-fromUTF8-for-UnicodeString-construction.patch
|
||||
|
||||
|
@ -187,7 +182,6 @@ build() {
|
|||
'link_pulseaudio=true'
|
||||
'use_system_freetype=true'
|
||||
'use_system_harfbuzz=true'
|
||||
'use_gtk3=true'
|
||||
'use_gconf=false'
|
||||
'use_gnome_keyring=false'
|
||||
'use_gold=false'
|
||||
|
@ -205,7 +199,11 @@ build() {
|
|||
)
|
||||
|
||||
if check_option strip y; then
|
||||
_flags+=('exclude_unwind_tables=true')
|
||||
# https://chromium-review.googlesource.com/c/chromium/src/+/712575
|
||||
# _flags+=('exclude_unwind_tables=true')
|
||||
CFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
|
||||
CXXFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
|
||||
CPPFLAGS+=' -DNO_UNWIND_TABLES'
|
||||
fi
|
||||
|
||||
python2 tools/gn/bootstrap/bootstrap.py --gn-gen-args "${_flags[*]}"
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff --git a/build/config/compiler/compiler.gni b/build/config/compiler/compiler.gni
|
||||
index ad40fd9..50e19a4 100644
|
||||
--- a/build/config/compiler/compiler.gni
|
||||
+++ b/build/config/compiler/compiler.gni
|
||||
@@ -68,19 +68,19 @@
|
||||
|
||||
# Whether or not we should use position independent code.
|
||||
use_pic = true
|
||||
+
|
||||
+ # Exclude unwind tables for official builds as unwinding can be done from
|
||||
+ # stack dumps produced by Crashpad at a later time "offline" in the crash
|
||||
+ # server. For unofficial (e.g. development) builds and non-Chrome branded
|
||||
+ # (e.g. Cronet which doesn't use Crashpad, crbug.com/479283) builds it's
|
||||
+ # useful to be able to unwind at runtime.
|
||||
+ exclude_unwind_tables =
|
||||
+ (is_chrome_branded && is_official_build) ||
|
||||
+ (is_chromecast && !is_cast_desktop_build && !is_debug && !is_fuchsia)
|
||||
}
|
||||
|
||||
assert(!is_cfi || use_thin_lto, "CFI requires ThinLTO")
|
||||
|
||||
-# Exclude unwind tables for official builds as unwinding can be done from stack
|
||||
-# dumps produced by Crashpad at a later time "offline" in the crash server.
|
||||
-# For unofficial (e.g. development) builds and non-Chrome branded (e.g. Cronet
|
||||
-# which doesn't use Crashpad, crbug.com/479283) builds it's useful to be able
|
||||
-# to unwind at runtime.
|
||||
-exclude_unwind_tables =
|
||||
- (is_chrome_branded && is_official_build) ||
|
||||
- (is_chromecast && !is_cast_desktop_build && !is_debug && !is_fuchsia)
|
||||
-
|
||||
# If true, optimize for size. Does not affect windows builds.
|
||||
# Linux & Mac favor speed over size.
|
||||
# TODO(brettw) it's weird that Mac and desktop Linux are different. We should
|
Loading…
Reference in a new issue