removed community/kbibtex

This commit is contained in:
Kevin Mihelich 2017-03-20 00:57:59 +00:00
parent e2fb127a68
commit 412fa7f692
3 changed files with 0 additions and 109 deletions

View file

@ -1,25 +0,0 @@
From 1c95e056224ab6399b84d69fb90572b37a8a53a5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 18 Aug 2015 17:37:44 -0600
Subject: [PATCH] remove qreal cast for arm
---
src/gui/widgets/starrating.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/gui/widgets/starrating.cpp b/src/gui/widgets/starrating.cpp
index 664f12f..d3dbb4c 100644
--- a/src/gui/widgets/starrating.cpp
+++ b/src/gui/widgets/starrating.cpp
@@ -250,7 +250,7 @@ double StarRating::percentForPosition(const QPoint &pos, int numTotalStars, cons
const int width = starSize * numTotalStars;
const int x = pos.x() - Private::paintMargin - inside.left();
const double percent = x * 100.0 / width;
- return qMax(qreal(0.0), qMin(qreal(100.0), percent));
+ return qMax(0.0, qMin(100.0, percent));
}
bool StarRatingFieldInput::reset(const Value &value)
--
2.5.0

View file

@ -1,50 +0,0 @@
# $Id$
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
# Contributor: cmorlok <christianmorlok@web.de>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove qreal usage on v5/6/7
pkgname=kbibtex
pkgver=0.6
_branch=0.6
pkgrel=5
pkgdesc="A BibTeX editor for KDE"
arch=('i686' 'x86_64')
url='http://home.gna.org/kbibtex/'
license=('GPL')
depends=('kdebase-runtime' 'poppler-qt4')
optdepends=('okular: Document preview')
makedepends=('cmake' 'automoc4')
source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch
'0001-remove-qreal-cast-for-arm.patch')
md5sums=('f1a9c1867d94c36fe88cfa0470b85dac'
'73a6be6e48e0e9106f60b65ad07d73e6'
'fae1a894b4dbc9339b0ad70a3a3b185c')
prepare() {
cd "$pkgname-$pkgver"
# Disable insecure qtwebkit
patch -p1 -i ../kbibtex-no-qtwebkit.patch
if [[ $CARCH != "aarch64" ]]; then
patch -p1 -i ../0001-remove-qreal-cast-for-arm.patch
fi
}
build() {
cd "$pkgname-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:

View file

@ -1,34 +0,0 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 04222a74..1485acc1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -34,29 +34,6 @@ include(
##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
-# check if QtWebKit is available, which seems to be not available
-# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
-if(
- QT_QTWEBKIT_FOUND
-)
- message(
- STATUS
- "Found QtWebKit, enabling WebKit support"
- )
- add_definitions(
- -DHAVE_QTWEBKIT
- )
-else(
- QT_QTWEBKIT_FOUND
-)
- message(
- STATUS
- "QtWebKit not found, disabling WebKit support"
- )
-endif(
- QT_QTWEBKIT_FOUND
-)
-
add_definitions(
${QT_DEFINITIONS}
${KDE4_DEFINITIONS}