mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox to 82.0-1
This commit is contained in:
parent
91751e3e3d
commit
415cf04563
5 changed files with 5 additions and 33279 deletions
|
@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
|
|||
2 files changed, 5 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index 49e2c73986ab..43ebcac381c7 100644
|
||||
index a16521852d05..d0be5a088d8c 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -3822,11 +3822,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
@@ -3832,11 +3832,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Jed Davis <jld@mozilla.com>
|
||||
Date: Fri, 28 Aug 2020 09:23:58 +0000
|
||||
Subject: [PATCH] Bug 1660901 - Support the fstat-like subset of fstatat in the
|
||||
Linux sandbox policies. r=gcp
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D88499
|
||||
---
|
||||
security/sandbox/linux/SandboxFilter.cpp | 6 ++++++
|
||||
security/sandbox/linux/broker/SandboxBrokerUtils.h | 2 ++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/security/sandbox/linux/SandboxFilter.cpp b/security/sandbox/linux/SandboxFilter.cpp
|
||||
index e522d61e065c..4087bdc07e01 100644
|
||||
--- a/security/sandbox/linux/SandboxFilter.cpp
|
||||
+++ b/security/sandbox/linux/SandboxFilter.cpp
|
||||
@@ -243,6 +243,12 @@ class SandboxPolicyCommon : public SandboxPolicyBase {
|
||||
auto path = reinterpret_cast<const char*>(aArgs.args[1]);
|
||||
auto buf = reinterpret_cast<statstruct*>(aArgs.args[2]);
|
||||
auto flags = static_cast<int>(aArgs.args[3]);
|
||||
+
|
||||
+ if (fd != AT_FDCWD && (flags & AT_EMPTY_PATH) != 0 &&
|
||||
+ strcmp(path, "") == 0) {
|
||||
+ return ConvertError(fstatsyscall(fd, buf));
|
||||
+ }
|
||||
+
|
||||
if (fd != AT_FDCWD && path[0] != '/') {
|
||||
SANDBOX_LOG_ERROR("unsupported fd-relative fstatat(%d, \"%s\", %p, %d)",
|
||||
fd, path, buf, flags);
|
||||
diff --git a/security/sandbox/linux/broker/SandboxBrokerUtils.h b/security/sandbox/linux/broker/SandboxBrokerUtils.h
|
||||
index 85a006740c2c..db33b5028e77 100644
|
||||
--- a/security/sandbox/linux/broker/SandboxBrokerUtils.h
|
||||
+++ b/security/sandbox/linux/broker/SandboxBrokerUtils.h
|
||||
@@ -19,10 +19,12 @@
|
||||
typedef struct stat64 statstruct;
|
||||
# define statsyscall stat64
|
||||
# define lstatsyscall lstat64
|
||||
+# define fstatsyscall fstat64
|
||||
#elif defined(__NR_stat)
|
||||
typedef struct stat statstruct;
|
||||
# define statsyscall stat
|
||||
# define lstatsyscall lstat
|
||||
+# define fstatsyscall fstat
|
||||
#else
|
||||
# error Missing stat syscall include.
|
||||
#endif
|
|
@ -1,31 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Julien Cristau <jcristau@mozilla.com>
|
||||
Date: Sun, 6 Sep 2020 20:20:39 +0000
|
||||
Subject: [PATCH] Bug 1660901 - ignore AT_NO_AUTOMOUNT in fstatat system call.
|
||||
r=jld
|
||||
|
||||
Per the manpage "Both stat() and lstat() act as though AT_NO_AUTOMOUNT
|
||||
was set.", so don't bail if it's set in a call to fstatat.
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D89121
|
||||
---
|
||||
security/sandbox/linux/SandboxFilter.cpp | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/security/sandbox/linux/SandboxFilter.cpp b/security/sandbox/linux/SandboxFilter.cpp
|
||||
index 4087bdc07e01..c4f6c318ad1c 100644
|
||||
--- a/security/sandbox/linux/SandboxFilter.cpp
|
||||
+++ b/security/sandbox/linux/SandboxFilter.cpp
|
||||
@@ -254,9 +254,10 @@ class SandboxPolicyCommon : public SandboxPolicyBase {
|
||||
fd, path, buf, flags);
|
||||
return BlockedSyscallTrap(aArgs, nullptr);
|
||||
}
|
||||
- if ((flags & ~AT_SYMLINK_NOFOLLOW) != 0) {
|
||||
+ if ((flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)) != 0) {
|
||||
SANDBOX_LOG_ERROR("unsupported flags %d in fstatat(%d, \"%s\", %p, %d)",
|
||||
- (flags & ~AT_SYMLINK_NOFOLLOW), fd, path, buf, flags);
|
||||
+ (flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)), fd,
|
||||
+ path, buf, flags);
|
||||
return BlockedSyscallTrap(aArgs, nullptr);
|
||||
}
|
||||
return (flags & AT_SYMLINK_NOFOLLOW) == 0 ? broker->Stat(path, buf)
|
File diff suppressed because one or more lines are too long
|
@ -10,7 +10,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=81.0.2
|
||||
pkgver=82.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
|
@ -30,18 +30,12 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
|
|||
arm.patch
|
||||
build-arm-libopus.patch
|
||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
|
||||
0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
|
||||
0004-Bug-1663715-Update-syn-and-proc-macro2-so-that-Firef.patch
|
||||
$pkgname.desktop)
|
||||
sha256sums=('91b6482de9b193b19d1fd9a8b99015a001646a48429297bbb7fe41784f9f9b44'
|
||||
sha256sums=('90c58707f5bd34978e2d1bcadbe463556edc0878430f969893ae2f89c5d464c2'
|
||||
'SKIP'
|
||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||
'e0eaec8ddd24bbebf4956563ebc6d7a56f8dada5835975ee4d320dd3d0c9c442'
|
||||
'c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29'
|
||||
'52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc'
|
||||
'2ffa37306bf8e5d79e074e612f88b6f3f671c45215724f84dd85cbea8b91e6bd'
|
||||
'1dba448eb1605c9dc73c22861a5394b50055909399f056baee4887b29af1b51e'
|
||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
|
||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||
|
||||
|
@ -65,14 +59,6 @@ prepare() {
|
|||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/67978
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1660901
|
||||
patch -Np1 -i ../0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
|
||||
patch -Np1 -i ../0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1663715
|
||||
patch -Np1 -i ../0004-Bug-1663715-Update-syn-and-proc-macro2-so-that-Firef.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue