mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/ncmpcpp to 0.9-1
This commit is contained in:
parent
14316f30a5
commit
417f4eb8c0
2 changed files with 15 additions and 40 deletions
|
@ -8,41 +8,42 @@
|
|||
# - strip -march=native from extras Makefile
|
||||
|
||||
pkgname=ncmpcpp
|
||||
pkgver=0.8.2
|
||||
pkgrel=14
|
||||
pkgver=0.9
|
||||
pkgrel=1
|
||||
pkgdesc='Almost exact clone of ncmpc with some new features'
|
||||
url='https://ncmpcpp.rybczak.net/'
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
depends=('curl' 'libmpdclient' 'taglib' 'ncurses' 'fftw' 'boost-libs')
|
||||
depends=('curl' 'libcurl.so' 'libmpdclient' 'libmpdclient.so' 'fftw' 'libfftw3.so' 'boost-libs'
|
||||
'libboost_filesystem.so' 'libboost_locale.so' 'libboost_program_options.so'
|
||||
'libboost_regex.so' 'libboost_thread.so' 'icu' 'libicui18n.so' 'libicuuc.so'
|
||||
'glibc' 'gcc-libs' 'ncurses' 'libncursesw.so' 'readline' 'libreadline.so' 'taglib')
|
||||
makedepends=('boost')
|
||||
source=(${pkgname}-${pkgver}.tar.bz2::https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2
|
||||
gcc10.patch)
|
||||
sha512sums=('9384edd162f40af23e4f26f437356520f117e4e2ab513ed3de132d2f11e597082d1cb7f0dd3696660d0c9bb85ad03e31fb921c97a11c7b28b32c5907fdbb8e8f'
|
||||
'99298d813391c03fc70ab16ffe8dd57c6151b87f4cd84f25a1747691d8f9f41e5f647b59c0d2ca25808acb995c7df6c99f386a4cc1f3f133b722731ef99a8a3b')
|
||||
source=(https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2)
|
||||
sha512sums=('aadf4bb510ce91b2af106d4881c90b618dbc30583c745e3ff924fc6c87553195b6cfb7d0034db7cf39d7001599a742d29d73a7de2701b70f36ad42d657df10e0')
|
||||
b2sums=('bdc55f16079d54b6ffdc0c1562b5cc91e1ea6c22bb45fe29642f8cedc8064d087a91fff37e04ec0f858163115cce50aa2e15bfd73a406ae58983ef53e11e6c39')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# https://github.com/ncmpcpp/ncmpcpp/pull/385
|
||||
patch -Np1 -i ../gcc10.patch
|
||||
|
||||
autoreconf -fiv
|
||||
sed -i 's/-march=native//' extras/Makefile
|
||||
sed -e 's/CXXFLAGS=/CXXFLAGS+=/' \
|
||||
-e 's/CPPFLAGS=/CPPFLAGS+=/' \
|
||||
-e 's/LDFLAGS=/LDFLAGS+=/' \
|
||||
-i extras/Makefile
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# http://site.icu-project.org/download/61#TOC-Migration-Issues
|
||||
CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
|
||||
export CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
|
||||
|
||||
BOOST_LIB_SUFFIX='' ./configure \
|
||||
--prefix=/usr \
|
||||
--enable-clock \
|
||||
--enable-outputs \
|
||||
--enable-unicode \
|
||||
--enable-visualizer \
|
||||
--with-curl \
|
||||
--with-fftw \
|
||||
--with-taglib
|
||||
make
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From 399e0f47008b487df3505476c959b4f42d8bc1b1 Mon Sep 17 00:00:00 2001
|
||||
From: Louis Sautier <sautier.louis@gmail.com>
|
||||
Date: Sat, 9 May 2020 14:31:52 +0200
|
||||
Subject: [PATCH] Fix build with GCC 10 by adding missing include
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes the following error:
|
||||
./mpdpp.h:438:15: error: ‘runtime_error’ is not a member of ‘std’
|
||||
---
|
||||
src/mpdpp.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/mpdpp.h b/src/mpdpp.h
|
||||
index a2bb79eb..abd3666c 100644
|
||||
--- a/src/mpdpp.h
|
||||
+++ b/src/mpdpp.h
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <exception>
|
||||
#include <random>
|
||||
#include <set>
|
||||
+#include <stdexcept>
|
||||
#include <vector>
|
||||
|
||||
#include <mpd/client.h>
|
Loading…
Reference in a new issue