extra/ceph fix

This commit is contained in:
Kevin Mihelich 2016-09-10 18:46:53 +00:00
parent a377682233
commit 418b2ebcf6
2 changed files with 21 additions and 2 deletions

View file

@ -3,6 +3,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove neon detection in configure
# - patch to remove incompatible gcc flag
pkgname=ceph
pkgver=10.2.2
@ -23,12 +24,14 @@ source=("http://ceph.com/download/$pkgname-$pkgver.tar.gz"
'ceph.sysusers'
'01-virtualenv2.patch'
'02-setup-python2.patch'
'no-neon.patch')
'no-neon.patch'
'no-omit-leaf-frame-pointer.diff')
md5sums=('5cba47af53b3b17002aad3c854e5405c'
'b3e24e3aa005a657ab475f84bfe3291a'
'a3f72dc8e97f9fd5708d52256bcd9e75'
'f11582acceeb6c1790518c3a5a29bb18'
'97d293b08d5d4b4a2db37030c28bc617')
'97d293b08d5d4b4a2db37030c28bc617'
'8c4af30de8c2dab89a8afa3ff8c03a5d')
prepare() {
cd $pkgname-$pkgver
@ -41,6 +44,9 @@ prepare() {
fi
done
:
if [[ $CARCH != "aarch64" ]]; then
patch -p1 -i ../no-omit-leaf-frame-pointer.diff
fi
}
build() {

View file

@ -0,0 +1,13 @@
diff -urN a/src/rocksdb/Makefile b/src/rocksdb/Makefile
--- a/src/rocksdb/Makefile 2016-06-14 05:44:41.000000000 -0600
+++ b/src/rocksdb/Makefile 2016-09-10 12:40:00.021152948 -0600
@@ -84,9 +84,6 @@
# compile with -O2 if debug level is not 2
ifneq ($(DEBUG_LEVEL), 2)
OPT += -O2 -fno-omit-frame-pointer
-ifneq ($(MACHINE),ppc64) # ppc64 doesn't support -momit-leaf-frame-pointer
-OPT += -momit-leaf-frame-pointer
-endif
endif
# if we're compiling for release, compile without debug code (-DNDEBUG) and