removed extra/haveged

This commit is contained in:
Kevin Mihelich 2019-09-08 20:36:36 +00:00
parent 0a6e59d212
commit 4190dec3f6
3 changed files with 0 additions and 88 deletions

View file

@ -1,50 +0,0 @@
# $Id$
# Maintainer: Christian Hesse <mail@eworm.de>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: kfgz <kfgz at interia dot pl>
# Contributor: pootzko <pootzko at gmail dot com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch from Alpine Linux to fix cache detection issues on ARM
pkgname=haveged
pkgver=1.9.4
pkgrel=3
pkgdesc='Entropy harvesting daemon using CPU timings'
arch=('x86_64')
url='https://github.com/jirka-h/haveged'
license=('GPL')
depends=('glibc')
validpgpkeys=('8F6B7293B03E5AC5762B65CE2E2F252B05CCA168') # Jirka Hladky <hladky.jiri@gmail.com>
source=("$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/$pkgname/archive/$pkgver.tar.gz"
"https://github.com/jirka-h/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz.asc"
'haveged.service'
'fix-cpu-cache-size-detection.patch')
sha256sums=('c4959d3cb1fa6391d16a3aa1ba4d82cd3a0d497206ae4b87d638088c0664e5aa'
'SKIP'
'1e78d296ebb5f4d46108094997c51e3fccf475f54d637f20212a3aa3730ef847'
'5aecfd72a1dbb9cc9b32d5677917d8a59dba7a2e021e31dee95f3f5b9e7ecf28')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../fix-cpu-cache-size-detection.patch
}
build() {
cd $pkgname-$pkgver
./configure \
--prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/bin
make
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -D -m0644 "${srcdir}"/haveged.service "$pkgdir"/usr/lib/systemd/system/haveged.service
}

View file

@ -1,15 +0,0 @@
Some ARM cpus does not report the cache size or say it is -1
diff --git a/src/havegetune.c b/src/havegetune.c
index f1a99f2..de39c53 100644
--- a/src/havegetune.c
+++ b/src/havegetune.c
@@ -795,6 +795,8 @@ static int vfs_configInfoCache(
ctype = vfs_configFile(pAnchor, path, vfs_configType);
strcpy(path+plen, "size");
size = vfs_configFile(pAnchor, path, vfs_configInt);
+ if (size == -1)
+ size = ctype == 'I' ? GENERIC_ICACHE : GENERIC_DCACHE;
cfg_cacheAdd(pAnchor, SRC_VFS_INDEX, pArgs[1], level, ctype, size);
}
}

View file

@ -1,23 +0,0 @@
[Unit]
Description=Entropy Harvesting Daemon
Documentation=man:haveged(8)
DefaultDependencies=no
ConditionVirtualization=!container
After=systemd-random-seed.service
Before=sysinit.target shutdown.target
[Service]
ExecStartPre=+/usr/bin/sysctl -w kernel.random.write_wakeup_threshold=1024
ExecStart=/usr/bin/haveged --Foreground --verbose=1
SuccessExitStatus=143
DynamicUser=on
AmbientCapabilities=CAP_SYS_ADMIN
NoNewPrivileges=on
PrivateDevices=on
PrivateNetwork=on
PrivateTmp=on
ProtectSystem=full
ProtectHome=on
[Install]
WantedBy=sysinit.target