mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/xbmc to 11.0-14
This commit is contained in:
parent
39ffe67b59
commit
419a603ed4
2 changed files with 48 additions and 1 deletions
|
@ -17,7 +17,7 @@ _prefix=/usr
|
|||
|
||||
pkgname=xbmc
|
||||
pkgver=11.0
|
||||
pkgrel=13
|
||||
pkgrel=14
|
||||
pkgdesc="A software media player and entertainment hub for digital media"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://xbmc.org"
|
||||
|
@ -39,9 +39,11 @@ optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
|||
install="${pkgname}.install"
|
||||
source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz"
|
||||
"xbmc.service"
|
||||
"cdio.patch"
|
||||
"alarm.patch")
|
||||
sha256sums=('1fe5d310c16138f26e2b13bc545604e95f48ace6c8636f23e77da402cd7b0b19'
|
||||
'82ebca3d66155f889a3d70311b000ac8b911b062af8df308d6a86aecc6b1b52b'
|
||||
'eef23b30b11acca317f71022df1091e35d8295138680618712f3ef6c719145ca'
|
||||
'6e4934e8d1bf82890679eca2fa78b3bc5942feedd9c012728a8d04c59be1651d')
|
||||
|
||||
build() {
|
||||
|
@ -53,6 +55,12 @@ build() {
|
|||
# fix lsb_release dependency
|
||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||
|
||||
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADER:' \
|
||||
lib/libid3tag/libid3tag/configure.ac \
|
||||
lib/libdvd/libdvdcss/configure.ac
|
||||
|
||||
patch -p1 <$srcdir/cdio.patch
|
||||
|
||||
# Bootstrapping XBMC
|
||||
./bootstrap
|
||||
|
||||
|
|
39
community/xbmc/cdio.patch
Normal file
39
community/xbmc/cdio.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
diff -wbBur xbmc-11.0/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp xbmc-11.0.my/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp
|
||||
--- xbmc-11.0/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp 2012-03-22 02:07:50.000000000 +0400
|
||||
+++ xbmc-11.0.my/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp 2013-01-09 14:40:10.670040454 +0400
|
||||
@@ -27,6 +27,10 @@
|
||||
#include "storage/MediaManager.h"
|
||||
#include "utils/log.h"
|
||||
|
||||
+#define CDTEXT_TITLE CDTEXT_FIELD_TITLE
|
||||
+#define CDTEXT_PERFORMER CDTEXT_FIELD_PERFORMER
|
||||
+#define CDTEXT_GENRE CDTEXT_FIELD_GENRE
|
||||
+
|
||||
using namespace MUSIC_INFO;
|
||||
|
||||
#ifdef HAS_DVD_DRIVE
|
||||
diff -wbBur xbmc-11.0/xbmc/storage/cdioSupport.cpp xbmc-11.0.my/xbmc/storage/cdioSupport.cpp
|
||||
--- xbmc-11.0/xbmc/storage/cdioSupport.cpp 2012-03-22 02:07:50.000000000 +0400
|
||||
+++ xbmc-11.0.my/xbmc/storage/cdioSupport.cpp 2013-01-09 14:51:40.276801092 +0400
|
||||
@@ -648,15 +648,18 @@
|
||||
CSingleLock lock(*m_cdio);
|
||||
|
||||
// Get the CD-Text , if any
|
||||
- cdtext_t *pcdtext = (cdtext_t *)::cdio_get_cdtext(cdio, trackNum);
|
||||
+ cdtext_t *pcdtext = (cdtext_t *)::cdio_get_cdtext(cdio);
|
||||
|
||||
if (pcdtext == NULL)
|
||||
return ;
|
||||
|
||||
// same ids used in libcdio and for our structure + the ids are consecutive make this copy loop safe.
|
||||
for (int i = 0; i < MAX_CDTEXT_FIELDS; i++)
|
||||
- if (pcdtext->field[i])
|
||||
- xcdt[(cdtext_field_t)i] = pcdtext->field[(cdtext_field_t)i];
|
||||
+ {
|
||||
+ char *data = cdtext_get(pcdtext, (cdtext_field_t)i, trackNum);
|
||||
+ if (data != NULL)
|
||||
+ xcdt[(cdtext_field_t)i] = data;
|
||||
+ }
|
||||
}
|
||||
|
||||
CCdInfo* CCdIoSupport::GetCdInfo(char* cDeviceFileName)
|
Loading…
Reference in a new issue