extra/thunderbird to 60.0-2

This commit is contained in:
Kevin Mihelich 2018-08-08 19:33:31 +00:00
parent 17d5803cf9
commit 41a2a75206
6 changed files with 17 additions and 186 deletions

View file

@ -1,48 +0,0 @@
From bbd48a5613c872883616884cfaf41665b0e4ec9b Mon Sep 17 00:00:00 2001
From: Ralph Giles <giles@mozilla.com>
Date: Fri, 10 Feb 2017 12:58:18 -0800
Subject: [PATCH] Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
We use the cheddar crate to generate a C header file
for our mp4parse_capi wrapper crate. Currently we
do this at code check-in time via update-rust.sh.
Cargo 0.18 and later will try to execute a build.rs
file in the crate source tree regardless of whether
it's specified in Cargo.toml so patching out that
line just results in 'crate cheddar not found'.
This change restores the old behaviour by substituting
a 'build = false' line instead.
We do have syntex vendored, but we don't currently build
it by default, so I prefer this solution to just vendoring
cheddar and generating the header at build time. The syntex
crate is quite large and adds significantly to our compile
time.
MozReview-Commit-ID: InJRRODWAdP
--HG--
extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
---
media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
index aee7ee947151a27c..d7e3f55119d3f4b6 100644
--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
@@ -18,6 +18,8 @@ exclude = [
"*.mp4",
]
+build = false
+
[dependencies]
byteorder = "1.0.0"
"mp4parse" = {version = "0.6.0", path = "../mp4parse"}
--
2.12.2

View file

@ -11,10 +11,11 @@
buildarch=12 buildarch=12
highmem=1 highmem=1
noautobuild=1
pkgname=thunderbird pkgname=thunderbird
pkgver=52.9.1 pkgver=60.0
pkgrel=1 pkgrel=2
pkgdesc="Standalone mail and news reader from mozilla.org" pkgdesc="Standalone mail and news reader from mozilla.org"
arch=(x86_64) arch=(x86_64)
license=(MPL GPL LGPL) license=(MPL GPL LGPL)
@ -22,21 +23,13 @@ url="https://www.mozilla.org/thunderbird/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
nss hunspell sqlite ttf-font libvpx icu) nss hunspell sqlite ttf-font libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
autoconf2.13) autoconf2.13 rust clang llvm)
optdepends=('libcanberra: sound support') optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags) options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
$pkgname.desktop $pkgname.desktop)
0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch sha256sums=('bd7da88dcc03c448a4e975b5a1d3e9bf466ec9151b1059392bcdb50955a22056'
rust-i686.patch fix-wifi-scanner.diff 'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827')
thunderbird-install-dir.patch no-crmf.diff)
sha256sums=('286fa71504e7184f3a41bcbdebf591bebe8e04dccbad1c93a47c6e72a7125c4d'
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
'413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
'a7317caba56e89932bd9e3b9352d94701dd9a419685057f238b1ded8dc0adcd7')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys) # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please # Note: These are for Arch Linux use ONLY. For your own distribution, please
@ -51,36 +44,21 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() { prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
cd $pkgname-$pkgver cd $pkgname-$pkgver
patch -Np1 -i ../thunderbird-install-dir.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
# Build with the rust targets we actually ship
patch -d mozilla -Np1 < ../rust-i686.patch
# https://bugs.archlinux.org/task/53890
patch -d mozilla -Np1 < ../0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
echo -n "$_google_api_key" >google-api-key echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key echo -n "$_mozilla_api_key" >mozilla-api-key
cat >.mozconfig <<END cat >.mozconfig <<END
ac_add_options --enable-application=mail ac_add_options --enable-application=comm/mail
ac_add_options --enable-calendar ac_add_options --enable-calendar
ac_add_options --prefix=/usr ac_add_options --prefix=/usr
ac_add_options --enable-release ac_add_options --enable-release
#ac_add_options --enable-gold ac_add_options --enable-linker=gold
#ac_add_options --enable-pie ac_add_options --enable-hardening
#ac_add_options --enable-optimize="-O2" ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# Branding # Branding
ac_add_options --enable-official-branding ac_add_options --enable-official-branding
@ -109,35 +87,19 @@ ac_add_options --disable-jack
ac_add_options --enable-startup-notification ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter ac_add_options --disable-crashreporter
ac_add_options --disable-updater ac_add_options --disable-updater
ac_add_options --disable-elf-hack
ac_add_options --disable-webrtc
END END
if [[ $CARCH == "armv7h" ]]; then
echo 'ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"' >> .mozconfig
else
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
fi
} }
build() { build() {
cd $pkgname-$pkgver cd $pkgname-$pkgver
./mach configure
# _FORTIFY_SOURCE causes configure failures ./mach build
CPPFLAGS+=" -O2" ./mach buildsymbols
export PATH="$srcdir/path:$PATH"
# Do PGO
#xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
# make -f client.mk build MOZ_PGO=1
make -f client.mk build
} }
package() { package() {
cd $pkgname-$pkgver cd $pkgname-$pkgver
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install DESTDIR="$pkgdir" ./mach install
_vendorjs="$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js" _vendorjs="$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END install -Dm644 /dev/stdin "$_vendorjs" <<END
@ -166,7 +128,7 @@ app.partner.archlinux=archlinux
END END
for i in 16 22 24 32 48 256; do for i in 16 22 24 32 48 256; do
install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \ install -Dm644 comm/mail/branding/thunderbird/default${i}.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done done

View file

@ -1,16 +0,0 @@
netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
index 182553e18fa6e104..6fa0a0b023d3e45f 100644
--- c/netwerk/wifi/nsWifiScannerDBus.cpp
+++ i/netwerk/wifi/nsWifiScannerDBus.cpp
@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
return NS_ERROR_FAILURE;
}
} else if (!strcmp(aFuncCall, "GetAll")) {
- const char* param = "";
+ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
return NS_ERROR_FAILURE;
}

View file

@ -1,39 +0,0 @@
diff -u -rN thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build
--- thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build 2017-05-09 23:35:13.000000000 +0200
+++ thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build 2017-06-14 01:51:36.686773132 +0200
@@ -8,7 +8,6 @@
if CONFIG['MOZ_SYSTEM_NSS']:
OS_LIBS += [l for l in CONFIG['NSS_LIBS'] if l.startswith('-L')]
- OS_LIBS += ['-lcrmf']
else:
USE_LIBS += [
# The dependency on nss is not real, but is required to force the
diff -u -rN thunderbird-52.1.1/mozilla/old-configure thunderbird-52.1.1-nocrmf/mozilla/old-configure
--- thunderbird-52.1.1/mozilla/old-configure 2017-05-09 23:35:35.000000000 +0200
+++ thunderbird-52.1.1-nocrmf/mozilla/old-configure 2017-06-14 01:50:28.726873231 +0200
@@ -10692,9 +10692,7 @@
fi
-if test -n "$MOZ_SYSTEM_NSS"; then
- NSS_LIBS="$NSS_LIBS -lcrmf"
-else
+if test -z "$MOZ_SYSTEM_NSS"; then
NSS_CFLAGS="-I${DIST}/include/nss"
fi
diff -u -rN thunderbird-52.1.1/mozilla/old-configure.in thunderbird-52.1.1-nocrmf/mozilla/old-configure.in
--- thunderbird-52.1.1/mozilla/old-configure.in 2017-05-09 23:35:22.000000000 +0200
+++ thunderbird-52.1.1-nocrmf/mozilla/old-configure.in 2017-06-14 01:50:50.953507079 +0200
@@ -2126,9 +2126,7 @@
AM_PATH_NSS(3.28.4, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
fi
-if test -n "$MOZ_SYSTEM_NSS"; then
- NSS_LIBS="$NSS_LIBS -lcrmf"
-else
+if test -z "$MOZ_SYSTEM_NSS"; then
NSS_CFLAGS="-I${DIST}/include/nss"
fi

View file

@ -1,16 +0,0 @@
build/moz.configure/rust.configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
index cd86b24153debb1b..44911715e25d95e3 100644
--- c/build/moz.configure/rust.configure
+++ i/build/moz.configure/rust.configure
@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
# OpenBSD
('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
# Linux
- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
+ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
# Linux
('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
# OS X and iOS

View file

@ -1,12 +0,0 @@
diff -upr comm-esr31.orig/mozilla/config/baseconfig.mk comm-esr31/mozilla/config/baseconfig.mk
--- comm-esr31.orig/mozilla/config/baseconfig.mk 2014-07-22 09:44:22.000000000 +0300
+++ comm-esr31/mozilla/config/baseconfig.mk 2014-07-22 09:46:45.000000000 +0300
@@ -4,7 +4,7 @@
# whether a normal build is happening or whether the check is running.
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
ifndef TOP_DIST
TOP_DIST = dist