extra/giac to 1.9.0.61-1

This commit is contained in:
Kevin Mihelich 2023-09-24 21:07:54 +00:00
parent ab1e5db3fc
commit 41b00c9def
2 changed files with 5 additions and 18 deletions

View file

@ -4,7 +4,7 @@
# - delete shipped x86 binary src/mkjs to force rebuild for ARM
pkgname=giac
_pkgver=1.9.0-59
_pkgver=1.9.0-61
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc='A free computer algebra system'
@ -40,16 +40,14 @@ makedepends=(hevea
texlive-mathscience)
optdepends=('perl: for pgiac')
source=(http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${pkgname}_$_pkgver.tar.gz
format-security.patch
fix-build.patch)
sha256sums=('c5b1ba93f42e758f46d541b28d9350f165eaf8c459bdea80f4a73a72d43c10de'
'04288944e408807a15aa502e1215087870d8921229c9f9890d862d3c9de337cd'
'184e158a59d6a07b03436d7fdc197f1422c0e6786b3d89c7a7231d10b193c5bb')
format-security.patch)
sha256sums=('129a3e1d949545775b2e728ee4d68757e5f9f446154fefcab63183dfa83ca9a8'
'04288944e408807a15aa502e1215087870d8921229c9f9890d862d3c9de337cd')
prepare() {
cd $pkgname-${pkgver%.*}
patch -p1 < ../format-security.patch # Fix -Werror=format-security errors
patch -p1 < ../fix-build.patch
# patch -p1 < ../fix-build.patch
rm -f src/mkjs # force rebuild for ARM
}

View file

@ -1,11 +0,0 @@
diff -ru giac-1.9.0.orig/src/first.h giac-1.9.0/src/first.h
--- giac-1.9.0.orig/src/first.h 2023-06-18 21:23:20.774912898 +0200
+++ giac-1.9.0/src/first.h 2023-06-18 21:24:54.712829079 +0200
@@ -29,6 +29,7 @@
#define GIAC_VERSION VERSION
#endif
//#include <stdint.h>
+#include <tuple>
// mingw now defines x86_64
#if (defined(__x86_64__) || defined(__arm64__)) && !defined __MINGW_H