extra/orc to 0.4.25-2

This commit is contained in:
Kevin Mihelich 2016-06-18 17:53:53 +00:00
parent 17922dafd3
commit 41cf8ed91b
2 changed files with 52 additions and 12 deletions

View file

@ -6,28 +6,36 @@
pkgname=orc
pkgver=0.4.25
pkgrel=1
pkgrel=2
pkgdesc="The Oil Runtime Compiler"
arch=('i686' 'x86_64')
license=('custom')
url="http://code.entropywave.com/projects/orc/"
url="https://gstreamer.freedesktop.org/projects/orc.html"
depends=('glibc')
source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz)
md5sums=('8582a28b15f53110c88d8043d9f55bcf')
source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz
fix-tests.patch)
md5sums=('8582a28b15f53110c88d8043d9f55bcf'
'0443f38fa7518a5d7de6c055a98365b7')
prepare() {
cd $pkgname-$pkgver
patch -Np1 -i ../fix-tests.patch
}
build () {
cd $pkgname-$pkgver
./configure --prefix=/usr --disable-static
make
cd $pkgname-$pkgver
./configure --prefix=/usr --disable-static
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname-$pkgver
make check
cd $pkgname-$pkgver
make check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}

32
extra/orc/fix-tests.patch Normal file
View file

@ -0,0 +1,32 @@
From c471352db4764bdcc24223338639e4c3f52b3e51 Mon Sep 17 00:00:00 2001
From: Pascal Terjan <pterjan@google.com>
Date: Wed, 4 May 2016 09:36:21 +0000
Subject: Fix test_parse with no executable backend
https://bugzilla.gnome.org/show_bug.cgi?id=765953
diff --git a/testsuite/test_parse.c b/testsuite/test_parse.c
index 65b17e9..87fa4ea 100644
--- a/testsuite/test_parse.c
+++ b/testsuite/test_parse.c
@@ -38,7 +38,7 @@ main (int argc, char *argv[])
printf ("%s\n", programs[i]->name);
orc_test_compare_output_full (programs[i], 0);
cres = orc_program_compile (programs[i]);
- if (cres != ORC_COMPILE_RESULT_OK) {
+ if (ORC_COMPILE_RESULT_IS_FATAL (cres)) {
fprintf (stderr, "compile error: %d\n", cres);
error = TRUE;
}
@@ -55,7 +55,7 @@ main (int argc, char *argv[])
printf ("%s\n", programs[i]->name);
orc_test_compare_output_full (programs[i], 0);
cres = orc_program_compile (programs[i]);
- if (cres != ORC_COMPILE_RESULT_OK) {
+ if (ORC_COMPILE_RESULT_IS_FATAL (cres)) {
fprintf (stderr, "compile error: %d\n", cres);
error = TRUE;
}
--
cgit v0.10.2