mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/omxplayer-git to 403.5337be8-2
This commit is contained in:
parent
d86b7e3dde
commit
41e80f9b50
2 changed files with 21 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
||||||
From d2eb946d05e0a7a58c5d3a7b8ec4e1d1a836c2a8 Mon Sep 17 00:00:00 2001
|
From 6439cd94f115feac6c7dfe2e48a33a2acb4f2e53 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Wed, 24 Sep 2014 08:47:14 -0600
|
Date: Wed, 24 Sep 2014 08:47:14 -0600
|
||||||
Subject: [PATCH] alarm fixes
|
Subject: [PATCH] alarm fixes
|
||||||
|
@ -6,7 +6,8 @@ Subject: [PATCH] alarm fixes
|
||||||
---
|
---
|
||||||
Makefile | 30 ++++++++++--------------------
|
Makefile | 30 ++++++++++--------------------
|
||||||
Makefile.include | 44 ++++----------------------------------------
|
Makefile.include | 44 ++++----------------------------------------
|
||||||
2 files changed, 14 insertions(+), 60 deletions(-)
|
omxplayer.cpp | 4 ++--
|
||||||
|
3 files changed, 16 insertions(+), 62 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 3615ff7..47d196b 100644
|
index 3615ff7..47d196b 100644
|
||||||
|
@ -117,6 +118,21 @@ index 58e9560..4789f10 100644
|
||||||
+CFLAGS += -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
|
+CFLAGS += -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
|
||||||
+LDFLAGS += -L/opt/vc/lib/
|
+LDFLAGS += -L/opt/vc/lib/
|
||||||
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
|
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
|
||||||
|
diff --git a/omxplayer.cpp b/omxplayer.cpp
|
||||||
|
index 3a417ca..c6f155d 100644
|
||||||
|
--- a/omxplayer.cpp
|
||||||
|
+++ b/omxplayer.cpp
|
||||||
|
@@ -90,8 +90,8 @@ bool m_osd = true;
|
||||||
|
bool m_no_keys = false;
|
||||||
|
std::string m_external_subtitles_path;
|
||||||
|
bool m_has_external_subtitles = false;
|
||||||
|
-std::string m_font_path = "/usr/share/fonts/truetype/freefont/FreeSans.ttf";
|
||||||
|
-std::string m_italic_font_path = "/usr/share/fonts/truetype/freefont/FreeSansOblique.ttf";
|
||||||
|
+std::string m_font_path = "/usr/share/fonts/TTF/FreeSans.ttf";
|
||||||
|
+std::string m_italic_font_path = "/usr/share/fonts/TTF/FreeSansOblique.ttf";
|
||||||
|
std::string m_dbus_name = "org.mpris.MediaPlayer2.omxplayer";
|
||||||
|
bool m_asked_for_font = false;
|
||||||
|
bool m_asked_for_italic_font = false;
|
||||||
--
|
--
|
||||||
2.2.1
|
2.3.1
|
||||||
|
|
||||||
|
|
|
@ -6,7 +6,7 @@ buildarch=20
|
||||||
|
|
||||||
pkgname=omxplayer-git
|
pkgname=omxplayer-git
|
||||||
pkgver=403.5337be8
|
pkgver=403.5337be8
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
||||||
arch=('arm' 'armv6h')
|
arch=('arm' 'armv6h')
|
||||||
url="https://github.com/popcornmix/omxplayer"
|
url="https://github.com/popcornmix/omxplayer"
|
||||||
|
@ -19,7 +19,7 @@ conflicts=('omxplayer' 'omxplayer-bin')
|
||||||
source=('git://github.com/popcornmix/omxplayer.git'
|
source=('git://github.com/popcornmix/omxplayer.git'
|
||||||
'0001-alarm-fixes.patch')
|
'0001-alarm-fixes.patch')
|
||||||
md5sums=('SKIP'
|
md5sums=('SKIP'
|
||||||
'ecf5782b2a3bffd4000f083e98a21478')
|
'13895e966d734d927bec43376a1c1de8')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd omxplayer
|
cd omxplayer
|
||||||
|
|
Loading…
Reference in a new issue