diff --git a/extra/ffmpeg/PKGBUILD b/extra/ffmpeg/PKGBUILD
index 8aacc92ae..9a133ef96 100644
--- a/extra/ffmpeg/PKGBUILD
+++ b/extra/ffmpeg/PKGBUILD
@@ -10,8 +10,8 @@
 #  - remove depends on aom, remove --enable-libaom
 
 pkgname=ffmpeg
-pkgver=4.2
-pkgrel=4
+pkgver=4.2.1
+pkgrel=1
 epoch=1
 pkgdesc='Complete solution to record, convert and stream audio and video'
 arch=(x86_64)
@@ -83,8 +83,14 @@ provides=(
   libswresample.so
   libswscale.so
 )
-source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver})
-sha256sums=('SKIP')
+source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=cbb3c9497549f8856d8cd37ac63af1406a784e58)
+sha256sums=(SKIP)
+
+pkgver() {
+  cd ffmpeg
+
+  git describe --tags | sed 's/^n//'
+}
 
 build() {
   cd ffmpeg
@@ -92,7 +98,7 @@ build() {
   [[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CONFIG='--host-cflags="-fPIC"'
 
   ./configure \
-    --prefix='/usr' \
+    --prefix=/usr \
     --disable-debug \
     --disable-static \
     --disable-stripping \