extra/meson to 0.61.0-4

This commit is contained in:
David Beauchamp 2022-01-13 12:06:50 -05:00
parent 0ba58b3901
commit 420d4ffbd1
2 changed files with 4 additions and 22 deletions

View file

@ -7,7 +7,7 @@
pkgname=meson
pkgver=0.61.0
pkgrel=3
pkgrel=4
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
arch=('any')
@ -24,7 +24,7 @@ source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${
https://github.com/mesonbuild/meson/commit/bcfb4d0f46608db46cd8881e2a02ba6c33ff066e.patch
https://github.com/mesonbuild/meson/commit/704e9802c9f424a57c32d9e63ececfece807529a.patch
https://github.com/mesonbuild/meson/commit/63593a55288ee5b89fc9c298dbc300f9c6adaba9.patch
fix-gdbus-codegen.diff
https://github.com/mesonbuild/meson/commit/bda11fe25d1efe688d251148cb7cf7939cd50433.patch
https://github.com/mesonbuild/meson/commit/9952446a2a28ea2b009f4b8b2a14ad50f0878bdd.patch
skip-test.diff
arch-meson)
@ -34,7 +34,7 @@ sha512sums=('ff739f767710c09a1b238f135c81bdb79675d06cec1b091503809cdbd71f0f92fd7
'8e943cecd9b4a43f690b9bae463f8cdb8dd4a53e6a9c4f9dc93ee0119ffae1d9964604fbc9180c7dda39790542b52ef30b6f76c1321ce493eb24d211895b15fa'
'f7b0d8e77af19cd666c1efcbed8767483efa4d2b58a08d9a01151f77dbcbd8047a6dfd95fa57146d565c0b7f404368efef6fdc096e127c640c66747641ecce3c'
'2fc23d7b1ac8320ffb3742a1299f69700b0ead212446aac9ca7d2c63874f4f2cd90e6739287814c61baaf00d92f9c99c714abac30b5b54e4362ca6476a32ca02'
'00e50d95e34ea15c65dc3976d36388571832bfcc32f1a01357d1eac73825fc5086eedd03238cd5365d81ecddf8d2bde8de4a0e59e54f0661b08879088f841b91'
'0d3181cae84c702060c34fb27b632bef46cca89829fa7cc7ec4bfe9650ad745d79caa593210838e91560eda05e5b752474d3cd093765bfe97a4c2fdd3d5767a9'
'cf59e2e2f6067fa512445c81f7e4b417c4fb20c720fbf84e3248bb40ff04a71ad18e20d86d28fc8b1c7ace4c3c2a0b9e9053c4a7870553eed7f0b2e69bd0f49d'
'994d88aaa7d9ad619885674352593826de198ef443c887fe6e9ecdcd84302eb04e0c396263404b4f16e447586f2b61f100643ba627803971070fa7b6baa75f78'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
@ -50,7 +50,7 @@ prepare() {
# gdbus-codegen fixes
patch -Np1 -i ../704e9802c9f424a57c32d9e63ececfece807529a.patch
patch -Np1 -i ../63593a55288ee5b89fc9c298dbc300f9c6adaba9.patch
patch -Np1 -i ../fix-gdbus-codegen.diff
patch -Np1 -i ../bda11fe25d1efe688d251148cb7cf7939cd50433.patch
# vapigen fixes
patch -Np1 -i ../9952446a2a28ea2b009f4b8b2a14ad50f0878bdd.patch

View file

@ -1,18 +0,0 @@
diff --git i/mesonbuild/modules/gnome.py w/mesonbuild/modules/gnome.py
index e5990f087..835ebfb5a 100644
--- i/mesonbuild/modules/gnome.py
+++ w/mesonbuild/modules/gnome.py
@@ -1477,9 +1477,10 @@ class GnomeModule(ExtensionModule):
build_by_default = kwargs['build_by_default']
# Annotations are a bit ugly in that they are a list of lists of strings...
- if kwargs['annotations']:
- cmd.append('--annotate')
- cmd.extend(kwargs['annotations'])
+ for i, a in enumerate(kwargs['annotations']):
+ if i % 3 == 0:
+ cmd.append('--annotate')
+ cmd.append(a)
targets = []
install_header = kwargs['install_header']