alarm/uboot-beagleboard to 2016.01-1

This commit is contained in:
Kevin Mihelich 2016-02-23 03:29:07 +00:00
parent 340b11d678
commit 427eb7a1a3
2 changed files with 11 additions and 11 deletions

View file

@ -1,4 +1,4 @@
From 7f420c8c4a9ad883d5f8699a2f37797080ae5683 Mon Sep 17 00:00:00 2001
From 99865c96edab6abba923bd6084309085712eb91d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 Jun 2015 18:24:03 -0600
Subject: [PATCH] arch linux arm modifications
@ -10,7 +10,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
2 files changed, 93 insertions(+), 117 deletions(-)
diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
index 7b37fbe..ff986ff 100644
index ff317ef..8c1639b 100644
--- a/board/ti/beagle/beagle.c
+++ b/board/ti/beagle/beagle.c
@@ -56,6 +56,7 @@
@ -111,10 +111,10 @@ index 7b37fbe..ff986ff 100644
switch (get_board_revision()) {
case REVISION_XM_AB:
diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
index f25a940..9f15cf1 100644
index 65f08a1..5058c3f 100644
--- a/include/configs/omap3_beagle.h
+++ b/include/configs/omap3_beagle.h
@@ -90,6 +90,12 @@
@@ -91,6 +91,12 @@
#define CONFIG_USB_ETHER_MCS7830
#define CONFIG_USB_ETHER_SMSC95XX
@ -127,7 +127,7 @@ index f25a940..9f15cf1 100644
/* GPIO banks */
#define CONFIG_OMAP3_GPIO_5 /* GPIO128..159 is in GPIO bank 5 */
#define CONFIG_OMAP3_GPIO_6 /* GPIO160..191 is in GPIO bank 6 */
@@ -129,50 +135,62 @@
@@ -125,50 +131,62 @@
/* devices */
#define CONFIG_EXTRA_ENV_SETTINGS \
@ -153,7 +153,7 @@ index f25a940..9f15cf1 100644
- "defaultdisplay=dvi\0" \
+ "fdtfile=undefined\0" \
+ "bootpart=0:1\0" \
+ "bootdir=/\0" \
+ "bootdir=\0" \
+ "fdtdir=/dtbs\0" \
+ "bootfile=zImage\0" \
+ "rdfile=initramfs-linux.img\0" \
@ -229,7 +229,7 @@ index f25a940..9f15cf1 100644
"findfdt=" \
"if test $beaglerev = AxBx; then " \
"setenv fdtfile omap3-beagle.dtb; fi; " \
@@ -185,81 +203,11 @@
@@ -181,81 +199,11 @@
"if test $beaglerev = xMC; then " \
"setenv fdtfile omap3-beagle-xm.dtb; fi; " \
"if test $fdtfile = undefined; then " \
@ -315,5 +315,5 @@ index f25a940..9f15cf1 100644
/*
* OMAP3 has 12 GP timers, they can be driven by the system clock
--
2.4.2
2.7.0

View file

@ -4,7 +4,7 @@
buildarch=4
pkgname=uboot-beagleboard
pkgver=2015.04
pkgver=2016.01
pkgrel=1
pkgdesc="U-Boot for BeagleBoard and BeagleBoard-xM"
arch=('armv7h')
@ -14,8 +14,8 @@ makedepends=('git' 'bc')
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'uEnv.txt')
md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
'64860a464158923815b052e997214867'
md5sums=('7d4f65fd43d4d706f5c5650e020d899d'
'373fac8aefcf8bea149ecb60162f0904'
'd41d8cd98f00b204e9800998ecf8427e')
prepare() {