mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/julius
This commit is contained in:
parent
55ac57a516
commit
42acf7aaae
3 changed files with 151 additions and 0 deletions
26
community/julius/0001-AArch64-cpuid-fix.patch
Normal file
26
community/julius/0001-AArch64-cpuid-fix.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From 06b026817594649a0e12f3687d5a4e400e3a91c4 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 14 Nov 2016 20:51:49 -0700
|
||||
Subject: [PATCH] AArch64 cpuid fix
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
libsent/src/phmm/calc_dnn.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libsent/src/phmm/calc_dnn.c b/libsent/src/phmm/calc_dnn.c
|
||||
index bfd741d..27d3c7c 100644
|
||||
--- a/libsent/src/phmm/calc_dnn.c
|
||||
+++ b/libsent/src/phmm/calc_dnn.c
|
||||
@@ -12,7 +12,7 @@
|
||||
#ifdef _WIN32
|
||||
#include <intrin.h>
|
||||
#else
|
||||
-#ifndef __arm__
|
||||
+#if !defined(__arm__) && !defined(__aarch64__)
|
||||
#include <cpuid.h>
|
||||
#endif
|
||||
#endif /* _WIN32 */
|
||||
--
|
||||
2.10.2
|
||||
|
61
community/julius/PKGBUILD
Normal file
61
community/julius/PKGBUILD
Normal file
|
@ -0,0 +1,61 @@
|
|||
# $Id$
|
||||
# Maintainer: Evgeniy Alekseev <arcanis.arch at gmail dot com>
|
||||
# Contributor: Matt Harrison <matt at mistbyte dot com>
|
||||
# Contributor: Muhammad Qadri <Muhammad dot A dot Qadri at gmail dot com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for AArch64
|
||||
|
||||
pkgname=julius
|
||||
pkgver=4.4.2
|
||||
pkgrel=2
|
||||
pkgdesc="A high-performance, two-pass large vocabulary continuous speech recognition decoder software"
|
||||
arch=("i686" "x86_64")
|
||||
url="http://julius.sourceforge.jp/"
|
||||
license=("custom")
|
||||
depends=("libpulse" "sdl2")
|
||||
optdepends=("voxforge-am-julius: acoustic models")
|
||||
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/julius-speech/julius/archive/v${pkgver}.tar.gz"
|
||||
"configure.patch"
|
||||
'0001-AArch64-cpuid-fix.patch')
|
||||
md5sums=('1891077bbca02dc9d6d6368c1efb2e4c'
|
||||
'9fe2a29fdec779104f69539ad4d1cce0'
|
||||
'e60b17977890c9407993d30c49d6a30d')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
# configure error
|
||||
patch -p1 -i "${srcdir}/configure.patch"
|
||||
|
||||
# aarch64 fix
|
||||
patch -p1 -i "${srcdir}/0001-AArch64-cpuid-fix.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
# redefine makeflags, coz it could not build in parallel
|
||||
export MAKEFLAGS="-j1"
|
||||
|
||||
cd "${srcdir}/${pkgname}-${pkgver}/"
|
||||
./configure \
|
||||
--prefix="/usr/" \
|
||||
--mandir='${prefix}/share/man'\
|
||||
--enable-words-int \
|
||||
--enable-msd \
|
||||
--enable-gmm-vad \
|
||||
--enable-decoder-vad \
|
||||
--enable-power-reject \
|
||||
--enable-wpair
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}/"
|
||||
|
||||
# leave static libraries since julius does not support
|
||||
# shared ones at the moment. See also FS#50599
|
||||
make prefix="${pkgdir}/usr" install
|
||||
install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/julius/LICENSE"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
64
community/julius/configure.patch
Normal file
64
community/julius/configure.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
diff -ruN julius-4.4-orig/jcontrol/configure julius-4.4/jcontrol/configure
|
||||
--- julius-4.4-orig/jcontrol/configure 2016-09-04 16:03:39.610663560 +0300
|
||||
+++ julius-4.4/jcontrol/configure 2016-09-04 16:05:14.054157193 +0300
|
||||
@@ -380,13 +380,6@@
|
||||
;;
|
||||
|
||||
*)
|
||||
- if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
|
||||
- echo "configure: warning: $ac_option: invalid host type" 1>&2
|
||||
- fi
|
||||
- if test "x$nonopt" != xNONE; then
|
||||
- { echo "configure: error: can only configure for one host and one target at a time" 1>&2; exit 1; }
|
||||
- fi
|
||||
- nonopt="$ac_option"
|
||||
;;
|
||||
|
||||
esac
|
||||
diff -ruN julius-4.4-orig/mkgshmm/configure julius-4.4/mkgshmm/configure
|
||||
--- julius-4.4-orig/mkgshmm/configure 2016-09-04 16:03:39.660661881 +0300
|
||||
+++ julius-4.4/mkgshmm/configure 2016-09-04 16:04:55.021463305 +0300
|
||||
@@ -380,13 +380,6 @@
|
||||
;;
|
||||
|
||||
*)
|
||||
- if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
|
||||
- echo "configure: warning: $ac_option: invalid host type" 1>&2
|
||||
- fi
|
||||
- if test "x$nonopt" != xNONE; then
|
||||
- { echo "configure: error: can only configure for one host and one target at a time" 1>&2; exit 1; }
|
||||
- fi
|
||||
- nonopt="$ac_option"
|
||||
;;
|
||||
|
||||
esac
|
||||
diff -ruN julius-4.4-orig/libjulius/Makefile.in julius-4.4/libjulius/Makefile.in
|
||||
--- julius-4.4-orig/libjulius/Makefile.in 2016-09-04 16:35:54.009006591 +0300
|
||||
+++ julius-4.4/libjulius/Makefile.in 2016-09-04 16:35:13.733693061 +0300
|
||||
@@ -94,12 +94,12 @@
|
||||
|
||||
install.lib: $(TARGET)
|
||||
${INSTALL} -d ${libdir}
|
||||
${INSTALL_DATA} $(TARGET) ${libdir}
|
||||
- ${INSTALL_DATA} $(PKGCONF_FILE) ${pkgconfigdir}
|
||||
+ ${INSTALL_DATA} -D $(PKGCONF_FILE) ${pkgconfigdir}/libjulius.pc
|
||||
|
||||
install.include:
|
||||
${INSTALL} -d ${includedir}/julius
|
||||
${INSTALL_DATA} include/julius/*.h ${includedir}/julius
|
||||
|
||||
install.bin: libjulius-config-dist
|
||||
${INSTALL} -d ${bindir}
|
||||
diff -ruN julius-4.4.1-orig/libsent/Makefile.in julius-4.4.1/libsent/Makefile.in
|
||||
--- julius-4.4.1-orig/libsent/Makefile.in 2016-09-07 18:01:52.948127111 +0300
|
||||
+++ julius-4.4.1/libsent/Makefile.in 2016-09-07 18:03:50.985347850 +0300
|
||||
@@ -152,8 +152,8 @@
|
||||
|
||||
install.lib: $(TARGET)
|
||||
${INSTALL} -d ${libdir}
|
||||
${INSTALL_DATA} $(TARGET) ${libdir}
|
||||
- ${INSTALL_DATA} $(PKGCONF_FILE) ${pkgconfigdir}
|
||||
+ ${INSTALL_DATA} -D $(PKGCONF_FILE) ${pkgconfigdir}/libsent.pc
|
||||
|
||||
install.include:
|
||||
${INSTALL} -d ${includedir}/sent
|
Loading…
Reference in a new issue