mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/libunwind to 1.2-1
This commit is contained in:
parent
159992f188
commit
42bd1bdbaf
3 changed files with 14 additions and 2597 deletions
|
@ -1,11 +0,0 @@
|
|||
--- a/include/dwarf_i.h
|
||||
+++ b/include/dwarf_i.h
|
||||
@@ -20,7 +20,7 @@
|
||||
extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
|
||||
/* REG is evaluated multiple times; it better be side-effects free! */
|
||||
# define dwarf_to_unw_regnum(reg) \
|
||||
- (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
||||
+ (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
||||
#endif
|
||||
|
||||
#ifdef UNW_LOCAL_ONLY
|
|
@ -1,55 +1,45 @@
|
|||
# $id$
|
||||
# Maintainer: Sébastien Luttringer
|
||||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Sébastien Luttringer
|
||||
# Contributor: Lawrence Lee <valheru@facticius.net>
|
||||
# Contributor: Phillip Marvin <phillip.marvin@gmail.com>
|
||||
# Contributor: keystone <phillip.marvin@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - aarch64 support patch
|
||||
# - build v5 with system libatomic_ops
|
||||
|
||||
pkgname=libunwind
|
||||
pkgver=1.1
|
||||
pkgrel=3
|
||||
pkgver=1.2
|
||||
pkgrel=1
|
||||
pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.nongnu.org/libunwind/'
|
||||
license=('GPL')
|
||||
depends=('glibc' 'xz')
|
||||
depends_arm=('libatomic_ops')
|
||||
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
|
||||
'001-invalid-dwarf-opcodes-can-cause-references-beyond.patch'
|
||||
'libunwind-aarch64.patch')
|
||||
md5sums=('fb4ea2f6fbbe45bf032cd36e586883ce'
|
||||
'73db2376e195a716f271ebce6bb7e5c0'
|
||||
'5dd4c2661baa949389259a027d3b89e2')
|
||||
|
||||
prepare() {
|
||||
patch -p1 -d $pkgname-$pkgver < 001-invalid-dwarf-opcodes-can-cause-references-beyond.patch
|
||||
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../libunwind-aarch64.patch
|
||||
autoreconf -fi
|
||||
}
|
||||
makedepends=('texlive-core')
|
||||
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
|
||||
sha512sums=('985d0817944e3cafd99aaa5642862d878972e0851f7954289247e808c9319f399ca29342395f0571cb6568a1104a82bd92d585936f2ca888dda37ac796fde0d4'
|
||||
'SKIP')
|
||||
validpgpkeys=('5C96BDEAF5F47FB02BD4F6B965D98560914F3F48' # Arun Sharma
|
||||
'1675C8DA2EF907FB116EB709EC52B396E6874AF2') # Dave Watson
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
[[ $CARCH == "arm" ]] && LDFLAGS+=" -latomic_ops" && CFLAGS+=" -DAO_USE_PTHREAD_DEFS=1"
|
||||
|
||||
./configure CFLAGS="$CFLAGS -U_FORTIFY_SOURCE" --prefix=/usr
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
# This function is ``supposed'' to fail. Upstream know, but haven't fixed it.
|
||||
make check || return 0
|
||||
make check || :
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir/" install
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue