mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webengine to 5.13.0-1
This commit is contained in:
parent
4e740e7425
commit
42cbd6b4d5
2 changed files with 4 additions and 91 deletions
|
@ -8,7 +8,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.12.4
|
||||
_qtver=5.13.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
|
@ -17,29 +17,20 @@ license=('LGPL3' 'LGPL2.1' 'BSD')
|
|||
pkgdesc='Provides support for web applications using the Chromium browser project'
|
||||
depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss'
|
||||
'libevent' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg' 're2' 'libvpx')
|
||||
makedepends=('python2' 'git' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
|
||||
makedepends=('python2' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
qtwebengine-harmony.patch qtwebengine-glibc-2.29.patch
|
||||
qtwebengine-glibc-2.29.patch
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('fccf5c945412c19c3805323211b504ac8becbf191c638a2dc85ec91abfb1b331'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
sha256sums=('e0af82ecee1ab41b6732697f667b98b7b0c53164bebcfaad8070e88b2e064efe'
|
||||
'dd791f154b48e69cd47fd94753c45448655b529590995fd71ac1591c53a3d60c'
|
||||
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
# Hack to force using python2
|
||||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
cd ${_pkgfqn}
|
||||
|
||||
# FreeType 2.8.1
|
||||
patch -Np1 -i ../qtwebengine-harmony.patch
|
||||
|
||||
cd src/3rdparty/chromium
|
||||
patch -p1 -i "$srcdir"/qtwebengine-glibc-2.29.patch # Fix PPAPI plugins with glibc 2.29
|
||||
|
||||
|
@ -50,7 +41,6 @@ prepare() {
|
|||
build() {
|
||||
cd build
|
||||
|
||||
export PATH="$srcdir/bin:$PATH"
|
||||
qmake ../${_pkgfqn} -- \
|
||||
-proprietary-codecs \
|
||||
-system-ffmpeg \
|
||||
|
|
|
@ -1,77 +0,0 @@
|
|||
--- qtwebengine-opensource-src-5.9.1/src/3rdparty/chromium/third_party/skia/src/ports/SkFontHost_FreeType.cpp.orig 2017-10-10 17:42:06.956950985 +0200
|
||||
+++ qtwebengine-opensource-src-5.9.1/src/3rdparty/chromium/third_party/skia/src/ports/SkFontHost_FreeType.cpp 2017-10-10 17:46:05.824187787 +0200
|
||||
@@ -99,8 +99,6 @@
|
||||
FreeTypeLibrary()
|
||||
: fGetVarDesignCoordinates(nullptr)
|
||||
, fLibrary(nullptr)
|
||||
- , fIsLCDSupported(false)
|
||||
- , fLCDExtra(0)
|
||||
{
|
||||
if (FT_New_Library(&gFTMemory, &fLibrary)) {
|
||||
return;
|
||||
@@ -147,12 +145,7 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
- // Setup LCD filtering. This reduces color fringes for LCD smoothed glyphs.
|
||||
- // The default has changed over time, so this doesn't mean the same thing to all users.
|
||||
- if (FT_Library_SetLcdFilter(fLibrary, FT_LCD_FILTER_DEFAULT) == 0) {
|
||||
- fIsLCDSupported = true;
|
||||
- fLCDExtra = 2; //Using a filter adds one full pixel to each side.
|
||||
- }
|
||||
+ FT_Library_SetLcdFilter(fLibrary, FT_LCD_FILTER_DEFAULT);
|
||||
}
|
||||
~FreeTypeLibrary() {
|
||||
if (fLibrary) {
|
||||
@@ -161,8 +153,6 @@
|
||||
}
|
||||
|
||||
FT_Library library() { return fLibrary; }
|
||||
- bool isLCDSupported() { return fIsLCDSupported; }
|
||||
- int lcdExtra() { return fLCDExtra; }
|
||||
|
||||
// FT_Get_{MM,Var}_{Blend,Design}_Coordinates were added in FreeType 2.7.1.
|
||||
// Prior to this there was no way to get the coordinates out of the FT_Face.
|
||||
@@ -173,8 +163,6 @@
|
||||
|
||||
private:
|
||||
FT_Library fLibrary;
|
||||
- bool fIsLCDSupported;
|
||||
- int fLCDExtra;
|
||||
|
||||
// FT_Library_SetLcdFilterWeights was introduced in FreeType 2.4.0.
|
||||
// The following platforms provide FreeType of at least 2.4.0.
|
||||
@@ -704,17 +692,6 @@
|
||||
rec->fTextSize = SkIntToScalar(1 << 14);
|
||||
}
|
||||
|
||||
- if (isLCD(*rec)) {
|
||||
- // TODO: re-work so that FreeType is set-up and selected by the SkFontMgr.
|
||||
- SkAutoMutexAcquire ama(gFTMutex);
|
||||
- ref_ft_library();
|
||||
- if (!gFTLibrary->isLCDSupported()) {
|
||||
- // If the runtime Freetype library doesn't support LCD, disable it here.
|
||||
- rec->fMaskFormat = SkMask::kA8_Format;
|
||||
- }
|
||||
- unref_ft_library();
|
||||
- }
|
||||
-
|
||||
SkPaint::Hinting h = rec->getHinting();
|
||||
if (SkPaint::kFull_Hinting == h && !isLCD(*rec)) {
|
||||
// collapse full->normal hinting if we're not doing LCD
|
||||
@@ -1115,11 +1092,11 @@
|
||||
void SkScalerContext_FreeType::updateGlyphIfLCD(SkGlyph* glyph) {
|
||||
if (isLCD(fRec)) {
|
||||
if (fLCDIsVert) {
|
||||
- glyph->fHeight += gFTLibrary->lcdExtra();
|
||||
- glyph->fTop -= gFTLibrary->lcdExtra() >> 1;
|
||||
+ glyph->fHeight += 2;
|
||||
+ glyph->fTop -= 1;
|
||||
} else {
|
||||
- glyph->fWidth += gFTLibrary->lcdExtra();
|
||||
- glyph->fLeft -= gFTLibrary->lcdExtra() >> 1;
|
||||
+ glyph->fWidth += 2;
|
||||
+ glyph->fLeft -= 1;
|
||||
}
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue