mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/xine-lib: patch to section off x86 code
This commit is contained in:
parent
e34ac810f3
commit
42f39d1a7a
2 changed files with 52 additions and 2 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - disabled vdpau
|
||||
# - patch to section off x86 code
|
||||
|
||||
pkgname=xine-lib
|
||||
pkgver=1.2.2
|
||||
|
@ -32,11 +33,14 @@ optdepends=('imagemagick: for using the imagemagick plugin' \
|
|||
'libbluray: for using the bluray plugin' \
|
||||
'gnome-vfs: for using the gnome-vfs plugin')
|
||||
options=('!libtool')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.xz)
|
||||
sha1sums=('a349cbb0b72256bb262377796a022dcf63829b4c')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.xz
|
||||
alarm.patch)
|
||||
sha1sums=('a349cbb0b72256bb262377796a022dcf63829b4c'
|
||||
'b0ffa9e139b63c178f4157ae4f442126b4e3664d')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
patch -p1 -i "${srcdir}/alarm.patch"
|
||||
./configure --prefix=/usr --with-wavpack --disable-vdpau --disable-optimizations
|
||||
make
|
||||
}
|
||||
|
|
46
extra/xine-lib/alarm.patch
Normal file
46
extra/xine-lib/alarm.patch
Normal file
|
@ -0,0 +1,46 @@
|
|||
# HG changeset patch
|
||||
# User Petri Hintukainen <phintuka@...>
|
||||
# Date 1339310702 -10800
|
||||
# Node ID b0df4b6003ad2b7454059c2d82ef7f8f29e48e9e
|
||||
# Branch default
|
||||
# Parent 52a99e60c2c9aa7e03be894b4396f229f881025c
|
||||
Fix building on non-x86 systems
|
||||
|
||||
diff --git a/src/post/deinterlace/plugins/greedy2frame_template.c b/src/post/deinterlace/plugins/greedy2frame_template.c
|
||||
--- a/src/post/deinterlace/plugins/greedy2frame_template.c
|
||||
+++ b/src/post/deinterlace/plugins/greedy2frame_template.c
|
||||
@@ -85,6 +85,7 @@
|
||||
*/
|
||||
|
||||
|
||||
+#if defined(ARCH_X86) || defined(ARCH_X86_64)
|
||||
#if !defined(MASKS_DEFINED)
|
||||
#define MASKS_DEFINED
|
||||
static const mmx_t Mask = { uq: 0x7f7f7f7f7f7f7f7fll };
|
||||
@@ -92,6 +93,7 @@
|
||||
static const mmx_t GreedyTwoFrameThreshold = { ub: {TP, TP, TP, TP} };
|
||||
#undef TP
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#if defined(IS_MMXEXT)
|
||||
static void DeinterlaceGreedy2Frame_MMXEXT(uint8_t *output, int outstride,
|
||||
--git a/src/post/deinterlace/plugins/greedy2frame_template_sse2.c b/src/post/deinterlace/plugins/greedy2frame_template_sse2.c
|
||||
--- a/src/post/deinterlace/plugins/greedy2frame_template_sse2.c
|
||||
+++ b/src/post/deinterlace/plugins/greedy2frame_template_sse2.c
|
||||
@@ -84,11 +84,12 @@
|
||||
** B0 | | B1 | |
|
||||
*/
|
||||
|
||||
-
|
||||
+#if defined(ARCH_X86) || defined(ARCH_X86_64)
|
||||
static const sse_t Mask128 = { uq: { 0x7f7f7f7f7f7f7f7fll, 0x7f7f7f7f7f7f7f7fll} };
|
||||
#define TP GREEDYTWOFRAMETHRESHOLD, GREEDYTWOFRAMETHRESHOLD2
|
||||
static const sse_t GreedyTwoFrameThreshold128 = { ub: {TP, TP, TP, TP, TP, TP, TP, TP} };
|
||||
#undef TP
|
||||
+#endif
|
||||
|
||||
static void DeinterlaceGreedy2Frame_SSE2(uint8_t *output, int outstride,
|
||||
deinterlace_frame_data_t *data,
|
||||
|
||||
|
Loading…
Reference in a new issue