extra/firefox: Fix regression on aarch64 (98.0.1-1.1)

Firefox 98+ fails to draw its window on aarch64.
Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1757571

Also add a hack to remove the psutil version cap, since otherwise it
fails to build with the latest python-psutil version (for no reason).
This commit is contained in:
Hector Martin 2022-03-15 09:24:13 -04:00 committed by Kevin Mihelich
parent 0e503f2213
commit 434abe24fa
3 changed files with 3316 additions and 1 deletions

View file

@ -11,7 +11,7 @@ highmem=1
pkgname=firefox
pkgver=98.0.1
pkgrel=1
pkgrel=1.1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -29,10 +29,14 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip !lto !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
build-arm-libopus.patch
revert-crossbeam-crates-upgrade.patch
psutil-remove-version-cap.patch
$pkgname.desktop identity-icons-brand.svg)
sha256sums=('f8de2f514d94cad25a2c8a5d219399de5c05a907607d51c5c5235a8bc9bb361c'
'SKIP'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'56bd09bfd2fa594c2af7dbe923d72bed9da23b7c001f923bf33784554e323541'
'2bb0ac385b54972eb3e665ac70fb13565ed9da77b33349b844b2e0ad4948cff5'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -122,6 +126,8 @@ END
export LDFLAGS+=" -Wl,--no-keep-memory"
export RUSTFLAGS="-Cdebuginfo=0"
patch -p1 -i ../build-arm-libopus.patch
patch -p1 -i ../revert-crossbeam-crates-upgrade.patch
patch -p1 -i ../psutil-remove-version-cap.patch
}
build() {

View file

@ -0,0 +1,9 @@
--- firefox-98.0.1/build/mach_virtualenv_packages.txt.old 2022-03-15 09:22:23.844188180 -0400
+++ firefox-98.0.1/build/mach_virtualenv_packages.txt 2022-03-15 09:22:31.767183949 -0400
@@ -133,5 +133,5 @@
# Mach gracefully handles the case where `psutil` is unavailable.
# We aren't (yet) able to pin packages in automation, so we have to
# support down to the oldest locally-installed version (5.4.2).
-pypi-optional:psutil>=5.4.2,<=5.8.0:telemetry will be missing some data
+pypi-optional:psutil>=5.4.2:telemetry will be missing some data
pypi-optional:zstandard>=0.11.1,<=0.17.0:zstd archives will not be possible to extract

File diff suppressed because it is too large Load diff