mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
Merge pull request #931 from CrawX/enablecec
core/linux-wandboard enable cec
This commit is contained in:
commit
434f0cbefd
2 changed files with 38 additions and 3 deletions
|
@ -9,7 +9,7 @@ _srcname=linux-${_commit}
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="i.MX6 Wandboard"
|
||||
pkgver=3.10.17
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -17,10 +17,17 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
|||
options=('!strip')
|
||||
source=("https://github.com/wandboard-org/linux/archive/${_commit}.tar.gz"
|
||||
'0001-Swap-usdhc1-and-usdhc3.patch'
|
||||
'config')
|
||||
'config'
|
||||
'https://github.com/wolfgar/linux-linaro-stable-mx6/commit/74fc2e85c080b0ddc2a4b2565eda97c55300303d.patch'
|
||||
'https://github.com/wolfgar/linux-linaro-stable-mx6/commit/76796e32b20dd8f34aadad8fd91672017d143812.patch'
|
||||
'enable-cec.patch')
|
||||
|
||||
md5sums=('e10cf2d6b0e82303be6ea384aa2880fb'
|
||||
'1edf745b39c715206fbe327c60f6cf76'
|
||||
'87706fcb5d01bf5a1722c6c9de5be83f')
|
||||
'87706fcb5d01bf5a1722c6c9de5be83f'
|
||||
'405499490b9a83adea6e8d911af2eb7e'
|
||||
'20b58d28255361e6f0b4fb0ef9c04647'
|
||||
'ecb5cb4aa94aeb2ad6a643cc057e3192')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -29,6 +36,13 @@ prepare() {
|
|||
|
||||
patch -p1 -i ../0001-Swap-usdhc1-and-usdhc3.patch
|
||||
|
||||
# add cec driver patches
|
||||
patch -Np1 < ../74fc2e85c080b0ddc2a4b2565eda97c55300303d.patch
|
||||
patch -Np1 < ../76796e32b20dd8f34aadad8fd91672017d143812.patch
|
||||
|
||||
# enable cec in dts
|
||||
patch -Np1 -l < ../enable-cec.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
|
|
21
core/linux-wandboard/enable-cec.patch
Normal file
21
core/linux-wandboard/enable-cec.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
ff --git a/arch/arm/boot/dts/imx6qdl-wandboard.dtsi.orig b/arch/arm/boot/dts/imx6qdl-wandboard.dtsi
|
||||
index 30f197f..7359aea 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-wandboard.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-wandboard.dtsi
|
||||
@@ -228,10 +228,16 @@
|
||||
fsl,phy_reg_vlev = <0x0294>;
|
||||
fsl,phy_reg_cksymtx = <0x800d>;
|
||||
status = "okay";
|
||||
};
|
||||
|
||||
+&hdmi_cec {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_hdmi_cec_2>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
&i2c1 {
|
||||
clock-frequency = <100000>;
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&pinctrl_i2c1_1>;
|
||||
status = "okay";
|
Loading…
Reference in a new issue