mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/python-debugpy to 1.6.4-1
This commit is contained in:
parent
3ffd71ac6b
commit
4364854320
2 changed files with 3 additions and 19 deletions
|
@ -6,7 +6,7 @@
|
|||
|
||||
_pipname=debugpy
|
||||
pkgname=python-$_pipname
|
||||
pkgver=1.6.3
|
||||
pkgver=1.6.4
|
||||
pkgrel=1
|
||||
pkgdesc='An implementation of the Debug Adapter Protocol for Python'
|
||||
arch=(x86_64)
|
||||
|
@ -14,17 +14,13 @@ url='https://aka.ms/debugpy'
|
|||
license=(EPL MIT)
|
||||
depends=(python)
|
||||
makedepends=(python-setuptools)
|
||||
source=(https://github.com/microsoft/debugpy/archive/v$pkgver/$pkgname-$pkgver.tar.gz
|
||||
fix-build.patch)
|
||||
sha256sums=('ddc10bf05903d1b4037a5ba7a511b0c5f188bdaf8f1c95a0bace505a9ce709fc'
|
||||
'a86e1e1a5a4d7a585c8185721863f563233b680c36fa35d65bfbff11abd519bc')
|
||||
source=(https://github.com/microsoft/debugpy/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
|
||||
sha256sums=('eede498ee6efde32eb3799fc57e9e279159facc11c63a66f28295f00f42efa5b')
|
||||
|
||||
prepare() {
|
||||
cd $_pipname-$pkgver
|
||||
# remove precompiled libs
|
||||
rm src/debugpy/_vendored/pydevd/pydevd_attach_to_process/*.{so,dll,dylib,exe,pdb}
|
||||
|
||||
patch -p1 -i ../fix-build.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff --git a/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h b/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
|
||||
index 6d39865e..04790698 100644
|
||||
--- a/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
|
||||
+++ b/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
|
||||
@@ -18,6 +18,7 @@
|
||||
#define __PYTHON_H__
|
||||
|
||||
#include "../common/py_version.hpp"
|
||||
+#include <cstdint>
|
||||
|
||||
#ifndef _WIN32
|
||||
typedef unsigned int DWORD;
|
Loading…
Reference in a new issue