mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/docker to 0.7.3-1 + arm patch
This commit is contained in:
parent
899c9e6c8c
commit
439e344338
2 changed files with 21 additions and 4 deletions
|
@ -1,10 +1,10 @@
|
|||
# $Id$
|
||||
# Maintainer: Sébastien "Seblu" Luttringer
|
||||
|
||||
# No changes for ALARM
|
||||
# Add patch for ARM being a supported platform.
|
||||
|
||||
pkgname=docker
|
||||
pkgver=0.7.2
|
||||
pkgver=0.7.3
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc='Pack, ship and run any application as a lightweight container'
|
||||
|
@ -16,14 +16,18 @@ makedepends=('git' 'go')
|
|||
# don't strip binaries! A sha1 is used to check binary consistency.
|
||||
options=('!strip')
|
||||
install=$pkgname.install
|
||||
source=("git+https://github.com/dotcloud/docker.git#tag=v$pkgver")
|
||||
md5sums=('SKIP')
|
||||
source=("git+https://github.com/dotcloud/docker.git#tag=v$pkgver"
|
||||
'docker-arm.patch')
|
||||
md5sums=('SKIP'
|
||||
'47cc1cdf900af66660bfa3402012ea71')
|
||||
# magic harcoded path
|
||||
_magic=src/github.com/dotcloud
|
||||
|
||||
prepare() {
|
||||
mkdir -p "$_magic"
|
||||
ln -sfn "../../../docker" "$_magic/docker"
|
||||
cd "${srcdir}/docker"
|
||||
patch -p1 <"${srcdir}/docker-arm.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
13
community/docker/docker-arm.patch
Normal file
13
community/docker/docker-arm.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/engine/engine.go b/engine/engine.go
|
||||
index 5da0a97..f468a59 100644
|
||||
--- a/engine/engine.go
|
||||
+++ b/engine/engine.go
|
||||
@@ -60,7 +60,7 @@ func (eng *Engine) Register(name string, handler Handler) error {
|
||||
// behavior.
|
||||
func New(root string) (*Engine, error) {
|
||||
// Check for unsupported architectures
|
||||
- if runtime.GOARCH != "amd64" {
|
||||
+ if runtime.GOARCH != "amd64" && runtime.GOARCH != "arm" {
|
||||
return nil, fmt.Errorf("The docker runtime currently only supports amd64 (not %s). This will change in the future. Aborting.", runtime.GOARCH)
|
||||
}
|
||||
// Check for unsupported kernel versions
|
Loading…
Reference in a new issue