extra/libreoffice-still to 6.3.5-3

This commit is contained in:
Kevin Mihelich 2020-03-07 16:13:35 +00:00
parent 0db295b870
commit 43ce776e38
2 changed files with 22 additions and 3 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=6.3.5.2
pkgver=6.3.5
pkgrel=1
pkgrel=3
arch=('x86_64')
license=('LGPL3')
url="https://www.libreoffice.org/"
@ -63,7 +63,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
make-pyuno-work-with-system-wide-module-install.diff
soffice-template.desktop.in
libreoffice-still.sh libreoffice-still.csh
0001-Switch-mdds-to-1.5.0-and-liborcus-to-0.15.0.patch)
0001-Switch-mdds-to-1.5.0-and-liborcus-to-0.15.0.patch
libreoffice-poppler-0.86.patch)
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
@ -105,12 +106,15 @@ sha256sums=('ffdb61dc01f18d85272dc798c3403ba74569b0b3e90f3cdc7d014710c3f6ca4a'
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
'c1e199f7767a4f42d9a95fc942cda4cf47737c7d67e6f334679c9b2e3e271dc2'
'07c28ff8f5258abfe4338efccbdfb1dd35892bd00a2ed7f53b1fc2263f71a8b6'
'77214ebc425916990ed80e9508572fd1d565412e1f8c2289424457e3d9bcbc79')
'77214ebc425916990ed80e9508572fd1d565412e1f8c2289424457e3d9bcbc79'
'f52ef5d64d7a74ca90bc96614260566720130d91f3764874eac673f6b3336b5e')
prepare() {
cd libreoffice-$_LOver
patch -p1 -i ../libreoffice-poppler-0.86.patch # Fix build with poppler 0.86
# move external sources into place
mkdir "${srcdir}"/ext_sources && pushd "${srcdir}"/ext_sources
for source in "${noextract[@]}"; do

View file

@ -0,0 +1,15 @@
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index e9c2a407c279..16ad04bf660a 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -563,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
if (!(pAction && pAction->getKind() == actionURI))
return;
-#if POPPLER_CHECK_VERSION(0, 72, 0)
+#if POPPLER_CHECK_VERSION(0, 86, 0)
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
+#elif POPPLER_CHECK_VERSION(0, 72, 0)
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
#else
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();