mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/libvpx to 1.11.0-1.1
This commit is contained in:
parent
6e6f96036a
commit
43dc392962
2 changed files with 6 additions and 96 deletions
|
@ -1,79 +0,0 @@
|
|||
From fa4917057c9d5a55ed8b848c67d3a36378b3a9b9 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Jan 2017 12:11:57 -0700
|
||||
Subject: [PATCH] ARM fixes
|
||||
|
||||
---
|
||||
build/make/configure.sh | 21 +++++++++++----------
|
||||
configure | 2 ++
|
||||
2 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 206b54f775..2f4809a123 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -737,6 +737,14 @@ process_common_toolchain() {
|
||||
aarch64*)
|
||||
tgt_isa=arm64
|
||||
;;
|
||||
+ armv5te*)
|
||||
+ tgt_isa=armv5te
|
||||
+ float_abi=soft
|
||||
+ ;;
|
||||
+ armv6*-gnueabihf)
|
||||
+ tgt_isa=armv6
|
||||
+ float_abi=hard
|
||||
+ ;;
|
||||
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
@@ -941,7 +949,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
- soft_enable neon
|
||||
+ #soft_enable neon
|
||||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -961,13 +969,6 @@ process_common_toolchain() {
|
||||
arch_int=${arch_int%%te}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
- if [ -z "${float_abi}" ]; then
|
||||
- check_cpp <<EOF && float_abi=hard || float_abi=softfp
|
||||
-#ifndef __ARM_PCS_VFP
|
||||
-#error "not hardfp"
|
||||
-#endif
|
||||
-EOF
|
||||
- fi
|
||||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -979,8 +980,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
- check_add_cflags -march=${tgt_isa}
|
||||
- check_add_asflags -march=${tgt_isa}
|
||||
+ check_add_cflags -march=${tgt_isa} -mfloat-abi=${float_abi}
|
||||
+ check_add_asflags -march=${tgt_isa} -mfloat-abi=${float_abi}
|
||||
fi
|
||||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index 32272ce36f..02bc560173 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -102,6 +102,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
all_platforms="${all_platforms} arm64-linux-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-vs15"
|
||||
+all_platforms="${all_platforms} armv5te-linux-gcc"
|
||||
+all_platforms="${all_platforms} armv6-linux-gcc"
|
||||
all_platforms="${all_platforms} armv7-android-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-darwin-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-linux-rvct" #neon Cortex-A8
|
||||
--
|
||||
2.26.0
|
||||
|
|
@ -2,16 +2,14 @@
|
|||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix building
|
||||
# - disable neon and neon-asm
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.11.0
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=(x86_64)
|
||||
url=http://www.webmproject.org/
|
||||
url=https://www.webmproject.org/
|
||||
license=(BSD)
|
||||
depends=(gcc-libs)
|
||||
makedepends=(
|
||||
|
@ -20,10 +18,8 @@ makedepends=(
|
|||
)
|
||||
provides=(libvpx.so)
|
||||
_tag=626ff35955c2c35b806b3e0ecf551a1a8611cdbf
|
||||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=${_tag}
|
||||
0001-ARM-fixes.patch)
|
||||
sha256sums=('SKIP'
|
||||
'65504659ca0fdc10b3ad8a82ad902aa97fd7a31f31377a217ca9538722961f22')
|
||||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=${_tag})
|
||||
sha256sums=(SKIP)
|
||||
|
||||
pkgver() {
|
||||
cd libvpx
|
||||
|
@ -31,16 +27,9 @@ pkgver() {
|
|||
git describe --tags | sed 's/^v//'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd libvpx
|
||||
|
||||
patch -p1 -i ../0001-ARM-fixes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd libvpx
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && CONFIG="--disable-neon --disable-neon-asm"
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--disable-install-docs \
|
||||
|
@ -52,7 +41,7 @@ build() {
|
|||
--enable-vp8 \
|
||||
--enable-vp9 \
|
||||
--enable-vp9-highbitdepth \
|
||||
--enable-vp9-temporal-denoising $CONFIG
|
||||
--enable-vp9-temporal-denoising
|
||||
make
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue