mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox: updates
This commit is contained in:
parent
8e23d01054
commit
447fab3dda
2 changed files with 1 additions and 35 deletions
|
@ -23,7 +23,7 @@ url="https://www.mozilla.org/firefox/"
|
||||||
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
|
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
|
||||||
nss hunspell sqlite ttf-font libpulse icu libvpx)
|
nss hunspell sqlite ttf-font libpulse icu libvpx)
|
||||||
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
|
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
|
||||||
autoconf2.13)
|
autoconf2.13 cargo)
|
||||||
optdepends=('networkmanager: Location detection via available WiFi networks'
|
optdepends=('networkmanager: Location detection via available WiFi networks'
|
||||||
'libnotify: Notification integration'
|
'libnotify: Notification integration'
|
||||||
'pulseaudio: Audio support'
|
'pulseaudio: Audio support'
|
||||||
|
@ -32,7 +32,6 @@ options=(!emptydirs !makeflags !strip)
|
||||||
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
|
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
|
||||||
$pkgname.desktop firefox-symbolic.svg
|
$pkgname.desktop firefox-symbolic.svg
|
||||||
firefox-install-dir.patch no-crmf.diff fix-wifi-scanner.diff
|
firefox-install-dir.patch no-crmf.diff fix-wifi-scanner.diff
|
||||||
mozilla-1335250.patch
|
|
||||||
rhbz-1354671.patch)
|
rhbz-1354671.patch)
|
||||||
sha256sums=('07843e68f2f64842bb230b7fe821e45c82944e64dc3f2a3a90d3ea9f1efa7f77'
|
sha256sums=('07843e68f2f64842bb230b7fe821e45c82944e64dc3f2a3a90d3ea9f1efa7f77'
|
||||||
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
|
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
|
||||||
|
@ -40,7 +39,6 @@ sha256sums=('07843e68f2f64842bb230b7fe821e45c82944e64dc3f2a3a90d3ea9f1efa7f77'
|
||||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||||
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
|
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
|
||||||
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
|
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
|
||||||
'f3944e22d21b41b3aa17e3ea0614ffd13863e66bc8f9f6120f2efbc7595ea347'
|
|
||||||
'22d5e5c07e759422027867121b24cdbcab8812670ca8e2e92825029f30eecbbd')
|
'22d5e5c07e759422027867121b24cdbcab8812670ca8e2e92825029f30eecbbd')
|
||||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||||
|
|
||||||
|
@ -97,7 +95,6 @@ ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
|
||||||
|
|
||||||
# ALARM
|
# ALARM
|
||||||
ac_add_options --disable-webrtc
|
ac_add_options --disable-webrtc
|
||||||
ac_add_options --disable-rust
|
|
||||||
|
|
||||||
# System libraries
|
# System libraries
|
||||||
ac_add_options --with-system-nspr
|
ac_add_options --with-system-nspr
|
||||||
|
@ -127,7 +124,6 @@ END
|
||||||
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||||
patch -p1 -i ../rhbz-1354671.patch
|
patch -p1 -i ../rhbz-1354671.patch
|
||||||
fi
|
fi
|
||||||
patch -p1 -i ../mozilla-1335250.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
diff -up firefox-53.0/dom/media/webrtc/MediaEngine.h.1335250 firefox-53.0/dom/media/webrtc/MediaEngine.h
|
|
||||||
--- firefox-53.0/dom/media/webrtc/MediaEngine.h.1335250 2017-04-11 06:15:22.000000000 +0200
|
|
||||||
+++ firefox-53.0/dom/media/webrtc/MediaEngine.h 2017-04-19 20:35:55.264741939 +0200
|
|
||||||
@@ -226,7 +226,7 @@ public:
|
|
||||||
~AllocationHandle() {}
|
|
||||||
public:
|
|
||||||
AllocationHandle(const dom::MediaTrackConstraints& aConstraints,
|
|
||||||
- const ipc::PrincipalInfo& aPrincipalInfo,
|
|
||||||
+ const mozilla::ipc::PrincipalInfo& aPrincipalInfo,
|
|
||||||
const MediaEnginePrefs& aPrefs,
|
|
||||||
const nsString& aDeviceId)
|
|
||||||
|
|
||||||
@@ -236,7 +236,7 @@ public:
|
|
||||||
mDeviceId(aDeviceId) {}
|
|
||||||
public:
|
|
||||||
NormalizedConstraints mConstraints;
|
|
||||||
- ipc::PrincipalInfo mPrincipalInfo;
|
|
||||||
+ mozilla::ipc::PrincipalInfo mPrincipalInfo;
|
|
||||||
MediaEnginePrefs mPrefs;
|
|
||||||
nsString mDeviceId;
|
|
||||||
};
|
|
||||||
@@ -327,7 +327,7 @@ public:
|
|
||||||
virtual nsresult Allocate(const dom::MediaTrackConstraints &aConstraints,
|
|
||||||
const MediaEnginePrefs &aPrefs,
|
|
||||||
const nsString& aDeviceId,
|
|
||||||
- const ipc::PrincipalInfo& aPrincipalInfo,
|
|
||||||
+ const mozilla::ipc::PrincipalInfo& aPrincipalInfo,
|
|
||||||
AllocationHandle** aOutHandle,
|
|
||||||
const char** aOutBadConstraint)
|
|
||||||
{
|
|
Loading…
Reference in a new issue