extra/qt5-webengine to 5.15.9-3

This commit is contained in:
Kevin Mihelich 2022-05-15 19:55:10 +00:00
parent 6c6e17af60
commit 44a3166f58
2 changed files with 18 additions and 2 deletions

View file

@ -9,9 +9,9 @@
highmem=1
pkgname=qt5-webengine
_basever=5.15.3
_basever=5.15.4
pkgver=5.15.9
pkgrel=2
pkgrel=3
arch=('x86_64')
url='https://www.qt.io'
license=('LGPL3' 'LGPL2.1' 'BSD')
@ -29,6 +29,7 @@ source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
qt5-webengine-chromium-python3.patch
qt5-webengine-ffmpeg5.patch
qt5-webengine-pipewire-0.3.patch
qt5-webengine-gcc12.patch
0001-ARM-toolchain-fixes.patch
0002-Fix-ARM-skia-ICE.patch
0003-bind-gen-Support-single_process-flag-in-generate_bin.patch
@ -40,6 +41,7 @@ sha256sums=('SKIP'
'fda4ff16790799fb285847918a677f4f3f7c0f513d4751f846ffc5aa5d873932'
'c50d3019626183e753c53a997dc8a55938847543aa3178d4c51f377be741c693'
'5e3a3c4711d964d5152a04059a2b5c1d14bb13dd29bce370120f60e85b476b6f'
'cf9be3ffcc3b3cd9450b1ff13535ff7d76284f73173412d097a6ab487463a379'
'81b7a62368f40d757b165b88df4813413f30db797e4f93a84dd75e12e1ebd679'
'298037fcbc132f1539616cdf6149ad5da104f8e2345a9c1af1e7bf8b0dd52c70'
'b878770648437c9bc24023b1d5a47bcd51382d7142b695864c3379826511bcd9'
@ -60,6 +62,7 @@ prepare() {
patch -p1 -d src/3rdparty -i "$srcdir"/qt5-webengine-ffmpeg5.patch # Fix build with ffmpeg 5
patch -p1 -d src/3rdparty -i "$srcdir"/qt5-webengine-pipewire-0.3.patch # Port to pipewire 0.3
patch -p1 -d src/3rdparty -i "$srcdir"/qt5-webengine-gcc12.patch # Fix build with GCC 12
# Update catapult for python3 compatibility
rm -r src/3rdparty/chromium/third_party/catapult

View file

@ -0,0 +1,13 @@
diff --git a/chromium/third_party/skia/src/utils/SkParseColor.cpp b/chromium/third_party/skia/src/utils/SkParseColor.cpp
index 7260365b2c6..b5a6aae3596 100644
--- a/chromium/third_party/skia/src/utils/SkParseColor.cpp
+++ b/chromium/third_party/skia/src/utils/SkParseColor.cpp
@@ -8,6 +8,8 @@
#include "include/utils/SkParse.h"
+#include <iterator>
+
static constexpr const char* gColorNames[] = {
"aliceblue",
"antiquewhite",