extra/firefox to 83.0-2

This commit is contained in:
Kevin Mihelich 2020-11-27 15:21:20 +00:00
parent 361a90ac38
commit 44f2f9f67c
3 changed files with 3529 additions and 9 deletions

View file

@ -5,14 +5,14 @@ Subject: [PATCH] Use remoting name for GDK application names
---
toolkit/xre/nsAppRunner.cpp | 6 +-----
widget/gtk/nsAppShell.cpp | 11 ++++-------
2 files changed, 5 insertions(+), 12 deletions(-)
widget/gtk/nsAppShell.cpp | 12 +++++-------
2 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
index a16521852d05..d0be5a088d8c 100644
index d944ce905cbe3..9a50545bfafcb 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
@@ -3832,11 +3832,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
@@ -4161,11 +4161,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.
@ -26,18 +26,19 @@ index a16521852d05..d0be5a088d8c 100644
// Initialize GTK here for splash.
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
index cfe022e65d82..06325264dbb1 100644
index cfe022e65d820..c228237830e43 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
@@ -24,6 +24,7 @@
@@ -24,6 +24,8 @@
# include "WakeLockListener.h"
#endif
#include "gfxPlatform.h"
+#include "nsAppRunner.h"
+#include "mozilla/XREAppData.h"
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
@@ -159,13 +160,9 @@ nsresult nsAppShell::Init() {
@@ -159,13 +161,9 @@ nsresult nsAppShell::Init() {
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
//
// Only bother doing this for the parent process, since it's the one

File diff suppressed because one or more lines are too long

View file

@ -11,7 +11,7 @@ highmem=1
pkgname=firefox
pkgver=83.0
pkgrel=1
pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -30,12 +30,14 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
arm.patch
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
$pkgname.desktop)
sha256sums=('d69e84e8b8449f828683d274c24e03095858362bfed21b08bdd7fe715eea5398'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'1dba448eb1605c9dc73c22861a5394b50055909399f056baee4887b29af1b51e'
'6ca7ff71cb4a7c72eca39769afe8e18ec81cba36d9b570df15fc243867049243'
'8da91fdb08fcc6e820111acda88c8f2484ef1c5271ce32997bfd919d507a238c'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -59,6 +61,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# Fix build with Rust 1.48 https://bugs.archlinux.org/task/68747
patch -Np1 -i ../0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key