mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/webkit2gtk to 2.12.0-2
This commit is contained in:
parent
1140304b95
commit
45e6aa33eb
2 changed files with 3 additions and 15 deletions
|
@ -8,13 +8,13 @@
|
||||||
highmem=1
|
highmem=1
|
||||||
|
|
||||||
pkgname=webkit2gtk
|
pkgname=webkit2gtk
|
||||||
pkgver=2.10.9
|
pkgver=2.12.0
|
||||||
pkgrel=2
|
pkgrel=2
|
||||||
pkgdesc="GTK+ Web content engine library"
|
pkgdesc="GTK+ Web content engine library"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://webkitgtk.org/"
|
url="http://webkitgtk.org/"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
depends=('libxt' 'libxslt' 'enchant' 'geoclue2' 'gst-plugins-base-libs' 'gst-plugins-bad'
|
depends=('libxt' 'libxslt' 'enchant' 'geoclue2' 'gst-plugins-base-libs'
|
||||||
'libsecret' 'libwebp' 'harfbuzz-icu' 'gtk3' 'libnotify' 'hyphen')
|
'libsecret' 'libwebp' 'harfbuzz-icu' 'gtk3' 'libnotify' 'hyphen')
|
||||||
makedepends=('gtk2' 'gperf' 'gobject-introspection' 'ruby' 'gtk-doc' 'cmake' 'python')
|
makedepends=('gtk2' 'gperf' 'gobject-introspection' 'ruby' 'gtk-doc' 'cmake' 'python')
|
||||||
optdepends=('gtk2: Netscape plugin support'
|
optdepends=('gtk2: Netscape plugin support'
|
||||||
|
@ -23,7 +23,7 @@ optdepends=('gtk2: Netscape plugin support'
|
||||||
'gst-libav: nonfree media decoding')
|
'gst-libav: nonfree media decoding')
|
||||||
options=('!emptydirs')
|
options=('!emptydirs')
|
||||||
source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz)
|
source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz)
|
||||||
sha256sums=('bbb18d741780b1b7fa284beb9a97361ac57cda2e42bad2ae2fcdbf797919e969')
|
sha256sums=('a68604f8fd1bcb247d647709290226289b90c16acb1f3730538b688db8df5ea6')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir build
|
mkdir build
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -u -r webkitgtk-2.10.8/Source/JavaScriptCore/runtime/Options.cpp webkitgtk-2.10.8-isnan/Source/JavaScriptCore/runtime/Options.cpp
|
|
||||||
--- webkitgtk-2.10.8/Source/JavaScriptCore/runtime/Options.cpp 2016-03-11 09:59:07.000000000 +0100
|
|
||||||
+++ webkitgtk-2.10.8-isnan/Source/JavaScriptCore/runtime/Options.cpp 2016-03-13 13:51:55.114836547 +0100
|
|
||||||
@@ -610,7 +610,7 @@
|
|
||||||
case Options::Type::unsignedType:
|
|
||||||
return m_entry.unsignedVal == other.m_entry.unsignedVal;
|
|
||||||
case Options::Type::doubleType:
|
|
||||||
- return (m_entry.doubleVal == other.m_entry.doubleVal) || (isnan(m_entry.doubleVal) && isnan(other.m_entry.doubleVal));
|
|
||||||
+ return (m_entry.doubleVal == other.m_entry.doubleVal) || (std::isnan(m_entry.doubleVal) && std::isnan(other.m_entry.doubleVal));
|
|
||||||
case Options::Type::int32Type:
|
|
||||||
return m_entry.int32Val == other.m_entry.int32Val;
|
|
||||||
case Options::Type::optionRangeType:
|
|
Loading…
Reference in a new issue