More preparation for mt-daapd

This commit is contained in:
Mike Staszel 2009-10-11 13:11:41 -05:00
parent 6e744c6e30
commit 463754f5ab
19 changed files with 30 additions and 270 deletions

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 26583 2009-02-09 21:13:40Z jgc $
# Maintainer: Alexander Baldeck <alexander@archlinux.org> # Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=inputproto pkgname=inputproto
pkgver=1.5.0 pkgver=1.5.0
pkgrel=1 pkgrel=1
pkgdesc="X11 Input extension wire protocol" pkgdesc="X11 Input extension wire protocol"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2) source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 10838 2008-08-31 13:22:37Z jgc $
# Maintainer: Alexander Baldeck <alexander@archlinux.org> # Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxau pkgname=libxau
pkgver=1.0.4 pkgver=1.0.4
pkgrel=1 pkgrel=1
pkgdesc="X11 authorisation library" pkgdesc="X11 authorisation library"
arch=(arm) arch=('arm')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
depends=('glibc') depends=('glibc')
makedepends=('pkgconfig' 'xproto') makedepends=('pkgconfig' 'xproto')

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 27498 2009-02-22 09:23:59Z andyrtr $
# Maintainer: Alexander Baldeck <alexander@archlinux.org> # Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxcb pkgname=libxcb
pkgver=1.2 pkgver=1.2
pkgrel=1 pkgrel=1
pkgdesc="X11 client-side library" pkgdesc="X11 client-side library"
arch=(arm) arch=('arm')
url="http://xcb.freedesktop.org/" url="http://xcb.freedesktop.org/"
depends=('xcb-proto>=1.4' 'libxdmcp' 'libxau') depends=('xcb-proto>=1.4' 'libxdmcp' 'libxau')
makedepends=('pkgconfig' 'libxslt' 'python') makedepends=('pkgconfig' 'libxslt' 'python')

View file

@ -1,12 +0,0 @@
diff -up libxcb-1.1/src/xcb_conn.c.jx libxcb-1.1/src/xcb_conn.c
--- libxcb-1.1/src/xcb_conn.c.jx 2007-10-28 16:11:18.000000000 -0400
+++ libxcb-1.1/src/xcb_conn.c 2008-04-22 11:58:05.000000000 -0400
@@ -63,7 +63,7 @@ static int _xcb_xlib_init(_xcb_xlib *xli
{
xlib->lock = 0;
#ifndef NDEBUG
- xlib->sloppy_lock = (getenv("LIBXCB_ALLOW_SLOPPY_LOCK") != 0);
+ xlib->sloppy_lock = 1;
#endif
pthread_cond_init(&xlib->cond, 0);
return 1;

View file

@ -1,11 +1,10 @@
# $Id: PKGBUILD 35595 2009-04-14 06:09:57Z eric $ # Maintainer: Jan de Groot <jgc@archlinux.org>
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libxdmcp pkgname=libxdmcp
pkgver=1.0.2 pkgver=1.0.2
pkgrel=2 pkgrel=2
pkgdesc="X11 Display Manager Control Protocol library" pkgdesc="X11 Display Manager Control Protocol library"
arch=(arm) arch=('arm')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
license=('custom') license=('custom')
depends=('xproto' 'glibc') depends=('xproto' 'glibc')

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 4363 2008-07-06 19:22:55Z jgc $
# Maintainer: Alexander Baldeck<alexander@archlinux.org> # Maintainer: Alexander Baldeck<alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxft pkgname=libxft
pkgver=2.1.13 pkgver=2.1.13
pkgrel=1 pkgrel=1
pkgdesc="FreeType-based font drawing library for X" pkgdesc="FreeType-based font drawing library for X"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
depends=('fontconfig>=2.6.0' 'libxrender') depends=('fontconfig>=2.6.0' 'libxrender')
@ -21,5 +21,4 @@ build() {
make DESTDIR=${startdir}/pkg install || return 1 make DESTDIR=${startdir}/pkg install || return 1
install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname} install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}
install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1 install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
} }

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 26966 2009-02-14 23:57:37Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org> # Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net> # Contributor: John Proctor <jproctor@prium.net>
@ -6,7 +5,7 @@ pkgname=libxml2
pkgver=2.7.3 pkgver=2.7.3
pkgrel=1 pkgrel=1
pkgdesc="XML parsing library, version 2" pkgdesc="XML parsing library, version 2"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
depends=('zlib>=1.2.3.3' 'readline>=5.2.013' 'ncurses>=5.7') depends=('zlib>=1.2.3.3' 'readline>=5.2.013' 'ncurses>=5.7')
makedepends=('python') makedepends=('python')

View file

@ -1,12 +0,0 @@
--- libxml2-2.6.32.dfsg.orig/libxml.h
+++ libxml2-2.6.32.dfsg/libxml.h
@@ -13,6 +13,9 @@
#ifndef _LARGEFILE_SOURCE
#define _LARGEFILE_SOURCE
#endif
+#ifndef _LARGEFILE64_SOURCE
+#define _LARGEFILE64_SOURCE
+#endif
#ifndef _FILE_OFFSET_BITS
#define _FILE_OFFSET_BITS 64
#endif

View file

@ -1,159 +0,0 @@
diff --git a/parser.c b/parser.c
index a476060..b404722 100644
--- a/parser.c
+++ b/parser.c
@@ -5323,7 +5323,8 @@ xmlParseNotationType(xmlParserCtxtPtr ctxt) {
if (name == NULL) {
xmlFatalErrMsg(ctxt, XML_ERR_NAME_REQUIRED,
"Name expected in NOTATION declaration\n");
- return(ret);
+ xmlFreeEnumeration(ret);
+ return(NULL);
}
tmp = ret;
while (tmp != NULL) {
@@ -5339,7 +5340,10 @@ xmlParseNotationType(xmlParserCtxtPtr ctxt) {
}
if (tmp == NULL) {
cur = xmlCreateEnumeration(name);
- if (cur == NULL) return(ret);
+ if (cur == NULL) {
+ xmlFreeEnumeration(ret);
+ return(NULL);
+ }
if (last == NULL) ret = last = cur;
else {
last->next = cur;
@@ -5350,9 +5354,8 @@ xmlParseNotationType(xmlParserCtxtPtr ctxt) {
} while (RAW == '|');
if (RAW != ')') {
xmlFatalErr(ctxt, XML_ERR_NOTATION_NOT_FINISHED, NULL);
- if ((last != NULL) && (last != ret))
- xmlFreeEnumeration(last);
- return(ret);
+ xmlFreeEnumeration(ret);
+ return(NULL);
}
NEXT;
return(ret);
@@ -5407,7 +5410,10 @@ xmlParseEnumerationType(xmlParserCtxtPtr ctxt) {
cur = xmlCreateEnumeration(name);
if (!xmlDictOwns(ctxt->dict, name))
xmlFree(name);
- if (cur == NULL) return(ret);
+ if (cur == NULL) {
+ xmlFreeEnumeration(ret);
+ return(NULL);
+ }
if (last == NULL) ret = last = cur;
else {
last->next = cur;
@@ -5775,9 +5781,10 @@ xmlParseElementMixedContentDecl(xmlParserCtxtPtr ctxt, int inputchk) {
}
/**
- * xmlParseElementChildrenContentDecl:
+ * xmlParseElementChildrenContentDeclPriv:
* @ctxt: an XML parser context
* @inputchk: the input used for the current entity, needed for boundary checks
+ * @depth: the level of recursion
*
* parse the declaration for a Mixed Element content
* The leading '(' and spaces have been skipped in xmlParseElementContentDecl
@@ -5805,12 +5812,20 @@ xmlParseElementMixedContentDecl(xmlParserCtxtPtr ctxt, int inputchk) {
* Returns the tree of xmlElementContentPtr describing the element
* hierarchy.
*/
-xmlElementContentPtr
-xmlParseElementChildrenContentDecl (xmlParserCtxtPtr ctxt, int inputchk) {
+static xmlElementContentPtr
+xmlParseElementChildrenContentDeclPriv(xmlParserCtxtPtr ctxt, int inputchk,
+ int depth) {
xmlElementContentPtr ret = NULL, cur = NULL, last = NULL, op = NULL;
const xmlChar *elem;
xmlChar type = 0;
+ if (((depth > 128) && ((ctxt->options & XML_PARSE_HUGE) == 0)) ||
+ (depth > 2048)) {
+ xmlFatalErrMsgInt(ctxt, XML_ERR_ELEMCONTENT_NOT_FINISHED,
+"xmlParseElementChildrenContentDecl : depth %d too deep, use XML_PARSE_HUGE\n",
+ depth);
+ return(NULL);
+ }
SKIP_BLANKS;
GROW;
if (RAW == '(') {
@@ -5819,7 +5834,8 @@ xmlParseElementChildrenContentDecl (xmlParserCtxtPtr ctxt, int inputchk) {
/* Recurse on first child */
NEXT;
SKIP_BLANKS;
- cur = ret = xmlParseElementChildrenContentDecl(ctxt, inputid);
+ cur = ret = xmlParseElementChildrenContentDeclPriv(ctxt, inputid,
+ depth + 1);
SKIP_BLANKS;
GROW;
} else {
@@ -5951,7 +5967,8 @@ xmlParseElementChildrenContentDecl (xmlParserCtxtPtr ctxt, int inputchk) {
/* Recurse on second child */
NEXT;
SKIP_BLANKS;
- last = xmlParseElementChildrenContentDecl(ctxt, inputid);
+ last = xmlParseElementChildrenContentDeclPriv(ctxt, inputid,
+ depth + 1);
SKIP_BLANKS;
} else {
elem = xmlParseName(ctxt);
@@ -6062,6 +6079,44 @@ xmlParseElementChildrenContentDecl (xmlParserCtxtPtr ctxt, int inputchk) {
}
/**
+ *
+ * xmlParseElementChildrenContentDecl:
+ * @ctxt: an XML parser context
+ * @inputchk: the input used for the current entity, needed for boundary checks
+ * @depth: the level of recursion
+ *
+ * parse the declaration for a Mixed Element content
+ * The leading '(' and spaces have been skipped in xmlParseElementContentDecl
+ *
+ * [47] children ::= (choice | seq) ('?' | '*' | '+')?
+ *
+ * [48] cp ::= (Name | choice | seq) ('?' | '*' | '+')?
+ *
+ * [49] choice ::= '(' S? cp ( S? '|' S? cp )* S? ')'
+ *
+ * [50] seq ::= '(' S? cp ( S? ',' S? cp )* S? ')'
+ *
+ * [ VC: Proper Group/PE Nesting ] applies to [49] and [50]
+ * TODO Parameter-entity replacement text must be properly nested
+ * with parenthesized groups. That is to say, if either of the
+ * opening or closing parentheses in a choice, seq, or Mixed
+ * construct is contained in the replacement text for a parameter
+ * entity, both must be contained in the same replacement text. For
+ * interoperability, if a parameter-entity reference appears in a
+ * choice, seq, or Mixed construct, its replacement text should not
+ * be empty, and neither the first nor last non-blank character of
+ * the replacement text should be a connector (| or ,).
+ *
+ * Returns the tree of xmlElementContentPtr describing the element
+ * hierarchy.
+ */
+xmlElementContentPtr
+xmlParseElementChildrenContentDecl(xmlParserCtxtPtr ctxt, int inputchk) {
+ /* stub left for API/ABI compat */
+ return(xmlParseElementChildrenContentDeclPriv(ctxt, inputchk, 1));
+}
+
+/**
* xmlParseElementContentDecl:
* @ctxt: an XML parser context
* @name: the name of the element being defined.
@@ -6097,7 +6152,7 @@ xmlParseElementContentDecl(xmlParserCtxtPtr ctxt, const xmlChar *name,
tree = xmlParseElementMixedContentDecl(ctxt, inputid);
res = XML_ELEMENT_TYPE_MIXED;
} else {
- tree = xmlParseElementChildrenContentDecl(ctxt, inputid);
+ tree = xmlParseElementChildrenContentDeclPriv(ctxt, inputid, 1);
res = XML_ELEMENT_TYPE_ELEMENT;
}
SKIP_BLANKS;

View file

@ -1,11 +1,11 @@
# $Id: PKGBUILD 1905 2008-05-22 18:21:37Z jgc $
# Maintainer: Alexander Baldeck <alexander@archlinux.org> # Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxss pkgname=libxss
pkgver=1.1.3 pkgver=1.1.3
pkgrel=1 pkgrel=1
pkgdesc="X11 Screen Saver extension library" pkgdesc="X11 Screen Saver extension library"
arch=(arm) arch=('arm')
license=('custom:XFREE86') license=('custom:XFREE86')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
depends=('libxext' 'scrnsaverproto') depends=('libxext' 'scrnsaverproto')

View file

@ -1,19 +0,0 @@
2009-06-06 Allan McRae <allan@archlinux.org>
* python 2.6.2-2
* add fix for smtplib (FS#14915)
2009-04-17 Allan McRae <allan@archlinux.org>
* python 2.6.2-1
* upstream update
* add expat and sqlite3 dependencies
* remove python-2.5 compatibility site path
2008-12-07 Allan McRae <allan@archlinux.org>
* python 2.6.1-1
* upstream update
* fix gdbm related build error
* fix modulator/pynche launchers
2008-10-27 Allan McRae <allan@archlinux.org>
* python 2.6-2
* patched to use internal expat

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 46742 2009-07-20 02:28:20Z allan $
# Maintainer: Allan McRae <allan@archlinux.org> # Maintainer: Allan McRae <allan@archlinux.org>
# Contributer: Jason Chu <jason@archlinux.org> # Contributer: Jason Chu <jason@archlinux.org>
@ -7,7 +6,7 @@ pkgver=2.6.2
pkgrel=3 pkgrel=3
_pybasever=2.6 _pybasever=2.6
pkgdesc="A high-level scripting language" pkgdesc="A high-level scripting language"
arch=('i686' 'x86_64') arch=('arm')
license=('custom') license=('custom')
url="http://www.python.org" url="http://www.python.org"
depends=('db' 'bzip2' 'gdbm' 'openssl>=0.9.8d' 'zlib' 'expat' 'sqlite3>=3.6.15-2') depends=('db' 'bzip2' 'gdbm' 'openssl>=0.9.8d' 'zlib' 'expat' 'sqlite3>=3.6.15-2')

View file

@ -1,11 +1,10 @@
# $Id: PKGBUILD 5568 2008-07-18 20:51:46Z jgc $ # Maintainer: Jan de Groot <jgc@archlinux.org>
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=scrnsaverproto pkgname=scrnsaverproto
pkgver=1.1.0 pkgver=1.1.0
pkgrel=2 pkgrel=2
pkgdesc="X11 Screen Saver extension wire protocol" pkgdesc="X11 Screen Saver extension wire protocol"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2) source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)

View file

@ -1,26 +0,0 @@
2000-04-28 Allan McRae <allan@archlinux.org>
* 8.5.7-1 :
new upstream release
include private headers (FS#14388)
2008-12-24 Allan McRae <allan@archlinux.org>
* 8.5.6-1 :
new upstream release
2008-10-16 Allan McRae <allan@archlinux.org>
* 8.5.5-1 :
new upstream release
2008-08-20 Allan McRae <allan@archlinux.org>
* 8.5.4-2 :
Remove xproto compatibility patch as no longer needed
2008-08-16 Allan McRae <allan@archlinux.org>
* 8.5.4-1 :
new upstream release
FHS man pages
2008-07-01 Allan McRae <allan@archlinux.org>
* 8.5.3-1 :
new upstream release
added patch for xproto-7.0.13 compatibility

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 36913 2009-04-28 13:33:52Z allan $
# Maintainer: Allan McRae <allan@archlinux.org> # Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org> # Contributor: Judd Vinet <jvinet@zeroflux.org>
@ -6,7 +5,7 @@ pkgname=tk
pkgver=8.5.7 pkgver=8.5.7
pkgrel=1 pkgrel=1
pkgdesc="A windowing toolkit for use with tcl" pkgdesc="A windowing toolkit for use with tcl"
arch=(arm) arch=('arm')
url="http://tcl.sourceforge.net/" url="http://tcl.sourceforge.net/"
license=('custom') license=('custom')
depends=("tcl=${pkgver}" 'libxss' 'libxft') depends=("tcl=${pkgver}" 'libxss' 'libxft')

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 27497 2009-02-22 09:20:47Z andyrtr $
# Maintainer: Alexander Baldeck <alexander@archlinux.org> # Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org> # Contributor: Jan de Groot <jgc@archlinux.org>
@ -6,7 +5,7 @@ pkgname=xcb-proto
pkgver=1.4 pkgver=1.4
pkgrel=1 pkgrel=1
pkgdesc="XML-XCB protocol descriptions" pkgdesc="XML-XCB protocol descriptions"
arch=(arm) arch=('arm')
url="http://xcb.freedesktop.org/" url="http://xcb.freedesktop.org/"
license=('custom') license=('custom')
makedepends=('python' 'libxml2') makedepends=('python' 'libxml2')

View file

@ -1,17 +1,15 @@
# $Id: PKGBUILD 26846 2009-02-13 15:23:45Z andyrtr $ # Maintainer: Jan de Groot <jgc@archlinux.org>
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xextproto pkgname=xextproto
pkgver=7.0.5 pkgver=7.0.5
pkgrel=1 pkgrel=1
pkgdesc="X11 various extension wire protocol" pkgdesc="X11 various extension wire protocol"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
depends=('inputproto>=1.5') depends=('inputproto>=1.5')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2) source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
md5sums=('e6841018a7c64983b0954aa2c564d115') md5sums=('e6841018a7c64983b0954aa2c564d115')
sha1sums=('d62e704039e7c647da66c9a6531ebdede37dace8')
build() { build() {
cd "${srcdir}/${pkgname}-${pkgver}" cd "${srcdir}/${pkgname}-${pkgver}"

View file

@ -1,5 +1,4 @@
# $Id: PKGBUILD 36402 2009-04-22 02:26:18Z eric $ # Maintainer: Jan de Groot <jgc@archlinux.org>
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xf86bigfontproto pkgname=xf86bigfontproto
pkgver=1.1.2 pkgver=1.1.2
@ -10,7 +9,6 @@ url="http://xorg.freedesktop.org/"
license=('custom') license=('custom')
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2) source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
md5sums=('a318c1e86123832d7b0c95fc7d47ef35') md5sums=('a318c1e86123832d7b0c95fc7d47ef35')
sha1sums=('4a2e84b3f529e4747dbc07bf4496bfe01f40aa85')
build() { build() {
cd ${srcdir}/${pkgname}-${pkgver} cd ${srcdir}/${pkgname}-${pkgver}

View file

@ -1,11 +1,10 @@
# $Id: PKGBUILD 21902 2008-12-17 20:27:32Z jgc $ # Maintainer: Jan de Groot <jgc@archlinux.org>
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xorg-util-macros pkgname=xorg-util-macros
pkgver=1.2.1 pkgver=1.2.1
pkgrel=1 pkgrel=1
pkgdesc="X.Org Autotools macros" pkgdesc="X.Org Autotools macros"
arch=(arm) arch=('arm')
license=('custom') license=('custom')
url="http://xorg.freedesktop.org/" url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/util/util-macros-${pkgver}.tar.bz2) source=(${url}/releases/individual/util/util-macros-${pkgver}.tar.bz2)