extra/ffmpeg to 7.1-7

This commit is contained in:
Kevin Mihelich 2025-03-09 18:56:40 +00:00
parent 7dd3e009fc
commit 464b12b39d
3 changed files with 40 additions and 3 deletions

View file

@ -1,7 +1,7 @@
pkgbase = ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video
pkgver = 7.1
pkgrel = 6
pkgrel = 7
epoch = 2
url = https://ffmpeg.org
arch = x86_64
@ -105,10 +105,12 @@ pkgbase = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=507a51fbe9732f0f6f12f43ce12431e8faa834b7
source = add-av_stream_get_first_dts-for-chromium.patch
source = fix_build_with_texinfo-7.2.patch
source = fix_build_with_svt-av1-3.0.patch
validpgpkeys = DD1EC9E8DE085C629B3E1846B18E8928B3948D64
b2sums = c7ec6b1db61608195117b79f3f0c8f6323c3abeb39721359da0f10e7d739da8301e04ff5fa83c022f86fc760f66e00066f9a50d97b771f797ccc679f9d912c40
b2sums = 555274228e09a233d92beb365d413ff5c718a782008075552cafb2130a3783cf976b51dfe4513c15777fb6e8397a34122d475080f2c4483e8feea5c0d878e6de
b2sums = 7b33e9527322604532f2b26b5c78680c54d7e50c07ff6acaddd4d17e031724ae91474f46cb034d9d02fb0cf370d6477e1d4f5b04c4dddab5e8b319f03c0fc9b9
b2sums = a71d0c0092ae64b9cef38efb4a585b415e74842a173796b63778cd2c570c3216179c5ac59346d51388cc874cc37a32adb93f038ab26747d8e3fc0c984ce116ff
pkgname = ffmpeg
depends = alsa-lib

View file

@ -16,7 +16,7 @@
pkgname=ffmpeg
pkgver=7.1
pkgrel=6
pkgrel=7
epoch=2
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=(x86_64)
@ -124,10 +124,12 @@ source=(
git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=${_tag}
add-av_stream_get_first_dts-for-chromium.patch
fix_build_with_texinfo-7.2.patch
fix_build_with_svt-av1-3.0.patch
)
b2sums=('c7ec6b1db61608195117b79f3f0c8f6323c3abeb39721359da0f10e7d739da8301e04ff5fa83c022f86fc760f66e00066f9a50d97b771f797ccc679f9d912c40'
'555274228e09a233d92beb365d413ff5c718a782008075552cafb2130a3783cf976b51dfe4513c15777fb6e8397a34122d475080f2c4483e8feea5c0d878e6de'
'7b33e9527322604532f2b26b5c78680c54d7e50c07ff6acaddd4d17e031724ae91474f46cb034d9d02fb0cf370d6477e1d4f5b04c4dddab5e8b319f03c0fc9b9')
'7b33e9527322604532f2b26b5c78680c54d7e50c07ff6acaddd4d17e031724ae91474f46cb034d9d02fb0cf370d6477e1d4f5b04c4dddab5e8b319f03c0fc9b9'
'a71d0c0092ae64b9cef38efb4a585b415e74842a173796b63778cd2c570c3216179c5ac59346d51388cc874cc37a32adb93f038ab26747d8e3fc0c984ce116ff')
validpgpkeys=(DD1EC9E8DE085C629B3E1846B18E8928B3948D64) # Michael Niedermayer <michael@niedermayer.cc>
prepare() {
@ -140,6 +142,9 @@ prepare() {
patch -Np1 -i ../add-av_stream_get_first_dts-for-chromium.patch # https://crbug.com/1251779
# Fix for svt-av1
# Taken from https://github.com/FFmpeg/FFmpeg/commit/d1ed5c06e3edc5f2b5f3664c80121fa55b0baa95.patch
patch -Np1 -i ../fix_build_with_svt-av1-3.0.patch
# VAAPI HEVC encode alignment fix
git cherry-pick -n bcfbf2bac8f9eeeedc407b40596f5c7aaa0d5b47
git cherry-pick -n d0facac679faf45d3356dff2e2cb382580d7a521

View file

@ -0,0 +1,30 @@
From d1ed5c06e3edc5f2b5f3664c80121fa55b0baa95 Mon Sep 17 00:00:00 2001
From: Gyan Doshi <ffmpeg@gyani.pro>
Date: Sat, 22 Feb 2025 10:38:53 +0530
Subject: [PATCH] avcodec/libsvtav1: unbreak build with latest svtav1
SVT-AV1 made a change in their public API in 988e930c but without a
version bump or any other accessible marker, thus breaking ffmpeg build
with current versions of SVT-AV1.
They have finally bumped versions a month later, so check added.
---
libavcodec/libsvtav1.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/libavcodec/libsvtav1.c b/libavcodec/libsvtav1.c
index 79b28eb4df546..43fe531fde74d 100644
--- a/libavcodec/libsvtav1.c
+++ b/libavcodec/libsvtav1.c
@@ -435,7 +435,11 @@ static av_cold int eb_enc_init(AVCodecContext *avctx)
svt_enc->eos_flag = EOS_NOT_REACHED;
+#if SVT_AV1_CHECK_VERSION(3, 0, 0)
+ svt_ret = svt_av1_enc_init_handle(&svt_enc->svt_handle, &svt_enc->enc_params);
+#else
svt_ret = svt_av1_enc_init_handle(&svt_enc->svt_handle, svt_enc, &svt_enc->enc_params);
+#endif
if (svt_ret != EB_ErrorNone) {
return svt_print_error(avctx, svt_ret, "Error initializing encoder handle");
}