community/libuhd to 3.11.1.0-1

This commit is contained in:
Kevin Mihelich 2018-06-08 05:01:19 +00:00
parent b37c77e1bf
commit 466e54944b
2 changed files with 24 additions and 14 deletions

View file

@ -6,9 +6,8 @@
# - patch out ineffectual neon check
pkgname=libuhd
pkgver=3.10.2.0
_verstring='003_010_002_000'
pkgrel=3
pkgver=3.11.1.0
pkgrel=1
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
arch=('x86_64')
url="http://www.ettus.com/kb/category/software-documentation/uhd-manual"
@ -17,22 +16,21 @@ depends=('boost-libs' 'orc' 'libusb')
optdepends=('python2: usrp utils')
makedepends=('cmake' 'boost' 'python2-cheetah' 'python2-mako')
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/release_${_verstring}.tar.gz"
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
'boost-1.67.patch'
'0001-remove-ineffectual-neon-check.patch')
md5sums=('f1e1977cd6c146daf800df681cb22944'
md5sums=('fb3c6972af55130f34ec9133caf6c9e4'
'45fcc6feb0ea9b4ae09e4ba7b010864f'
'2cb16216ee735ab1160e572d523155ea')
prepare() {
patch -d uhd-release_$_verstring -p1 -i ../0001-remove-ineffectual-neon-check.patch
cd "$srcdir/uhd-release_$_verstring/host"
# from commit d9d9d0a8a2e6, remove on 3.10.2.1
sed -i 's|socket->native()|socket->native_handle()|' examples/network_relay.cpp
sed -i 's|socket->native()|socket->native_handle()|' lib/transport/{tcp_zero_copy,udp_simple,udp_zero_copy}.cpp
sed -i 's|recver->native()|recver->native_handle()|' lib/usrp/e300/e300_network.cpp
cd "$srcdir/uhd-$pkgver"
patch -Np1 -i ../boost-1.67.patch
patch -Np1 -i ../0001-remove-ineffectual-neon-check.patch
}
build() {
cd "$srcdir/uhd-release_$_verstring/host"
cd "$srcdir/uhd-$pkgver/host"
# fix for py2
find -name "*.py" -or -name '*.py.in' | xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
@ -49,12 +47,12 @@ build() {
}
check() {
cd "$srcdir/uhd-release_$_verstring/host/build"
cd "$srcdir/uhd-$pkgver/host/build"
make test
}
package() {
cd "$srcdir/uhd-release_$_verstring/host/build"
cd "$srcdir/uhd-$pkgver/host/build"
make DESTDIR="$pkgdir" install
install -Dm644 "../utils/uhd-usrp.rules" "$pkgdir/usr/lib/udev/rules.d/10-uhd-usrp.rules"
}

View file

@ -0,0 +1,12 @@
diff -upr uhd-3.11.1.0.orig/host/lib/usrp/e300/e300_fifo_config.cpp uhd-3.11.1.0/host/lib/usrp/e300/e300_fifo_config.cpp
--- uhd-3.11.1.0.orig/host/lib/usrp/e300/e300_fifo_config.cpp 2018-05-16 22:25:48.000000000 +0300
+++ uhd-3.11.1.0/host/lib/usrp/e300/e300_fifo_config.cpp 2018-06-03 00:16:53.119018076 +0300
@@ -107,7 +107,7 @@ struct e300_fifo_poll_waiter
boost::mutex::scoped_lock l(_mutex);
if (_poll_claimed)
{
- _cond.timed_wait(l, boost::posix_time::microseconds(timeout*1000000));
+ _cond.timed_wait(l, boost::posix_time::microseconds(long(timeout*1000000)));
}
else
{