mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libreoffice-fresh to 7.6.1-1
This commit is contained in:
parent
fba2043018
commit
46962bf730
2 changed files with 11 additions and 64 deletions
|
@ -1,53 +0,0 @@
|
|||
From 5484657d2b1677b7e385ab6ef87ad64dcb9934e4 Mon Sep 17 00:00:00 2001
|
||||
From: Noel Grandin <noel.grandin@collabora.co.uk>
|
||||
Date: Thu, 10 Aug 2023 17:42:12 +0200
|
||||
Subject: [PATCH] tdf#156209 Font size increases when copying from cell in edit mode
|
||||
|
||||
Regression from 0558926c2f9201a12b4c46efc36b8a4080af4d46
|
||||
"use more officecfg for SvtMiscOptions".
|
||||
|
||||
However.... even reverting the above commit does not fix the problem.
|
||||
This is because there is an underlying latent bug, where depending on the order of initialisation of various and when they fire events, we can end up calling the alternative path in ScInputHandler::ImplCreateEditEngine which creates a pool via EditEngine::CreatePool(), which ends up having the "wrong" default map unit. And then that pool sticks around even after we have a document, and causes the reported bug.
|
||||
|
||||
Solve it by simply not initialising the pool until we have an associated document, which is fine, since we don't actually need the pool until then.
|
||||
|
||||
|
||||
Change-Id: If012c82df225e59dca828556bfca84c1948b5887
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/155560
|
||||
Tested-by: Noel Grandin <noel.grandin@collabora.co.uk>
|
||||
Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
|
||||
---
|
||||
|
||||
diff --git a/sc/source/ui/app/inputhdl.cxx b/sc/source/ui/app/inputhdl.cxx
|
||||
index 3351408..1267509 100644
|
||||
--- a/sc/source/ui/app/inputhdl.cxx
|
||||
+++ b/sc/source/ui/app/inputhdl.cxx
|
||||
@@ -928,14 +928,10 @@
|
||||
if ( mpEditEngine )
|
||||
return;
|
||||
|
||||
- if ( pActiveViewSh )
|
||||
- {
|
||||
- ScDocument& rDoc = pActiveViewSh->GetViewData().GetDocShell()->GetDocument();
|
||||
- mpEditEngine = std::make_unique<ScFieldEditEngine>(&rDoc, rDoc.GetEnginePool(), rDoc.GetEditPool());
|
||||
- }
|
||||
- else
|
||||
- mpEditEngine = std::make_unique<ScFieldEditEngine>(nullptr, EditEngine::CreatePool().get(), nullptr, true);
|
||||
-
|
||||
+ // we cannot create a properly initialised EditEngine until we have a document
|
||||
+ assert( pActiveViewSh );
|
||||
+ ScDocument& rDoc = pActiveViewSh->GetViewData().GetDocShell()->GetDocument();
|
||||
+ mpEditEngine = std::make_unique<ScFieldEditEngine>(&rDoc, rDoc.GetEnginePool(), rDoc.GetEditPool());
|
||||
mpEditEngine->SetWordDelimiters( ScEditUtil::ModifyDelimiters( mpEditEngine->GetWordDelimiters() ) );
|
||||
UpdateRefDevice(); // also sets MapMode
|
||||
mpEditEngine->SetPaperSize( Size( 1000000, 1000000 ) );
|
||||
@@ -4197,7 +4193,8 @@
|
||||
else
|
||||
pActiveViewSh = dynamic_cast<ScTabViewShell*>( SfxViewShell::Current() );
|
||||
|
||||
- ImplCreateEditEngine();
|
||||
+ if (pActiveViewSh)
|
||||
+ ImplCreateEditEngine();
|
||||
|
||||
if ( pState != pLastState.get() )
|
||||
{
|
|
@ -17,9 +17,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
|
|||
|
||||
pkgbase=libreoffice-fresh
|
||||
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
|
||||
_LOver=7.6.0.3
|
||||
pkgver=7.6.0
|
||||
pkgrel=3
|
||||
_LOver=7.6.1.2
|
||||
pkgver=7.6.1
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -68,7 +68,6 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
623ea5c.diff
|
||||
5484657.diff
|
||||
soffice-template.desktop.in
|
||||
libreoffice-fresh.sh libreoffice-fresh.csh)
|
||||
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -93,11 +92,11 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
|||
185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
)
|
||||
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
|
||||
sha256sums=('07f33f11a75b72a3044749d4f2f7d02a0fd79eaed4fb73e618ec5fe3576d0c25'
|
||||
sha256sums=('763a799ff15afee0b0b02bf222000a90e9101d3047b5bfc14f6fc94759833d1d'
|
||||
'SKIP'
|
||||
'210f18ff60e93d366856d84e714d3fd6f184f399b5163afc92b7e11155cbe768'
|
||||
'205b0b4fd922200e96f33964a07f0fcd10a2c04b8e041a702d68fba30c3f3428'
|
||||
'SKIP'
|
||||
'667e4ffeacc01bd0f830c2edcc56e2328f924eeac224639babeb3841a44ec5f4'
|
||||
'4d942b709869fb504f62e4dec4e213dfe15775a0eb0e12608f6e578632933e46'
|
||||
'SKIP'
|
||||
'64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1'
|
||||
'1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
|
||||
|
@ -121,7 +120,6 @@ sha256sums=('07f33f11a75b72a3044749d4f2f7d02a0fd79eaed4fb73e618ec5fe3576d0c25'
|
|||
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
|
||||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'440c9af5f3d1213d8ed7177282380f25cbc981cabc8b590dcb777aaae84178e5'
|
||||
'f4a61b909460162cc0f9140020b996a2a2d7d0d42362dbb9eb42ac81fa46d6a7'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'b43ed267643fc5ced803dca010427b12b1f10db485173ccb19efb3395e60c82e'
|
||||
'66f2cb5d2ff9909ee9633aea73d5306fc8c4ff358fa526f45d9994210d3e23ff')
|
||||
|
@ -148,9 +146,6 @@ prepare() {
|
|||
# fix build - https://gerrit.libreoffice.org/c/core/+/145421
|
||||
patch -Np1 -i "${srcdir}"/623ea5c.diff
|
||||
|
||||
# tdf#156209 / FS#79484 calc font size bug
|
||||
patch -Np1 -i "${srcdir}"/5484657.diff
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
case "$i" in
|
||||
|
@ -166,6 +161,11 @@ build() {
|
|||
# strip -s from Makeflags in case you use it to shorten build logs
|
||||
_MAKEFLAGS=${MAKEFLAGS/-s/}
|
||||
|
||||
# this uses malloc_usable_size, which is incompatible with fortification level 3
|
||||
# /usr/lib/libreoffice/program/libskialo.so uses malloc_usable_size
|
||||
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
|
||||
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
|
||||
|
||||
# http://site.icu-project.org/download/61#TOC-Migration-Issues
|
||||
CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
|
||||
|
||||
|
|
Loading…
Reference in a new issue