community/consul to 1.4.2-1

This commit is contained in:
Kevin Mihelich 2019-03-01 13:52:37 +00:00
parent 6e6446765b
commit 469af5a1a1
5 changed files with 160 additions and 15 deletions

View file

@ -3,9 +3,10 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix ARM build
# - remove export GOARCH='amd64'
pkgname=consul
pkgver=1.2.3
pkgver=1.4.2
pkgrel=1
pkgdesc="A tool for service discovery, monitoring and configuration."
arch=('x86_64')
@ -20,17 +21,23 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/consul/archiv
'consul.default'
'consul.sysusers'
'example.json'
'consul-ldflags.patch'
'fix-build-version-info.patch'
'disable-syslog-test.patch'
'unparallelize-or-disable-flaky-tests.patch'
'0001-fix-ARM-build.patch')
install=consul.install
backup=('etc/default/consul')
sha512sums=('71a7dbfc031df4a96faf2ddd829f289e96adefd0e0087208bbdd26e742a24e3da05fceea4181eb915703ad3323ed5b02bf74eb3fdfbed1e9a1afa2f74acb2a34'
sha512sums=('7890626903ae167bddd31eac92da8da56df46c913e4a5e166cec910b749bdf24df4eaa5f9f13f2d0b6ff8f4133a81d85a5b2c90ef52275a4caa752c737b8210f'
'SKIP'
'c70b9d1556f6c7ecb2e915ab685f289cef0e31198bd2e50c74a0483bbfb387beec67334f539a90adbf68b61b07946e98b300ab8a8e26e53b35f4ab4894adeb04'
'ec5a800529a297c709fa383c094ecf106351cf0f8ac7b613b972d415d77fe001088902d7ab805e63e78a8e6360323fec1b795db5a4446df1e21b9b4ed31e7079'
'ef872aedb2bc022a29292b7972a792b22e684c1ccb904a2b2cfec6d8966c28fb19be1452ce060821c419f1b646b236ba2e783175595e4bb6926d164c27a15c87'
'c4292b8f56ee955ed7385a49843fd90d6434029891b3e1e724cb2fc841514c06e2554a26d3937c114371b18c2168c4e64319eb2cbd726ee8b35870df19089348'
'6709e51ff57fbe8118e7c9b38c99ef096a62d0c88ac2694e8c86065052cd2600f65dd9ac7f4a7e60712c26d15355f938cd9d98684955f4a02b2d5adfe1c2c04e'
'1d261cc36c3fe617db55d1bfa31354637cdd707bfc803582181e86f64fb8166905b46ba91b326d205392e142ba53deeb6dc1ed8f0f0fefe5201c10773e904b1c'
'64a73277468929c65f7aa3ef1523a5e170b18333129629d5070492e773f63cfdf56ff9a670798d140ef301bece1579bdc881343499b5ea7a0d807c7c95154a2e'
'2a2e31469708f66877885c9e38f2044da13067c4111fc081ffea6187ff39acea6b17c0d33b2d0ada614315c3e5759a7592fbf7b0e9e9094ba2c31003bf1dbd4c'
'b59b2733d598ae6648c198f26f23961d4c1ea8c693a1a5b1c16a0951400c3bb9a9d2d5efe4f0a5cca9ae3b1f225a8eb4133c9011c4125589e936c7dcdc4b2495'
'b9be57fc21ffccd5083ceccd96937d8d1e83b9e411b0ad1c4b79daad74aa11746afa360b937724cd6d559a9d679774e0abbaefe519bca6ad0b94462c57159f58')
prepare() {
@ -44,26 +51,29 @@ prepare() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
# use proper release build version string (w/o '-dev' suffix)
patch -p1 -N -l -i "${srcdir}/fix-build-version-info.patch"
# disable syslog test (requires running syslog service)
rm ./logger/syslog_test.go
# fix ARM build
patch -p1 -i "${srcdir}/0001-fix-ARM-build.patch"
local filename
for filename in "${source[@]}"; do
if [[ "$filename" =~ \.patch$ ]]; then
msg2 "Applying patch ${filename##*/}"
patch -p1 -N -l -i "$srcdir/${filename##*/}"
fi
done
}
build() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
# weird race conditions when being run with more than 1 thread...
taskset --cpu-list 0 make linux
export GOOS='linux'
make linux
}
check() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
# weird race conditions when being run with more than 1 thread...
taskset --cpu-list 0 make test
# weird race conditions when being run overparallelized
export GOMAXPROCS="2"
export GOOS='linux'
export GOTEST_FLAGS="-p 2 -parallel 2"
export CONSUL_TEST_SKIP_SYSLOG='true'
make -j1 test
}
package() {

View file

@ -0,0 +1,29 @@
--- a/GNUmakefile 2018-11-14 23:37:47.000000000 +0100
+++ b/GNUmakefile 2019-01-08 15:44:48.494251517 +0100
@@ -29,6 +29,7 @@ GIT_DIRTY?=$(shell test -n "`git status
GIT_DESCRIBE?=$(shell git describe --tags --always)
GIT_IMPORT=github.com/hashicorp/consul/version
GOLDFLAGS=-X $(GIT_IMPORT).GitCommit=$(GIT_COMMIT)$(GIT_DIRTY) -X $(GIT_IMPORT).GitDescribe=$(GIT_DESCRIBE)
+EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
NOCACHE=--no-cache
@@ -98,6 +99,7 @@ export GIT_DIRTY
export GIT_DESCRIBE
export GOTAGS
export GOLDFLAGS
+export EXTLDFLAGS
DEV_PUSH?=0
--- a/build-support/functions/20-build.sh 2018-11-14 23:37:47.000000000 +0100
+++ b/build-support/functions/20-build.sh 2019-01-08 15:03:55.598451424 +0100
@@ -468,7 +468,7 @@ function build_consul_local {
if [ $os == "windows" ];then
binname="consul.exe"
fi
- CGO_ENABLED=0 GOOS=${os} GOARCH=${arch} go install -ldflags "${GOLDFLAGS}" -tags "${GOTAGS}" && cp "${MAIN_GOPATH}/bin/${GOBIN_EXTRA}${binname}" "${outdir}/${binname}"
+ CGO_ENABLED=0 GOOS=${os} GOARCH=${arch} go install -ldflags "-linkmode external -extldflags ${EXTLDFLAGS} -s -w ${GOLDFLAGS}" -tags "${GOTAGS}" && cp "${MAIN_GOPATH}/bin/${GOBIN_EXTRA}${binname}" "${outdir}/${binname}"
if test $? -ne 0
then
err "ERROR: Failed to build Consul for ${osarch}"

View file

@ -0,0 +1,12 @@
--- a/./logger/syslog_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/./logger/syslog_test.go 2019-01-04 14:16:21.575451546 +0100
@@ -16,6 +16,9 @@ func TestSyslogFilter(t *testing.T) {
if os.Getenv("TRAVIS") == "true" {
t.Skip("Syslog not supported on travis-ci")
}
+ if os.Getenv("CONSUL_TEST_SKIP_SYSLOG") == "true" {
+ t.Skip("Skipping test due to env var CONSUL_TEST_SKIP_SYSLOG being set")
+ }
l, err := gsyslog.NewLogger(gsyslog.LOG_NOTICE, "LOCAL0", "consul")
if err != nil {

View file

@ -33,3 +33,43 @@
// Strip off any single quotes added by the git information.
return strings.Replace(version, "'", "", -1)
--- b/GNUmakefile 2019-01-08 15:44:48.494251517 +0100
+++ c/GNUmakefile 2019-01-08 15:48:07.639739133 +0100
@@ -23,12 +23,7 @@ GOARCH?=$(shell go env GOARCH)
GOPATH=$(shell go env GOPATH)
ASSETFS_PATH?=agent/bindata_assetfs.go
-# Get the git commit
-GIT_COMMIT?=$(shell git rev-parse --short HEAD)
-GIT_DIRTY?=$(shell test -n "`git status --porcelain`" && echo "+CHANGES" || true)
-GIT_DESCRIBE?=$(shell git describe --tags --always)
-GIT_IMPORT=github.com/hashicorp/consul/version
-GOLDFLAGS=-X $(GIT_IMPORT).GitCommit=$(GIT_COMMIT)$(GIT_DIRTY) -X $(GIT_IMPORT).GitDescribe=$(GIT_DESCRIBE)
+GOLDFLAGS=
EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
@@ -238,17 +233,6 @@ ui: ui-legacy-docker ui-docker static-as
tools:
go get -u -v $(GOTOOLS)
-version:
- @echo -n "Version: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh
- @echo -n "Version + release: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -r
- @echo -n "Version + git: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -g
- @echo -n "Version + release + git: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -r -g
-
-
docker-images: go-build-image ui-build-image ui-legacy-build-image
go-build-image:
@@ -276,4 +263,4 @@ ui-legacy-docker: ui-legacy-build-image
.PHONY: all ci bin dev dist cov test test-ci test-internal test-install-deps cover format vet ui static-assets tools vendorfmt
-.PHONY: docker-images go-build-image ui-build-image ui-legacy-build-image static-assets-docker consul-docker ui-docker ui-legacy-docker version proto
+.PHONY: docker-images go-build-image ui-build-image ui-legacy-build-image static-assets-docker consul-docker ui-docker ui-legacy-docker proto

View file

@ -0,0 +1,54 @@
diff -upr a/agent/cache/cache_test.go b/agent/cache/cache_test.go
--- a/agent/cache/cache_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/agent/cache/cache_test.go 2019-01-08 15:23:12.540631267 +0100
@@ -213,7 +213,6 @@ func TestCacheGet_blockingInitSameKey(t
// Test that Get with different cache keys both block on initial value
// but that the fetches were both properly called.
func TestCacheGet_blockingInitDiffKeys(t *testing.T) {
- t.Parallel()
require := require.New(t)
@@ -299,7 +298,6 @@ func TestCacheGet_blockingIndex(t *testi
// Test a get with an index set will timeout if the fetch doesn't return
// anything.
func TestCacheGet_blockingIndexTimeout(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -438,7 +436,6 @@ func TestCacheGet_emptyFetchResult(t *te
// Test that a type registered with a periodic refresh will perform
// that refresh after the timer is up.
func TestCacheGet_periodicRefresh(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -525,7 +522,6 @@ func TestCacheGet_periodicRefreshMultipl
// Test that a refresh performs a backoff.
func TestCacheGet_periodicRefreshErrorBackoff(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -566,7 +562,6 @@ func TestCacheGet_periodicRefreshErrorBa
// Test that a badly behaved RPC that returns 0 index will perform a backoff.
func TestCacheGet_periodicRefreshBadRPCZeroIndexErrorBackoff(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
diff -upr a/agent/cache-types/connect_ca_leaf_test.go b/agent/cache-types/connect_ca_leaf_test.go
--- a/agent/cache-types/connect_ca_leaf_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/agent/cache-types/connect_ca_leaf_test.go 2019-01-08 15:23:55.670339830 +0100
@@ -870,7 +870,6 @@ func TestConnectCALeaf_changingRoots(t *
// Test that after an initial signing, an expiringLeaf will trigger a
// blocking query to resign.
func TestConnectCALeaf_expiringLeaf(t *testing.T) {
- t.Parallel()
require := require.New(t)
rpc := TestRPC(t)