community/xbmc to 13.2-2

This commit is contained in:
Kevin Mihelich 2014-08-19 00:12:08 +00:00
parent 250fab8bcc
commit 46a1d99550
3 changed files with 4 additions and 60 deletions

View file

@ -1,27 +0,0 @@
From 6abfd7104202121d3e23ddad47e377dfaef22b10 Mon Sep 17 00:00:00 2001
From: BlackEagle <ike.devolder@gmail.com>
Date: Sun, 25 May 2014 12:10:01 +0200
Subject: [PATCH] make sure applications/xbmc.desktop does'nt have executable
flag
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
---
Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index 754f153..bee1fdd 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -646,7 +646,7 @@ endif
endif
@# Icons and links
@install -d $(DESTDIR)$(datarootdir)/applications
- @install tools/Linux/xbmc.desktop $(DESTDIR)$(datarootdir)/applications/xbmc.desktop
+ @install -m 0644 tools/Linux/xbmc.desktop $(DESTDIR)$(datarootdir)/applications/xbmc.desktop
@install -d $(DESTDIR)$(datadir)/icons/hicolor/48x48/apps
@install -m 0644 media/icon48x48.png $(DESTDIR)$(datadir)/icons/hicolor/48x48/apps/xbmc.png
@install -d $(DESTDIR)$(datadir)/icons/hicolor/256x256/apps
--
1.9.1

View file

@ -16,9 +16,9 @@ buildarch=4
_prefix=/usr
pkgname=xbmc
pkgver=13.1
pkgver=13.2
_codename=Gotham
pkgrel=5
pkgrel=2
pkgdesc="A software media player and entertainment hub for digital media"
arch=('i686' 'x86_64')
url="http://xbmc.org"
@ -50,10 +50,8 @@ optdepends=(
)
install="${pkgname}.install"
source=("xbmc-$pkgver-$_codename.tar.gz::https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
'enable-external-ffmpeg.patch'
'0001-make-sure-applications-xbmc.desktop-does-nt-have-exe.patch'
'libnfs-header-changes.patch')
sha256sums=('344b604eae2ddb47c032dd7964d01f27e6fcd7a8873c84c0841d5da75961a678'
'enable-external-ffmpeg.patch')
sha256sums=('acbf5dffa3034a3406240ee3cf81e721386cd383d23d056ddde1f769e050e585'
'0239e33e87292c7340ed2092f2b5f1e82f5e283b1f763fb125b3aee78f50c355'
'5f5fe2932050265ad71c82b5d23efe5eaf7b2b3a152bdc6da66675cfb655fabe'
'cec996873f7c45fd01c04b5598152f4a13509eed9b38f395dd1fe0d5c8a4c1ff')
@ -61,8 +59,6 @@ sha256sums=('344b604eae2ddb47c032dd7964d01f27e6fcd7a8873c84c0841d5da75961a678'
prepare() {
cd "$srcdir/xbmc-$pkgver-$_codename"
patch -p1 -i "$srcdir/enable-external-ffmpeg.patch"
patch -p1 -i "$srcdir/0001-make-sure-applications-xbmc.desktop-does-nt-have-exe.patch"
patch -p1 -i "$srcdir/libnfs-header-changes.patch"
find -type f -name *.py -exec sed 's|^#!.*python$|#!/usr/bin/python2|' -i "{}" +
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
@ -107,7 +103,6 @@ build() {
--enable-udev \
--enable-libusb \
--enable-libcec \
--enable-external-libraries \
--with-lirc-device=/run/lirc/lircd \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
# Now (finally) build

View file

@ -1,24 +0,0 @@
diff --git a/xbmc/filesystem/NFSDirectory.cpp b/xbmc/filesystem/NFSDirectory.cpp
index 85084a5..8efa7bf 100644
--- a/xbmc/filesystem/NFSDirectory.cpp
+++ b/xbmc/filesystem/NFSDirectory.cpp
@@ -37,6 +37,7 @@
using namespace XFILE;
using namespace std;
#include <limits.h>
+#include <nfsc/libnfs-zdr.h>
#include <nfsc/libnfs-raw-mount.h>
#include <nfsc/libnfs-raw-nfs.h>
diff --git a/xbmc/filesystem/NFSFile.cpp b/xbmc/filesystem/NFSFile.cpp
index 479f3fe..2aeea32 100644
--- a/xbmc/filesystem/NFSFile.cpp
+++ b/xbmc/filesystem/NFSFile.cpp
@@ -32,6 +32,7 @@
#include "network/DNSNameCache.h"
#include "threads/SystemClock.h"
+#include <nfsc/libnfs-zdr.h>
#include <nfsc/libnfs-raw-mount.h>
#ifdef TARGET_WINDOWS