mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/boost to 1.50.0-1
This commit is contained in:
parent
d14b69c863
commit
470e1472ac
2 changed files with 4 additions and 34 deletions
|
@ -12,17 +12,15 @@ plugrel=1
|
||||||
|
|
||||||
pkgbase=boost
|
pkgbase=boost
|
||||||
pkgname=('boost-libs' 'boost')
|
pkgname=('boost-libs' 'boost')
|
||||||
pkgver=1.49.0
|
pkgver=1.50.0
|
||||||
_boostver=${pkgver//./_}
|
_boostver=${pkgver//./_}
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://www.boost.org/"
|
url="http://www.boost.org/"
|
||||||
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
|
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
|
||||||
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
|
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
|
||||||
exceptions.patch)
|
|
||||||
license=('custom')
|
license=('custom')
|
||||||
md5sums=('e0defc8c818e4f1c5bbb29d0292b76ca'
|
md5sums=('dbc07ab0254df3dda6300fd737b3f264')
|
||||||
'9b44c28b36303152050c8c82469569c5')
|
|
||||||
|
|
||||||
_stagedir="${srcdir}/stagedir"
|
_stagedir="${srcdir}/stagedir"
|
||||||
|
|
||||||
|
@ -33,9 +31,6 @@ build() {
|
||||||
echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
|
echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
|
||||||
|
|
||||||
cd "${srcdir}"/${pkgbase}_${_boostver}
|
cd "${srcdir}"/${pkgbase}_${_boostver}
|
||||||
# https://svn.boost.org/trac/boost/ticket/5731
|
|
||||||
patch -p0 -i "${srcdir}/exceptions.patch"
|
|
||||||
|
|
||||||
|
|
||||||
# build bjam
|
# build bjam
|
||||||
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
|
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
diff -up boost/numeric/conversion/converter_policies.hpp\~ boost/numeric/conversion/converter_policies.hpp
|
|
||||||
--- boost/numeric/conversion/converter_policies.hpp~ 2008-10-13 11:00:03.000000000 +0200
|
|
||||||
+++ boost/numeric/conversion/converter_policies.hpp 2011-07-22 11:46:40.961876274 +0200
|
|
||||||
@@ -20,6 +20,7 @@
|
|
||||||
|
|
||||||
#include "boost/mpl/if.hpp"
|
|
||||||
#include "boost/mpl/integral_c.hpp"
|
|
||||||
+#include "boost/throw_exception.hpp"
|
|
||||||
|
|
||||||
namespace boost { namespace numeric
|
|
||||||
{
|
|
||||||
@@ -159,9 +160,9 @@ struct def_overflow_handler
|
|
||||||
void operator() ( range_check_result r ) // throw(negative_overflow,positive_overflow)
|
|
||||||
{
|
|
||||||
if ( r == cNegOverflow )
|
|
||||||
- throw negative_overflow() ;
|
|
||||||
+ boost::throw_exception( negative_overflow() ) ;
|
|
||||||
else if ( r == cPosOverflow )
|
|
||||||
- throw positive_overflow() ;
|
|
||||||
+ boost::throw_exception( positive_overflow() ) ;
|
|
||||||
}
|
|
||||||
} ;
|
|
||||||
|
|
||||||
|
|
||||||
Diff finished. Fri Jul 22 11:46:49 2011
|
|
Loading…
Reference in a new issue