mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/doxygen to 1.8.11-4
This commit is contained in:
parent
21768d0deb
commit
471352e110
2 changed files with 6 additions and 50 deletions
|
@ -6,7 +6,7 @@
|
||||||
# - patch for AArch64
|
# - patch for AArch64
|
||||||
|
|
||||||
pkgname=doxygen
|
pkgname=doxygen
|
||||||
pkgver=1.8.10
|
pkgver=1.8.11
|
||||||
pkgrel=4
|
pkgrel=4
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
|
@ -14,17 +14,11 @@ url="http://www.doxygen.org/"
|
||||||
makedepends=('cmake' 'gcc-libs' 'flex' 'qt4' 'texlive-core' 'ghostscript'
|
makedepends=('cmake' 'gcc-libs' 'flex' 'qt4' 'texlive-core' 'ghostscript'
|
||||||
'texlive-latexextra' 'graphviz' 'python2')
|
'texlive-latexextra' 'graphviz' 'python2')
|
||||||
source=(http://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz
|
source=(http://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz
|
||||||
0001-Partial-revert-of-commit-080a465b1321.patch
|
0001-Partial-revert-of-commit-080a465b1321.patch)
|
||||||
flex-2.6.patch::"https://github.com/heirecka/doxygen/commit/5fcb1357.patch"
|
md5sums=('f4697a444feaed739cfa2f0644abc19b'
|
||||||
doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch)
|
'93cc5bb3f18c73a3e2b53d6276d87a11')
|
||||||
md5sums=('79767ccd986f12a0f949015efb5f058f'
|
sha1sums=('c0841007cf8a7910ccf0d8e4f7a5dd8fd2d9fc18'
|
||||||
'93cc5bb3f18c73a3e2b53d6276d87a11'
|
'aa03a6a51ff691ffef11d96bb25236f2f7655b6b')
|
||||||
'b282c91bac1888f607a3676a236d2828'
|
|
||||||
'7039d4a63c3a0e8ead83d1f828d5a271')
|
|
||||||
sha1sums=('6bad93cbdb1b2efacba14769d39bcc7bc9c0753b'
|
|
||||||
'aa03a6a51ff691ffef11d96bb25236f2f7655b6b'
|
|
||||||
'aeeb45547de0f659789588b563210d9511c6a291'
|
|
||||||
'5aea21a336015675075b3b8744e4444b0dc6c3d5')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir build
|
mkdir build
|
||||||
|
@ -36,12 +30,6 @@ prepare() {
|
||||||
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=759241
|
# https://bugzilla.gnome.org/show_bug.cgi?id=759241
|
||||||
patch -Np1 -i ../0001-Partial-revert-of-commit-080a465b1321.patch
|
patch -Np1 -i ../0001-Partial-revert-of-commit-080a465b1321.patch
|
||||||
|
|
||||||
# Fix build with flex 2.6
|
|
||||||
patch -p1 -i ../flex-2.6.patch
|
|
||||||
|
|
||||||
# Fix AArch64 build
|
|
||||||
patch -p1 -i ../doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
From 031780293d2838da2643b46878061598ebb56822 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
|
|
||||||
Date: Thu, 8 Oct 2015 10:24:36 +0200
|
|
||||||
Subject: [PATCH] DO NOT hardcode x86-64 architecture.
|
|
||||||
|
|
||||||
doxygen built on most of architectures by pure luck and order of Qt5
|
|
||||||
qatomics_arch.h header where check for QT_ARCH_X86_64 was *after* most
|
|
||||||
of other architectures.
|
|
||||||
|
|
||||||
But not after AArch64 where it failed due to attempt of using x86-64
|
|
||||||
atomics code.
|
|
||||||
|
|
||||||
https://github.com/doxygen/doxygen/pull/402
|
|
||||||
|
|
||||||
Signed-off-by: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
|
|
||||||
---
|
|
||||||
addon/doxywizard/CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
Index: doxygen-1.8.10/addon/doxywizard/CMakeLists.txt
|
|
||||||
===================================================================
|
|
||||||
--- doxygen-1.8.10.orig/addon/doxywizard/CMakeLists.txt
|
|
||||||
+++ doxygen-1.8.10/addon/doxywizard/CMakeLists.txt
|
|
||||||
@@ -10,7 +10,7 @@ include_directories(
|
|
||||||
set(GENERATED_SRC_WIZARD ${GENERATED_SRC}/doxywizard)
|
|
||||||
file(MAKE_DIRECTORY ${GENERATED_SRC_WIZARD})
|
|
||||||
|
|
||||||
-add_definitions(-DQT_ARCH_X86_64 -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
|
|
||||||
+add_definitions(-DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
|
|
||||||
set(QT_USE_QTXML TRUE)
|
|
||||||
find_package(Qt4 REQUIRED)
|
|
||||||
include(${QT_USE_FILE})
|
|
Loading…
Reference in a new issue