mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java7-openjdk: v8 fix
This commit is contained in:
parent
589c45a68d
commit
47365142c6
2 changed files with 20 additions and 3 deletions
|
@ -8,6 +8,7 @@
|
|||
# - --enable-zero
|
||||
# - added our architectures to set _JARCH
|
||||
# - strip -D_FORTIFY_SOURCE=2 from C/CXXFLAGS
|
||||
# - patch to fix fPIC usage on AArch64
|
||||
|
||||
pkgname=('jre7-openjdk-headless' 'jre7-openjdk' 'jdk7-openjdk' 'openjdk7-src')
|
||||
pkgbase=java7-openjdk
|
||||
|
@ -44,7 +45,8 @@ source=(${_icedtea_url}/source/icedtea-${_icedtea_ver}.tar.xz{,.sig}
|
|||
icedtea_${_icedtea_ver}_langtools.tar.bz2::${_drops_url}/langtools.tar.bz2
|
||||
icedtea_${_icedtea_ver}_hotspot.tar.bz2::${_drops_url}/hotspot.tar.bz2
|
||||
fontconfig-paths.diff
|
||||
openjdk7_nonreparenting-wm.diff)
|
||||
openjdk7_nonreparenting-wm.diff
|
||||
text-relocations.diff)
|
||||
# EdDSA key may require `keyserver sks-keyservers.net` in GPG config
|
||||
validpgpkeys=('5132579DD1540ED23E04C5A0CFDA0F9B35964222') # Andrew John Hughes
|
||||
|
||||
|
@ -60,7 +62,8 @@ sha256sums=('104e84205d1176e217e24f770784c53d1cd666aeb23ab0bae8ac858e5b0e63f0'
|
|||
'12036b985f8811cdadf6d5bf840f90bab25f4da1cc3e86bab9c3f6efcc10055b'
|
||||
'9ae3d6d43ff771cf02b8c7805ac0f0a457f5fa7026b1334ea1085262d3d86d9d'
|
||||
'9ad943ceb3dbcdf45d72974fc3667886a7ed65c69ab9abc17be5412827551a7f'
|
||||
'56b919ababb13bd6afdcdaceb112b529b6e82539255f2dae9a7e5eb91645164b')
|
||||
'56b919ababb13bd6afdcdaceb112b529b6e82539255f2dae9a7e5eb91645164b'
|
||||
'6dd92db9ba302141c94a2031082e3e130bcb370a5adcb8185467dd22cbff6b51')
|
||||
|
||||
noextract=(icedtea_${_icedtea_ver}_openjdk.tar.bz2
|
||||
icedtea_${_icedtea_ver}_corba.tar.bz2
|
||||
|
@ -94,7 +97,8 @@ build() {
|
|||
|
||||
cp "${srcdir}"/*.diff "${srcdir}"/icedtea-${_icedtea_ver}/patches
|
||||
export DISTRIBUTION_PATCHES="patches/fontconfig-paths.diff \
|
||||
patches/openjdk7_nonreparenting-wm.diff"
|
||||
patches/openjdk7_nonreparenting-wm.diff \
|
||||
patches/text-relocations.diff"
|
||||
|
||||
if [ "$_bootstrap" = "1" ]; then
|
||||
BOOTSTRAPOPT="--enable-bootstrap --with-ecj-jar=/usr/share/java/ecj.jar"
|
||||
|
|
13
extra/java7-openjdk/text-relocations.diff
Normal file
13
extra/java7-openjdk/text-relocations.diff
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: openjdk/hotspot/make/linux/makefiles/gcc.make
|
||||
===================================================================
|
||||
--- openjdk/hotspot/make/linux/makefiles/gcc.make
|
||||
+++ openjdk/hotspot/make/linux/makefiles/gcc.make
|
||||
@@ -66,7 +66,7 @@ endif
|
||||
# Compiler flags
|
||||
|
||||
# position-independent code
|
||||
-ifneq ($(filter parisc ppc ppc64 s390 s390x sparc sparc64 sparcv9,$(ZERO_LIBARCH)),)
|
||||
+ifneq ($(filter aarch64 alpha m68k mips mipsel parisc ppc ppc64 s390 s390x sparc sparc64 sparcv9,$(ZERO_LIBARCH)),)
|
||||
PICFLAG = -fPIC
|
||||
else
|
||||
PICFLAG = -fpic
|
Loading…
Reference in a new issue