mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/glibc: drop patch
This commit is contained in:
parent
0b990359bb
commit
4788a2f558
2 changed files with 0 additions and 26 deletions
|
@ -29,22 +29,14 @@ backup=(etc/gai.conf
|
||||||
options=('!strip' 'staticlibs' '!distcc')
|
options=('!strip' 'staticlibs' '!distcc')
|
||||||
install=glibc.install
|
install=glibc.install
|
||||||
source=(git://sourceware.org/git/glibc.git#commit=${_commit}
|
source=(git://sourceware.org/git/glibc.git#commit=${_commit}
|
||||||
local-soname-hack.diff
|
|
||||||
locale.gen.txt
|
locale.gen.txt
|
||||||
locale-gen)
|
locale-gen)
|
||||||
md5sums=('SKIP'
|
md5sums=('SKIP'
|
||||||
'905370139382428ef2b97b247c0970bf'
|
|
||||||
'07ac979b6ab5eeb778d55f041529d623'
|
'07ac979b6ab5eeb778d55f041529d623'
|
||||||
'476e9113489f93b348b21e144b6a8fcf')
|
'476e9113489f93b348b21e144b6a8fcf')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir glibc-build
|
mkdir glibc-build
|
||||||
|
|
||||||
cd ${pkgname}
|
|
||||||
# ALARM: patch for hard-float ld-linux soname
|
|
||||||
if [[ $CARCH == "armv6h" || $CARCH == "armv7h" ]]; then
|
|
||||||
patch -p1 -i ${srcdir}/local-soname-hack.diff
|
|
||||||
fi
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
diff -urN a/elf/dl-load.c b/elf/dl-load.c
|
|
||||||
--- a/elf/dl-load.c 2013-08-10 16:52:55.000000000 -0600
|
|
||||||
+++ b/elf/dl-load.c 2014-01-17 12:25:32.482819996 -0700
|
|
||||||
@@ -2105,10 +2105,13 @@
|
|
||||||
soname = ((const char *) D_PTR (l, l_info[DT_STRTAB])
|
|
||||||
+ l->l_info[DT_SONAME]->d_un.d_val);
|
|
||||||
if (strcmp (name, soname) != 0)
|
|
||||||
+#ifdef __arm__
|
|
||||||
+ if (strcmp(name, "ld-linux.so.3") || strcmp(soname, "ld-linux-armhf.so.3"))
|
|
||||||
+#endif
|
|
||||||
continue;
|
|
||||||
|
|
||||||
/* We have a match on a new name -- cache it. */
|
|
||||||
- add_name_to_object (l, soname);
|
|
||||||
+ add_name_to_object (l, name);
|
|
||||||
l->l_soname_added = 1;
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in a new issue