removed community/ceph

This commit is contained in:
Kevin Mihelich 2019-10-06 15:41:54 +00:00
parent 30be8014c3
commit 47984386f9
10 changed files with 0 additions and 752 deletions

View file

@ -1,158 +0,0 @@
From d04bf15ce582037c8b256711c697238bbdb4c031 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 5 Jul 2018 09:54:41 -0600
Subject: [PATCH] Fix building on 32-bit ARM
---
src/common/ceph_context.h | 2 +-
src/mon/OSDMonitor.cc | 4 ++--
src/os/bluestore/BlueStore.cc | 2 +-
src/osd/PrimaryLogPG.cc | 4 ++--
src/rgw/rgw_op.h | 4 ++--
src/rgw/rgw_rest_swift.cc | 6 +++---
src/rgw/rgw_sync_log_trim.cc | 4 ++--
src/test/rbd_mirror/test_ImageSync.cc | 2 +-
8 files changed, 14 insertions(+), 14 deletions(-)
diff --git a/src/common/ceph_context.h b/src/common/ceph_context.h
index 6af282225c..cda1b002a2 100644
--- a/src/common/ceph_context.h
+++ b/src/common/ceph_context.h
@@ -144,7 +144,7 @@ public:
void do_command(std::string_view command, const cmdmap_t& cmdmap,
std::string_view format, ceph::bufferlist *out);
- static constexpr std::size_t largest_singleton = sizeof(void*) * 72;
+ static constexpr std::size_t largest_singleton = sizeof(void*) * 128;
template<typename T, typename... Args>
T& lookup_or_create_singleton_object(std::string_view name,
diff --git a/src/mon/OSDMonitor.cc b/src/mon/OSDMonitor.cc
index 244c8dbf1b..3e96017289 100644
--- a/src/mon/OSDMonitor.cc
+++ b/src/mon/OSDMonitor.cc
@@ -738,8 +738,8 @@ OSDMonitor::update_pending_pgs(const OSDMap::Incremental& inc,
<< " modified " << p->second.modified
<< " [" << p->second.start << "-" << p->second.end << ")"
<< dendl;
- int n = std::min(max - pending_creatings.pgs.size(),
- p->second.end - p->second.start);
+ int n = std::min((long)(max - pending_creatings.pgs.size()),
+ (long)(p->second.end - p->second.start));
ps_t first = p->second.start;
ps_t end = first + n;
for (ps_t ps = first; ps < end; ++ps) {
diff --git a/src/os/bluestore/BlueStore.cc b/src/os/bluestore/BlueStore.cc
index 17e485a131..2903881156 100644
--- a/src/os/bluestore/BlueStore.cc
+++ b/src/os/bluestore/BlueStore.cc
@@ -12225,7 +12225,7 @@ size_t BlueStoreRepairer::StoreSpaceTracker::filter_out(
if (e.second == 0) {
continue;
}
- size_t pos = max(e.first / granularity, prev_pos);
+ size_t pos = max((long)(e.first / granularity), (long)prev_pos);
size_t end_pos = 1 + (e.first + e.second - 1) / granularity;
while (pos != npos && pos < end_pos) {
assert( collections_bfs[pos].element_count() ==
diff --git a/src/osd/PrimaryLogPG.cc b/src/osd/PrimaryLogPG.cc
index 848b2dd12b..65e75ef8d6 100644
--- a/src/osd/PrimaryLogPG.cc
+++ b/src/osd/PrimaryLogPG.cc
@@ -1628,8 +1628,8 @@ void PrimaryLogPG::calc_trim_to()
if (limit != eversion_t() &&
limit != pg_trim_to &&
pg_log.get_log().approx_size() > target) {
- size_t num_to_trim = std::min(pg_log.get_log().approx_size() - target,
- cct->_conf->osd_pg_log_trim_max);
+ size_t num_to_trim = std::min((long)(pg_log.get_log().approx_size() - target),
+ (long)(cct->_conf->osd_pg_log_trim_max));
if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
cct->_conf->osd_pg_log_trim_max >= cct->_conf->osd_pg_log_trim_min) {
return;
diff --git a/src/rgw/rgw_op.h b/src/rgw/rgw_op.h
index da638eb4c0..07ab0a119d 100644
--- a/src/rgw/rgw_op.h
+++ b/src/rgw/rgw_op.h
@@ -1974,7 +1974,7 @@ static inline int rgw_get_request_metadata(CephContext* const cct,
* as ObjectStore::get_max_attr_name_length() can set the limit even
* lower than the "osd_max_attr_name_len" configurable. */
const size_t max_attr_name_len = \
- cct->_conf->get_val<size_t>("rgw_max_attr_name_len");
+ cct->_conf->get_val<Option::size_t>("rgw_max_attr_name_len");
if (max_attr_name_len && attr_name.length() > max_attr_name_len) {
return -ENAMETOOLONG;
}
@@ -1990,7 +1990,7 @@ static inline int rgw_get_request_metadata(CephContext* const cct,
/* Swift allows administrators to limit the number of metadats items
* send _in a single request_. */
const auto rgw_max_attrs_num_in_req = \
- cct->_conf->get_val<size_t>("rgw_max_attrs_num_in_req");
+ cct->_conf->get_val<Option::size_t>("rgw_max_attrs_num_in_req");
if (rgw_max_attrs_num_in_req &&
++valid_meta_count > rgw_max_attrs_num_in_req) {
return -E2BIG;
diff --git a/src/rgw/rgw_rest_swift.cc b/src/rgw/rgw_rest_swift.cc
index ebf2803b62..70cef69f5c 100644
--- a/src/rgw/rgw_rest_swift.cc
+++ b/src/rgw/rgw_rest_swift.cc
@@ -724,7 +724,7 @@ static inline int handle_metadata_errors(req_state* const s, const int op_ret)
} else if (op_ret == -E2BIG) {
const auto error_message = boost::str(
boost::format("Too many metadata items; max %lld")
- % s->cct->_conf->get_val<size_t>("rgw_max_attrs_num_in_req"));
+ % s->cct->_conf->get_val<Option::size_t>("rgw_max_attrs_num_in_req"));
set_req_state_err(s, EINVAL, error_message);
return -EINVAL;
}
@@ -1779,7 +1779,7 @@ void RGWInfo_ObjStore_SWIFT::list_swift_data(Formatter& formatter,
formatter.dump_string("version", ceph_version);
const size_t max_attr_name_len = \
- g_conf->get_val<size_t>("rgw_max_attr_name_len");
+ g_conf->get_val<Option::size_t>("rgw_max_attr_name_len");
if (max_attr_name_len) {
const size_t meta_name_limit = \
max_attr_name_len - strlen(RGW_ATTR_PREFIX RGW_AMZ_META_PREFIX);
@@ -1792,7 +1792,7 @@ void RGWInfo_ObjStore_SWIFT::list_swift_data(Formatter& formatter,
}
const size_t meta_num_limit = \
- g_conf->get_val<size_t>("rgw_max_attrs_num_in_req");
+ g_conf->get_val<Option::size_t>("rgw_max_attrs_num_in_req");
if (meta_num_limit) {
formatter.dump_int("max_meta_count", meta_num_limit);
}
diff --git a/src/rgw/rgw_sync_log_trim.cc b/src/rgw/rgw_sync_log_trim.cc
index e1002253b8..b5dc6aa899 100644
--- a/src/rgw/rgw_sync_log_trim.cc
+++ b/src/rgw/rgw_sync_log_trim.cc
@@ -351,10 +351,10 @@ int take_min_status(CephContext *cct, Iter first, Iter last,
status->clear();
// The initialisation below is required to silence a false positive
// -Wmaybe-uninitialized warning
- boost::optional<size_t> num_shards = boost::make_optional(false, 0UL);
+ boost::optional<size_t> num_shards = boost::none;
for (auto peer = first; peer != last; ++peer) {
const size_t peer_shards = peer->size();
- if (!num_shards) {
+ if (num_shards == boost::none) {
num_shards = peer_shards;
status->resize(*num_shards);
} else if (*num_shards != peer_shards) {
diff --git a/src/test/rbd_mirror/test_ImageSync.cc b/src/test/rbd_mirror/test_ImageSync.cc
index 5ef2cbe77a..814c73b8ca 100644
--- a/src/test/rbd_mirror/test_ImageSync.cc
+++ b/src/test/rbd_mirror/test_ImageSync.cc
@@ -41,7 +41,7 @@ int flush(librbd::ImageCtx *image_ctx) {
void scribble(librbd::ImageCtx *image_ctx, int num_ops, size_t max_size)
{
- max_size = std::min(image_ctx->size, max_size);
+ max_size = std::min((long)image_ctx->size, (long)max_size);
for (int i=0; i<num_ops; i++) {
uint64_t off = rand() % (image_ctx->size - max_size + 1);
uint64_t len = 1 + rand() % max_size;
--
2.18.0

View file

@ -1,28 +0,0 @@
From 38f696ece361beffcc3f843c786f8b165d7ad81f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 9 Dec 2017 10:20:06 -0700
Subject: [PATCH] no neon
---
cmake/modules/SIMDExt.cmake | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/cmake/modules/SIMDExt.cmake b/cmake/modules/SIMDExt.cmake
index 021524e11e..2c4adc7307 100644
--- a/cmake/modules/SIMDExt.cmake
+++ b/cmake/modules/SIMDExt.cmake
@@ -68,10 +68,7 @@ if(CMAKE_SYSTEM_PROCESSOR MATCHES "aarch64|AARCH64")
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "arm|ARM")
set(HAVE_ARM 1)
- CHECK_C_COMPILER_FLAG(-mfpu=neon HAVE_ARM_NEON)
- if(HAVE_ARM_NEON)
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
- endif()
+ set(HAVE_ARM_NEON 0)
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
set(HAVE_INTEL 1)
--
2.17.1

View file

@ -1,213 +0,0 @@
# Maintainer: Thore Bödecker <foxxx0@archlinux.org>
# Contributor: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove neon detection in cmake
# - make -j1 on ARMv7, RAM constraints
# - patch to fix building on 32-bit ARM
highmem=1
buildarch=12
pkgbase='ceph'
pkgname=('ceph' 'ceph-libs')
pkgver=13.2.1
pkgrel=3
pkgdesc='Distributed, fault-tolerant storage platform delivering object, block, and file system'
arch=('x86_64')
url='https://ceph.com/'
license=('GPL')
makedepends=('bc' 'boost' 'boost-libs' 'cmake' 'cpio' 'crypto++' 'curl' 'cython'
'cython2' 'expat' 'fcgi' 'fuse2' 'gcc-libs' 'git' 'glibc' 'gperf' 'gperftools'
'gptfdisk' 'inetutils' 'jq' 'junit' 'keyutils' 'leveldb' 'libaio'
'libatomic_ops' 'libedit' 'libsystemd' 'libutil-linux' 'libxml2' 'lsb-release'
'lz4' 'ncurses' 'nss' 'parted' 'pcre' 'procps-ng' 'python2-cherrypy'
'python2-jinja' 'python2-nose' 'python2-pecan' 'python2-pip' 'python2-bcrypt'
'python2-prettytable' 'python2-pyopenssl' 'python2-setuptools' 'python2-routes'
'python2-sphinx' 'python2-tox' 'python2-virtualenv' 'python2-werkzeug' 'sed'
'snappy' 'socat' 'systemd' 'valgrind' 'xfsprogs' 'xmlstarlet' 'yasm'
'zlib' 'zstd' 'cunit' 'oath-toolkit' 'fontconfig')
options=('emptydirs')
source=("https://download.ceph.com/tarballs/${pkgbase}-${pkgver}.tar.gz"
'ceph.sysusers'
'0001-no-neon.patch'
'boost-1.67.patch'
'fix-ceph_disk-python-interpreter.patch'
'fix-or-disable-broken-tests.patch'
'fix-python2-paths.patch'
'remove-distro-version-detection.patch'
'0001-Fix-building-on-32-bit-ARM.diff')
sha512sums=('411218ea6037bdf9425a741720ea89876e893e64fbfa518c9584ba581f805fde2c82b13ed47313279665e5d20f36223fc8d5c27055b580c72b22c2004e4da81b'
'4354001c1abd9a0c385ba7bd529e3638fb6660b6a88d4e49706d4ac21c81b8e829303a20fb5445730bdac18c4865efb10bc809c1cd56d743c12aa9a52e160049'
'5b813e2532d5e497d44a41c57493fb4eacecd46cac56ad49815b9f5db798ddcb4fdeb6574e86b1b45fef526feef156d9262a98bb73cdf89c9960222f66ca6d55'
'b886c3f2b2a2b32d4033225b5f28cef98ca96e3f4fe2d04cfdbdb3141bbefd81895284abe9c9b75dcad156d54a93dc938bd8d9a45056b4de12855bbbdf0870ca'
'7abd94a333fb0d6c9f7156d69ed6d4bf123f0f3030407f4347209d677b282e5023664d43e74a21a27b7856d3493ae469a17ea8a810331c7266018cc34eee4841'
'915bb02b91a2e7c6e21243e5d4d80847aedaf6f899e3bac55f4ccae4bb8386c434aad7f052dd449fd510c103f7796bd0a25c0cfac72ee8d1e94d230cf2f0550a'
'b8ce48ab190b2408f38a7e78d755d762994d271f7bbf88f51392572d1976c4f81e8fad78eb38051df8ef287d70554214624c7b45359d4bef2c11d9ae7d61151c'
'02c9e8fd3c23fb4c9c4c576ee6d06e8525ca31decfd964fb7231e73c98fe2987a483dda680969752186f0918f47d9af4fb09a4901e5319077f45d870906716da'
'691184735728d95628df627d924d0290131a528ebf03f9682698115805e7ce49500e90f32c376cc26da19db3f5ff3d49c31ef42020ed9cc127f6ac301183de71')
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
# apply patch from the source array (should be a pacman feature)
local filename
for filename in "${source[@]}"; do
if [[ "$filename" =~ \.patch$ ]]; then
msg2 "Applying patch ${filename##*/}"
patch -p1 -N -i "$srcdir/${filename##*/}"
fi
done
# Fix building on 32-bit ARM
[[ $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Fix-building-on-32-bit-ARM.diff && MAKEFLAGS="-j1"
# remove tests that require root privileges
rm src/test/cli/ceph-authtool/cap*.t
# remove broken tests
rm src/test/cli/crushtool/build.t
rm -rf qa/btrfs
rm src/btrfs_ioc_test.c
# this test will try to perform btrfs operations when a btrfs mount
# is active on the build host, which will fail
if mount | grep 'type btrfs' &>/dev/null; then
sed -i '/run-tox-ceph-disk/d' src/test/CMakeLists.txt
fi
# fix python interpreter -> python2
for file in \
src/ceph-create-keys \
src/mount.fuse.ceph \
src/ceph-detect-init/ceph_detect_init/main.py
do
sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' "${file}"
done
}
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
mkdir -p build
cd build
# experimental in luminous: (and currently broken with boost 1.66)
# RADOSGW_BEAST_FRONTEND
# -> disabled
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DCMAKE_INSTALL_SBINDIR=/usr/bin \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
-DWITH_BABELTRACE=OFF \
-DWITH_CEPHFS=ON \
-DWITH_FUSE=ON \
-DWITH_LTTNG=OFF \
-DWITH_LZ4=ON \
-DWITH_MGR=ON \
-DWITH_NSS=ON \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DWITH_RADOSGW=ON \
-DWITH_RADOSGW_BEAST_FRONTEND=OFF \
-DWITH_RDMA=OFF \
-DWITH_SSL=ON \
-DWITH_SYSTEM_BOOST=ON \
-DWITH_SYSTEMD=ON \
-DWITH_TESTS=ON \
-DWITH_XFS=ON \
-DENABLE_SHARED=ON \
-DWITH_MGR_DASHBOARD_FRONTEND=OFF \
..
make all
}
check() {
cd "${srcdir}/${pkgbase}-${pkgver}/build"
export CTEST_PARALLEL_LEVEL="$(nproc)"
make check
# sometimes processes are not properly terminated...
for process in ceph-mon ceph-mgr ceph-osd; do
pkill -9 "$process" || true
done
}
package_ceph-libs() {
depends=('boost-libs' 'curl' 'glibc' 'keyutils' 'leveldb' 'libaio'
'libutil-linux' 'lz4' 'nss' 'python2' 'xfsprogs' 'oath-toolkit')
cd "${srcdir}/${pkgbase}-${pkgver}/build"
# main install
make DESTDIR="$pkgdir" install
# remove stuff that goes into the ceph package
rm -rf "${pkgdir}"/usr/lib/{ceph/mgr,systemd,sysusers.d,tmpfiles.d}
rm -rf "${pkgdir}/usr/share"
rm -rf "${pkgdir}/usr/sbin"
rm -rf "${pkgdir}/usr/bin"
rm -rf "${pkgdir}/etc"
rm -rf "${pkgdir}/var"
}
package_ceph() {
depends=('ceph-libs' 'boost-libs' 'curl' 'fuse2' 'glibc' 'gperftools'
'keyutils' 'leveldb' 'libaio' 'libsystemd' 'libutil-linux' 'python2-routes'
'lsb-release' 'ncurses' 'nss' 'python2' 'python2-cherrypy' 'python2-bcrypt'
'python2-jinja' 'python2-mako' 'python2-pecan' 'python2-prettytable'
'python2-pyopenssl' 'python2-setuptools' 'python2-singledispatch'
'python2-webob' 'python2-werkzeug' 'snappy' 'xfsprogs' 'python2-requests')
cd "${srcdir}/${pkgbase}-${pkgver}/build"
# main install
make DESTDIR="$pkgdir" install
# remove stuff that is in the ceph-libs package
find "${pkgdir}/usr/lib" -maxdepth 1 -type f -delete
find "${pkgdir}/usr/lib" -maxdepth 1 -type l -delete
find "${pkgdir}/usr/lib/ceph" -maxdepth 1 -type f -delete
find "${pkgdir}/usr/lib/ceph" -maxdepth 1 -type l -delete
rm -rf "${pkgdir}"/usr/lib/{ceph/{compressor,crypto,erasure-code},python2.7,rados-classes}
rm -rf "${pkgdir}/usr/include"
# install tmpfiles.d and sysusers.d stuff
install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/systemd/ceph.tmpfiles.d" \
"${pkgdir}/usr/lib/tmpfiles.d/${pkgbase}.conf"
install -Dm644 "${srcdir}/ceph.sysusers" \
"${pkgdir}/usr/lib/sysusers.d/${pkgbase}.conf"
# remove debian init script
rm -rf "${pkgdir}/etc/init.d"
# fix sbin dir (cmake opt seems to have no effect)
mv "${pkgdir}"/usr/sbin/* "${pkgdir}/usr/bin/"
rm -rf "${pkgdir}/usr/sbin"
# remove drop.ceph.com ssh stuff
rm -f "${pkgdir}/usr/share/ceph/{{known_hosts,id_rsa}_drop.ceph.com,.pub}"
# fix bash completions path
install -d -m 755 "${pkgdir}/usr/share/bash-completion"
mv "$pkgdir"/{etc/bash_completion.d,usr/share/bash-completion/completions}
# fix EnvironmentFile location in systemd service files
sed -i 's|/etc/sysconfig/|/etc/conf.d/|g' "${pkgdir}"/usr/lib/systemd/system/*.service
# prepare some paths and set correct permissions
install -D -d -m750 -o 0 -g 340 "${pkgdir}/etc/ceph"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/log/ceph"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/bootstrap-mds"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/bootstrap-osd"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/bootstrap-rgw"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/mon"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/mgr"
install -D -d -m750 -o 340 -g 340 "${pkgdir}/var/lib/ceph/osd"
}
# vim:set ts=2 sw=2 et:

View file

@ -1,11 +0,0 @@
--- a/src/test/librbd/test_mock_Journal.cc 2018-06-03 01:56:35.407273176 +0300
+++ b/src/test/librbd/test_mock_Journal.cc 2018-06-03 01:56:29.800506081 +0300
@@ -1,6 +1,8 @@
// -*- mode:C++; tab-width:8; c-basic-offset:2; indent-tabs-mode:t -*-
// vim: ts=8 sw=2 smarttab
+#define BOOST_BIND_NO_PLACEHOLDERS
+
#include "test/librbd/test_mock_fixture.h"
#include "test/journal/mock/MockJournaler.h"
#include "test/librbd/test_support.h"

View file

@ -1 +0,0 @@
u ceph 340 - /run/ceph

View file

@ -1,8 +0,0 @@
--- a/src/ceph-disk/ceph_disk/main.py 2017-08-28 18:30:20.000000000 +0200
+++ b/src/ceph-disk/ceph_disk/main.py 2017-09-21 13:50:39.373573382 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
#
# Copyright (C) 2015, 2016, 2017 Red Hat <contact@redhat.com>
# Copyright (C) 2014 Inktank <info@inktank.com>

View file

@ -1,260 +0,0 @@
--- a/src/test/CMakeLists.txt 2018-05-29 14:04:02.000000000 +0200
+++ b/src/test/CMakeLists.txt 2018-06-04 13:35:28.440465053 +0200
@@ -572,7 +572,6 @@ add_ceph_test(test_objectstore_memstore.
#add_ceph_test(test_pidfile.sh ${CMAKE_CURRENT_SOURCE_DIR}/test_pidfile.sh)
add_ceph_test(test_subman.sh ${CMAKE_CURRENT_SOURCE_DIR}/test_subman.sh)
-add_ceph_test(smoke.sh ${CMAKE_CURRENT_SOURCE_DIR}/smoke.sh)
add_ceph_test(unittest_bufferlist.sh ${CMAKE_SOURCE_DIR}/src/unittest_bufferlist.sh)
add_test(NAME run-tox-ceph-disk COMMAND bash ${CMAKE_SOURCE_DIR}/src/ceph-disk/run-tox.sh)
--- a/src/test/common/CMakeLists.txt 2018-05-29 14:04:02.000000000 +0200
+++ b/src/test/common/CMakeLists.txt 2018-06-04 13:36:33.340014839 +0200
@@ -41,13 +41,6 @@ add_executable(unittest_prioritized_queu
)
add_ceph_unittest(unittest_prioritized_queue)
-# unittest_mclock_priority_queue
-add_executable(unittest_mclock_priority_queue
- test_mclock_priority_queue.cc
- )
-add_ceph_unittest(unittest_mclock_priority_queue)
-target_link_libraries(unittest_mclock_priority_queue ceph-common dmclock)
-
# unittest_str_map
add_executable(unittest_str_map
test_str_map.cc
--- a/src/test/encoding/CMakeLists.txt 2018-05-29 14:04:02.000000000 +0200
+++ b/src/test/encoding/CMakeLists.txt 2018-06-04 13:37:22.693006351 +0200
@@ -1,4 +1,3 @@
# scripts
-add_ceph_test(check-generated.sh ${CMAKE_CURRENT_SOURCE_DIR}/check-generated.sh)
add_ceph_test(readable.sh ${CMAKE_CURRENT_SOURCE_DIR}/readable.sh)
--- a/src/test/run-cli-tests 2018-05-29 14:04:02.000000000 +0200
+++ b/src/test/run-cli-tests 2018-06-04 13:38:12.529328276 +0200
@@ -1,7 +1,7 @@
#!/bin/sh
set -e
-if ! command -v virtualenv >/dev/null; then
+if ! command -v virtualenv2 >/dev/null; then
echo "$0: virtualenv not installed, skipping python-using tests." 1>&2
exit 1
fi
@@ -30,7 +30,7 @@ if [ ! -e "$CRAM_BIN" ]; then
# patched cram to support that. See upstream ticket at
# https://bitbucket.org/brodie/cram/issue/9/allow-read-only-directories-for-t
# -- tv@inktank.com
- virtualenv "$VENV" && $VENV/bin/pip --log "$VENV"/log.txt install "$SRCDIR/downloads/cram-0.5.0ceph.2011-01-14.tar.gz"
+ virtualenv2 "$VENV" && $VENV/bin/pip --log "$VENV"/log.txt install "$SRCDIR/downloads/cram-0.5.0ceph.2011-01-14.tar.gz"
fi
SRCDIR_ABS="$(readlink -f "$SRCDIR")"
--- a/src/test/pybind/test_ceph_argparse.py 2017-09-26 18:27:07.000000000 +0200
+++ b/src/test/pybind/test_ceph_argparse.py 2017-10-08 16:50:49.060831801 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env nosetests
+#!/usr/bin/env nosetests2
# -*- mode:python; tab-width:4; indent-tabs-mode:t; coding:utf-8 -*-
# vim: ts=4 sw=4 smarttab expandtab fileencoding=utf-8
#
--- a/src/test/pybind/test_ceph_daemon.py 2017-09-26 18:27:07.000000000 +0200
+++ b/src/test/pybind/test_ceph_daemon.py 2017-10-08 16:50:58.341131927 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env nosetests
+#!/usr/bin/env nosetests2
# -*- mode:python; tab-width:4; indent-tabs-mode:t -*-
# vim: ts=4 sw=4 smarttab expandtab
#
--- a/qa/standalone/ceph-helpers.sh 2018-05-29 14:04:02.000000000 +0200
+++ b/qa/standalone/ceph-helpers.sh 2018-06-04 13:39:31.305450795 +0200
@@ -147,7 +147,7 @@ function teardown() {
kill_daemons $dir KILL
if [ `uname` != FreeBSD ] \
&& [ $(stat -f -c '%T' .) == "btrfs" ]; then
- __teardown_btrfs $dir
+ true
fi
local cores="no"
local pattern="$(sysctl -n $KERNCORE)"
@@ -183,12 +183,7 @@ function teardown() {
}
function __teardown_btrfs() {
- local btrfs_base_dir=$1
- local btrfs_root=$(df -P . | tail -1 | awk '{print $NF}')
- local btrfs_dirs=$(cd $btrfs_base_dir; sudo btrfs subvolume list -t . | awk '/^[0-9]/ {print $4}' | grep "$btrfs_base_dir/$btrfs_dir")
- for subvolume in $btrfs_dirs; do
- sudo btrfs subvolume delete $btrfs_root/$subvolume
- done
+ true
}
function test_teardown() {
--- a/src/ceph-disk/run-tox.sh 2018-05-29 14:04:02.000000000 +0200
+++ b/src/ceph-disk/run-tox.sh 2018-06-04 13:40:15.601811858 +0200
@@ -30,4 +30,4 @@ if [ -z $CEPH_BUILD_DIR ]; then
fi
source ${CEPH_DISK_VIRTUALENV}/bin/activate
-tox -c ${TOX_PATH}
+tox2 -c ${TOX_PATH}
--- a/qa/workunits/rbd/run_devstack_tempest.sh 2017-09-26 18:27:07.000000000 +0200
+++ b/qa/workunits/rbd/run_devstack_tempest.sh 2017-10-10 18:53:33.564468674 +0200
@@ -127,4 +127,4 @@
chmod -R o+rx ${STACK_OPT_PATH}/devstack/files
cd ${STACK_OPT_PATH}/tempest
-sudo -H -u ${TEMPEST_USER} tox -eall-plugin -- '(?!.*\[.*\bslow\b.*\])(^tempest\.(api|scenario)|(^cinder\.tests.tempest))' --concurrency=3
+sudo -H -u ${TEMPEST_USER} tox2 -eall-plugin -- '(?!.*\[.*\bslow\b.*\])(^tempest\.(api|scenario)|(^cinder\.tests.tempest))' --concurrency=3
--- a/src/test/filestore/TestFileStore.cc 2017-09-26 18:27:07.000000000 +0200
+++ b/src/test/filestore/TestFileStore.cc 2017-10-10 20:31:36.325983555 +0200
@@ -36,13 +36,6 @@
ASSERT_EQ(pm["filestore_backend"], "generic");
}
#if defined(__linux__)
- {
- map<string,string> pm;
- FileStore fs(g_ceph_context, "a", "b");
- TestFileStore::create_backend(fs, BTRFS_SUPER_MAGIC);
- fs.collect_metadata(&pm);
- ASSERT_EQ(pm["filestore_backend"], "btrfs");
- }
# ifdef HAVE_LIBXFS
{
map<string,string> pm;
--- a/src/test/cli/osdmaptool/ceph.conf.withracks 2017-09-26 18:27:07.000000000 +0200
+++ b/src/test/cli/osdmaptool/ceph.conf.withracks 2017-10-10 21:30:49.230389707 +0200
@@ -42,8 +42,8 @@
keyring = /mnt/osd.$id/keyring
osd data = /mnt/osd.$id
osd journal = /dev/disk/by-label/osd.$id.journal
- osd mkfs type = btrfs
- osd mount options btrfs = rw,noatime
+ osd mkfs type = xfs
+ osd mount options xfs = rw,noatime
devs = /dev/disk/by-label/osd.$id.data
; temp sage
debug osd = 20
--- a/src/spdk/test/iscsi_tgt/filesystem/filesystem.sh 2017-04-13 06:05:24.000000000 +0200
+++ b/src/spdk/test/iscsi_tgt/filesystem/filesystem.sh 2017-10-10 21:33:09.084930640 +0200
@@ -55,7 +55,7 @@
parted -s /dev/$dev mkpart primary '0%' '100%'
sleep 1
-for fstype in "ext4" "btrfs" "xfs"; do
+for fstype in "ext4" "xfs"; do
if [ "$fstype" == "ext4" ]; then
mkfs.${fstype} -F /dev/${dev}1
--- a/src/spdk/test/nvmf/filesystem/filesystem.sh 2017-04-13 06:05:24.000000000 +0200
+++ b/src/spdk/test/nvmf/filesystem/filesystem.sh 2017-10-10 21:33:26.258820759 +0200
@@ -49,7 +49,7 @@
timing_exit parted
sleep 1
- for fstype in "ext4" "btrfs" "xfs"; do
+ for fstype in "ext4" "xfs"; do
timing_enter $fstype
if [ $fstype = ext4 ]; then
force=-F
--- a/src/ceph.conf.twoosds 2017-09-26 18:27:07.000000000 +0200
+++ b/src/ceph.conf.twoosds 2017-10-10 21:34:13.160340506 +0200
@@ -72,8 +72,8 @@
; osd journal = /mnt/osd$id/journal
; osd journal size = 1000
osd journal = "/dev/disk/by-path/pci-0000:05:02.0-scsi-6:0:0:0"
- osd mkfs type = btrfs
- osd mount options btrfs = "flushoncommit,usertrans"
+ osd mkfs type = xfs
+ osd mount options xfs = "flushoncommit,usertrans"
; filestore max sync interval = 1
devs = "/dev/disk/by-path/pci-0000:05:01.0-scsi-2:0:0:0"
--- a/src/ceph-disk/tests/ceph-disk.sh 2017-09-26 18:27:07.000000000 +0200
+++ b/src/ceph-disk/tests/ceph-disk.sh 2017-10-10 21:35:26.386044372 +0200
@@ -74,8 +74,7 @@
kill_daemons $dir
if [ `uname` != FreeBSD ] && \
[ $(stat -f -c '%T' .) == "btrfs" ]; then
- rm -fr $dir/*/*db
- __teardown_btrfs $dir
+ true
fi
grep " $(pwd)/$dir/" < ${PROCDIR}/proc/mounts | while read mounted rest ; do
umount $mounted
--- a/qa/run_xfstests.sh 2017-09-26 18:27:07.000000000 +0200
+++ b/qa/run_xfstests.sh 2017-10-10 22:18:49.663141392 +0200
@@ -81,7 +81,7 @@
arg_count 1 $#
case "$1" in
- xfs|ext4|btrfs) return 0 ;;
+ xfs|ext4) return 0 ;;
*) return 1 ;;
esac
}
@@ -120,7 +120,7 @@
echo " -c or --count" >&2
echo " iteration count (1 or more)" >&2
echo " -f or --fs-type" >&2
- echo " one of: xfs, ext4, btrfs" >&2
+ echo " one of: xfs, ext4" >&2
echo " (default fs-type: xfs)" >&2
echo " -r or --randomize" >&2
echo " randomize test order" >&2
@@ -132,7 +132,7 @@
echo " name of file with list of tests to skip" >&2
echo " tests:" >&2
echo " list of test numbers, e.g.:" >&2
- echo " generic/001 xfs/008 shared/032 btrfs/009" >&2
+ echo " generic/001 xfs/008 shared/032" >&2
echo " or possibly an xfstests test group, e.g.:" >&2
echo " -g quick" >&2
echo " (default tests: -g auto)" >&2
@@ -235,7 +235,6 @@
case "${FSTYP}" in
xfs) options="-f" ;;
ext4) options="-F" ;;
- btrfs) options="-f" ;;
esac
"mkfs.${FSTYP}" ${options} "${dev}" ||
--- a/qa/run_xfstests-obsolete.sh 2017-09-26 18:27:07.000000000 +0200
+++ b/qa/run_xfstests-obsolete.sh 2017-10-10 22:19:27.027675395 +0200
@@ -125,7 +125,7 @@
arg_count 1 $#
case "$1" in
- xfs|ext4|btrfs) return 0 ;;
+ xfs|ext4) return 0 ;;
*) return 1 ;;
esac
}
@@ -157,7 +157,7 @@
echo " -c or --count" >&2
echo " iteration count (1 or more)" >&2
echo " -f or --fs-type" >&2
- echo " one of: xfs, ext4, btrfs" >&2
+ echo " one of: xfs, ext4" >&2
echo " (default fs-type: xfs)" >&2
echo " -s or --scratch-dev (REQUIRED)" >&2
echo " name of device used for scratch filesystem" >&2
@@ -262,7 +262,7 @@
# Filesystem-specific mkfs options--set if not supplied
export XFS_MKFS_OPTIONS="${XFS_MKFS_OPTIONS:--f -l su=65536}"
export EXT4_MKFS_OPTIONS="${EXT4_MKFS_OPTIONS:--F}"
-export BTRFS_MKFS_OPTION # No defaults
+unset BTRFS_MKFS_OPTION # No defaults
XFSTESTS_DIR="/var/lib/xfstests" # Where the tests live
@@ -348,7 +348,6 @@
case "${FSTYP}" in
xfs) options="${XFS_MKFS_OPTIONS}" ;;
ext4) options="${EXT4_MKFS_OPTIONS}" ;;
- btrfs) options="${BTRFS_MKFS_OPTIONS}" ;;
esac
"mkfs.${FSTYP}" ${options} "${dev}" ||

View file

@ -1,52 +0,0 @@
--- a/CMakeLists.txt 2018-05-29 14:04:02.000000000 +0200
+++ b/CMakeLists.txt 2018-06-04 13:41:55.684455580 +0200
@@ -49,7 +49,7 @@ endif(WITH_CCACHE)
option(WITH_MANPAGE "Build man pages." ON)
if(WITH_MANPAGE)
find_program(SPHINX_BUILD
- sphinx-build)
+ sphinx-build2)
if(NOT SPHINX_BUILD)
message(FATAL_ERROR "Can't find sphinx-build.")
endif(NOT SPHINX_BUILD)
--- a/src/tools/setup-virtualenv.sh 2018-05-29 14:04:02.000000000 +0200
+++ b/src/tools/setup-virtualenv.sh 2018-06-04 13:43:24.767175961 +0200
@@ -58,10 +58,10 @@ if [ -z "$DIR" ] ; then
fi
rm -fr $DIR
mkdir -p $DIR
-virtualenv --python $PYTHON_BINARY $DIR
+virtualenv2 --python $PYTHON_BINARY $DIR
. $DIR/bin/activate
-if pip --help | grep -q disable-pip-version-check; then
+if pip2 --help | grep -q disable-pip-version-check; then
DISABLE_PIP_VERSION_CHECK=--disable-pip-version-check
else
DISABLE_PIP_VERSION_CHECK=
@@ -69,12 +69,12 @@ fi
# older versions of pip will not install wrap_console scripts
# when using wheel packages
-pip $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install --upgrade 'pip >= 6.1'
+pip2 $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install --upgrade 'pip >= 6.1'
# workaround of https://github.com/pypa/setuptools/issues/1042
-pip $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install --upgrade "setuptools < 36"
+pip2 $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install --upgrade "setuptools < 36"
-if pip --help | grep -q disable-pip-version-check; then
+if pip2 --help | grep -q disable-pip-version-check; then
DISABLE_PIP_VERSION_CHECK=--disable-pip-version-check
else
DISABLE_PIP_VERSION_CHECK=
@@ -84,7 +84,7 @@ if test -d wheelhouse ; then
export NO_INDEX=--no-index
fi
-pip $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install $NO_INDEX --find-links=file://$(pwd)/wheelhouse 'tox >=2.9.1'
+pip2 $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install $NO_INDEX --find-links=file://$(pwd)/wheelhouse 'tox >=2.9.1'
if test -f requirements.txt ; then
- pip $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install $NO_INDEX --find-links=file://$(pwd)/wheelhouse -r requirements.txt
+ pip2 $DISABLE_PIP_VERSION_CHECK --log $DIR/log.txt install $NO_INDEX --find-links=file://$(pwd)/wheelhouse -r requirements.txt
fi

View file

@ -1,11 +0,0 @@
--- a/CMakeLists.txt 2017-09-26 18:27:07.000000000 +0200
+++ b/CMakeLists.txt 2017-10-06 14:10:11.032378659 +0200
@@ -63,7 +63,7 @@
option(WITH_MANPAGE "Build man pages." ON)
if(WITH_MANPAGE)
find_program(SPHINX_BUILD
- sphinx-build)
+ sphinx-build2)
if(NOT SPHINX_BUILD)
message(FATAL_ERROR "Can't find sphinx-build.")
endif(NOT SPHINX_BUILD)

View file

@ -1,10 +0,0 @@
--- a/src/common/util.cc 2018-05-29 14:04:02.000000000 +0200
+++ b/src/common/util.cc 2018-06-04 13:45:52.279495745 +0200
@@ -96,7 +96,6 @@ static bool os_release_parse(map<string,
static const map<string, string> kvm = {
{ "distro", "ID=" },
{ "distro_description", "PRETTY_NAME=" },
- { "distro_version", "VERSION_ID=" }
};
FILE *fp = fopen("/etc/os-release", "r");