core/linux-imx6-cubox-dt to 3.14.40-2; aufs fix

This commit is contained in:
moonman 2015-05-01 09:07:11 +00:00
parent ca3d6877a3
commit 47a6c97002
2 changed files with 51 additions and 3 deletions

View file

@ -0,0 +1,45 @@
diff -ruN a/fs/aufs/debug.c b/fs/aufs/debug.c
--- a/fs/aufs/debug.c 2015-05-01 08:27:35.903754731 +0000
+++ b/fs/aufs/debug.c 2015-05-01 08:30:16.164156908 +0000
@@ -168,7 +168,7 @@
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff -ruN a/fs/aufs/export.c b/fs/aufs/export.c
--- a/fs/aufs/export.c 2015-05-01 08:27:35.908755087 +0000
+++ b/fs/aufs/export.c 2015-05-01 08:34:17.023328460 +0000
@@ -243,7 +243,7 @@
dentry = d_find_alias(inode);
else {
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
if (!au_test_anon(d)
&& d->d_parent->d_inode->i_ino == dir_ino) {
diff -ruN a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
--- a/fs/aufs/hnotify.c 2015-05-01 08:27:35.914755514 +0000
+++ b/fs/aufs/hnotify.c 2015-05-01 08:32:32.574871642 +0000
@@ -211,7 +211,7 @@
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
@@ -378,7 +378,7 @@
dentry = NULL;
spin_lock(&parent->d_lock);
- list_for_each_entry(d, &parent->d_subdirs, d_u.d_child) {
+ list_for_each_entry(d, &parent->d_subdirs, d_child) {
/* AuDbg("%pd\n", d); */
spin_lock_nested(&d->d_lock, DENTRY_D_LOCK_NESTED);
dname = &d->d_name;

View file

@ -16,7 +16,7 @@ _srcname=linux-imx6-3.14-${_commit}
_kernelname=${pkgname#linux}
_basekernel=3.14
pkgver=${_basekernel}.40
pkgrel=1
pkgrel=2
cryptodev_commit=da730106c2558c8e0c8e1b1b1812d32ef9574ab7
arch=('armv7h')
url="http://www.kernel.org/"
@ -30,7 +30,8 @@ source=("linux-${_commit}::https://github.com/moonman/linux-imx6-3.14/archive/${
'config'
'001_cec.patch'
'002_cec.patch'
'003_cec.patch')
'003_cec.patch'
'0001-AUFS-fix-for-3.14.40.patch')
md5sums=('58101f6676d2a4cc8fb5513e63b41542'
'8fb4d3b7cc970351f3b5078b7893a107'
@ -39,7 +40,8 @@ md5sums=('58101f6676d2a4cc8fb5513e63b41542'
'5315fab8f481b34a2ed6abe5d27035ca'
'8bf79a580704e8dab806f58043720a90'
'6391a74bf1d451b74df6f189a25cf642'
'a70798b63a0e7c3fb50a57ea1815d353')
'a70798b63a0e7c3fb50a57ea1815d353'
'SKIP')
prepare() {
cd "${srcdir}/${_srcname}"
@ -56,6 +58,7 @@ msg2 "Applying aufs3 patches"
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
patch -Np1 -i ${srcdir}/0001-AUFS-fix-for-3.14.40.patch
msg2 "CEC patches"
patch -Np1 -i ${srcdir}/001_cec.patch