diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 8adbd49ed..3973ce23b 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -11,7 +11,7 @@ pkgbase=qt5-base
 pkgname=(qt5-base qt5-xcb-private-headers)
 _qtver=5.10.1
 pkgver=${_qtver/-/}
-pkgrel=5
+pkgrel=6
 arch=('x86_64')
 url='http://qt-project.org/'
 license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -20,7 +20,7 @@ depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontc
          'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu' 'pcre2'
          'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion')
 makedepends=('libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
-             'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-validation-layers')
+             'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers')
 optdepends=('qt5-svg: to use SVG icon themes'
             'postgresql-libs: PostgreSQL driver'
             'libmariadbclient: MariaDB driver'
@@ -35,12 +35,14 @@ source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submo
         revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
         qtbug-65478.patch
         qheaderview-restore.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=4a04eea4"
-        qtbug-66444.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=9395f35c")
+        qtbug-66444.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=9395f35c"
+        qtbug-66420.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=fa091640")
 sha256sums=('d8660e189caa5da5142d5894d328b61a4d3ee9750b76d61ad74e4eee8765a969'
             '7161ea5747500dc9666f8d185f4b8e538799fc0aef574e577277747100ac4763'
             'b2e8cb06c60be7de31a984c4cfc9ab85c9e2d08c1a3d93136f193735b43600c6'
             '3a1016cbf8c3c4676e6fc406756ffa5a151ffe09153dfc0fa7ed3c16945b0ae5'
-            '88766a7b73a03e1219800c8fdc56afbf23b15d16cc61c4d77547b1fd2404ea6e')
+            '88766a7b73a03e1219800c8fdc56afbf23b15d16cc61c4d77547b1fd2404ea6e'
+            '9e21893545f950132c9face1d502d32e746b2838d4e8c9075dcf3fa43981fcb2')
 
 prepare() {
   cd ${_pkgfqn}
@@ -68,6 +70,8 @@ prepare() {
   patch -p1 -i ../qheaderview-restore.patch
   # Fix QHeaderView regression https://bugreports.qt.io/browse/QTBUG-66444
   patch -p1 -i ../qtbug-66444.patch
+  # Fix white screen with Mesa 18 https://bugreports.qt.io/browse/QTBUG-66420
+  patch -p1 -i ../qtbug-66420.patch
 }
 
 build() {