mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed extra/gnome-builder
This commit is contained in:
parent
b1d786bd82
commit
47f8427e1e
2 changed files with 0 additions and 81 deletions
|
@ -1,28 +0,0 @@
|
|||
From c950a2fe53e8f3269b2cb969fca2c37397732216 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 12 Oct 2016 06:40:31 -0600
|
||||
Subject: [PATCH] ARM fix
|
||||
|
||||
---
|
||||
libide/highlighting/ide-highlight-index.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/libide/highlighting/ide-highlight-index.c b/libide/highlighting/ide-highlight-index.c
|
||||
index 1e90686..711bd89 100644
|
||||
--- a/libide/highlighting/ide-highlight-index.c
|
||||
+++ b/libide/highlighting/ide-highlight-index.c
|
||||
@@ -31,6 +31,11 @@ G_DEFINE_BOXED_TYPE (IdeHighlightIndex, ide_highlight_index,
|
||||
|
||||
EGG_DEFINE_COUNTER (instances, "IdeHighlightIndex", "Instances", "Number of indexes")
|
||||
|
||||
+#ifndef PAGE_SIZE
|
||||
+#include <unistd.h>
|
||||
+#define PAGE_SIZE sysconf(_SC_PAGESIZE)
|
||||
+#endif
|
||||
+
|
||||
struct _IdeHighlightIndex
|
||||
{
|
||||
volatile gint ref_count;
|
||||
--
|
||||
2.10.0
|
||||
|
|
@ -1,53 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix build on ARM
|
||||
|
||||
pkgname=gnome-builder
|
||||
pkgver=3.22.4
|
||||
pkgrel=2
|
||||
pkgdesc="An IDE for writing GNOME-based software"
|
||||
url="https://wiki.gnome.org/Apps/Builder"
|
||||
arch=(i686 x86_64)
|
||||
license=(GPL3)
|
||||
depends=(gtksourceview3 devhelp libgit2-glib gjs python-gobject clang desktop-file-utils
|
||||
ctags libpeas vte3 vala python-jedi autoconf-archive sysprof flatpak)
|
||||
makedepends=(intltool llvm gobject-introspection gtk-doc yelp-tools appstream-glib vala git
|
||||
mm-common)
|
||||
groups=(gnome-extra)
|
||||
_commit=054d54c8c9a6952e6480408e96decfe1955fd40d # tags/GNOME_BUILDER_3_22_4^0
|
||||
source=("git+https://git.gnome.org/browse/gnome-builder#commit=$_commit"
|
||||
'0001-ARM-fix.patch')
|
||||
sha256sums=('SKIP'
|
||||
'a92b25439576fe44565d3d7517be5f22d386806916fbc4abd1b3b304ed7b7ca2')
|
||||
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/^GNOME_BUILDER_//;s/_/./g;s/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
git apply ../0001-ARM-fix.patch
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
|
||||
--libexecdir=/usr/lib --enable-gtk-doc --enable-meson-templates
|
||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname
|
||||
make -k check || :
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
Loading…
Reference in a new issue