extra/libreoffice-still to 6.0.7-3

This commit is contained in:
Kevin Mihelich 2018-12-18 01:25:46 +00:00
parent 5a33a57bb8
commit 47f9a8baa5
2 changed files with 25 additions and 1 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=6.0.7.3
pkgver=6.0.7
pkgrel=2
pkgrel=3
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -66,6 +66,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.70.patch
libreoffice-poppler-0.71.patch
libreoffice-poppler-0.72.patch
emfio.patch
libreoffice-still.sh libreoffice-still.csh)
noextract=(boost_1_65_1.tar.bz2
@ -111,6 +112,7 @@ sha256sums=('b9633ccbd719fe6ad8142eceed3047eda346fca5d2962567283f350354b64c72'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
'ffe1698d3db3320a9213a459e7619f4962c9792a8b256ea0fe2b7e0af1df430a'
'dc8b5b0d1a4a1fed4f5cab048cd7ecd78630725458311bcbfe0a660c82357b49'
'8b4815788be087940750b775690b5890c4cf9e121f11006a72ccab834f212abb'
'52e90a5a3d8d5b626caa51675b601aba508463c2b9caa98d07cfa35220fc0b22'
'531de4133cb6ff5c841e4251fdafe69521ccd195f5933eb8c113291d3eff183a')
@ -152,6 +154,8 @@ prepare() {
patch -Np1 -i ../poppler-0.70.patch
# fix build with poppler 0.71
patch -p1 -i ../libreoffice-poppler-0.71.patch
# fix build with poppler 0.72
patch -p1 -i ../libreoffice-poppler-0.72.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do

View file

@ -0,0 +1,20 @@
--- libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2018-12-14 20:04:01.633697240 +0000
+++ libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2018-12-14 20:04:18.020410653 +0000
@@ -555,7 +555,7 @@
LinkAction* pAction = link->getAction();
if (pAction && pAction->getKind() == actionURI)
{
- const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
std::vector<char> aEsc( lcl_escapeLineFeeds(pURI) );
@@ -757,7 +757,7 @@
aFont = it->second;
- std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.getCString()) );
+ std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.c_str()) );
printf( " %d %d %d %d %f %d %s",
aFont.isEmbedded,
aFont.isBold,