community/mysql-workbench to 6.3.6-1

This commit is contained in:
Kevin Mihelich 2015-12-15 18:22:44 +00:00
parent 9cefea94f9
commit 48269725ef
2 changed files with 13 additions and 37 deletions

View file

@ -1,25 +0,0 @@
diff --git a/library/forms/swig/mforms.i b/library/forms/swig/mforms.i
index 3f5104f..cdcca30 100644
--- a/library/forms/swig/mforms.i
+++ b/library/forms/swig/mforms.i
@@ -533,7 +533,7 @@ inline boost::function<void (mforms::TextEntryAction)> pycall_void_entryaction_f
#define SWIG_ADD_SIGNAL_BOOL_INT_CALLBACK(method, signal)\
void add_##method(PyObject *callback) { signal->connect(pycall_bool_int_fun(callback)); }\
- bool call_##method(int i) { return (*signal)(i); }
+ bool call_##method(int i) { return *( (*signal)(i) ); }
#define SWIG_ADD_SIGNAL_VOID_ENTRYACTION_CALLBACK(method, signal)\
void add_##method(PyObject *callback) { signal->connect(pycall_void_entryaction_fun(callback)); }
diff --git a/library/forms/view.cpp b/library/forms/view.cpp
index ec49389..67ff486 100644
--- a/library/forms/view.cpp
+++ b/library/forms/view.cpp
@@ -512,7 +512,7 @@ DropPosition View::get_drop_position()
bool View::mouse_leave()
{
if (_signal_mouse_leave.num_slots() > 0)
- return _signal_mouse_leave();
+ return *_signal_mouse_leave();
return false;
}

View file

@ -9,8 +9,8 @@
# - use our cxxflags plus -fsigned-char
pkgname=mysql-workbench
pkgver=6.3.5
pkgrel=2
pkgver=6.3.6
pkgrel=1
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
arch=('i686' 'x86_64')
url='https://www.mysql.com/products/workbench/'
@ -32,17 +32,15 @@ source=("http://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-
'0007-mysql-workbench-no-set-gtid-purged.patch'
'0009-mysql-workbench-gnome-keyring.patch'
'0010-mysql-workbench-object.patch'
'0012-mysql-workbench-cpp11.patch'
'0013-mysql-workbench-no-json.patch'
'arch_linux_profile.xml')
sha256sums=('7a63d05cfb5dec60ece3e73869eb61afc7125e4a8a18e53d760cd7ca0479dc84'
sha256sums=('c51fce1a3fd9425dd9adf4d16e24e84f92e2f8374b43a956f580fd84d03afe62'
'SKIP'
'9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7'
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
'b49d4ea352d2c2013b9c5834668c44521a0a2c5f9c7e3fe746ad94ce0d2bb865'
'9c2ae2fe7a4f59502bdcf591a07353c350b0ba29c3935c8242d97848cc0e50d3'
'2bc79f935cd5059409d32aa64832b7aa2c49ba533cc93d40a063bcbfe01a4485'
'f76ffa7343b758ac0de2448e948c533e8623a0e426d293602ab7261c853ec684'
'663b6eed3715988e16a695f5810bdfb7e76aaeb28baaf4b11b2a73ee2bcb403d'
'28724c4b4cec29ce19aada08279df1b086381cd788fef7ae07c1860f7d17af7e')
@ -62,13 +60,17 @@ prepare() {
# fix cannot call member function without object
patch -Np1 < "${srcdir}"/0010-mysql-workbench-object.patch
# fix for C++11
# http://bugs.mysql.com/bug.php?id=78668
patch -Np1 < "${srcdir}"/0012-mysql-workbench-cpp11.patch
# we have no JSON, probably missing in mariadb
patch -Np1 < "${srcdir}"/0013-mysql-workbench-no-json.patch
# make cmake happy with mariadb
sed -i '/^find_package(MySQL /c find_package(MySQL REQUIRED)' \
CMakeLists.txt
# we need python 2.x
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
CMakeLists.txt
# fix the swig workaround
sed -i '/SWIG_VERSION/s/0x030008/0x030006/' \
library/forms/mforms/textbox.h \
@ -77,10 +79,9 @@ prepare() {
# fix GDAL
sed -i '/#include/s|gdal/||' \
backend/wbpublic/grtui/geom_draw_box.h \
backend/wbpublic/grt/spatial_handler.h
backend/wbpublic/grt/spatial_handler.h \
backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
# allow to stick icon to the gnome dash
echo "StartupWMClass=mysql-workbench-bin" >> mysql-workbench.desktop.in
# put antlr into place
install -D ${srcdir}/antlr-3.4-complete.jar ${srcdir}/linux-res/bin/antlr-3.4-complete.jar